Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Strange: Bluetooth and Webcam not working after repair

07 Apr 2010   #1

Windows 7 Ultimate x86
Strange: Bluetooth and Webcam not working after repair

Dell XPS M1330 Laptop,
Running Windows 7 32-bit

Description of the Problem:

My Wi-Fi switch had a loose connection, and since my laptop was under warranty I got them to replace the entire bottom base for me. Immediately after the replacement, I started getting the error "USB Device Not recognized" [Attachment 1].

There were 2 unknown devices in the Device Manager [Attachment 2]. This was not present before. All my drivers (except card reader and sound) were automatically installed with Windows Update, so I tried to update the driver. However it was not getting installed [Attachment 3].

At this point of time I noticed that my bluetooth wasn't working, so I then proceeded to try and install the drivers manually (Dell driver package R140135 Bluetooth+EDR for Vista x86). However, it was asking me to switch on the radio, even though it was already on [Attachment 4]. The bluetooth light was on on my panel, and the wi-fi switch was also turned on.

Now I had a feeling that somehow the technician who replaced the bottom base had messed up the connections, so I checked the BIOS, where I noticed that Bluetooth and Wireless were both Enabled.

However, when I ran the Dell Diagnostics package by booting it from a USB drive, and I got this error:
Now this, being entirely outside of the operating system environment, indicated that it was not a driver issue but a hardware one.

Now I have also noticed that my Webcam is not being detected.
I'm beginning to believe that somewhere there is a cable that connects both the Bluetooth Radio (which I think is behind the screen) as well as the Webcam (which I know is in the screen) to the motherboard, and this cable is loose.

The Real Problem:

I called Dell customer care, and they are trying to convince me that it is a driver problem, since my Wi-Fi is working. I told them that it was strange that a driver problem occurred immediately after their technician replaced the bottom base, and they told me it was a coincidence.
I told them that there is an error message in the diagnostics. They said it is unrelated.

Additional Comments:

- During the bottom base replacement, the BIOS cell had been removed, and the BIOS reset.
- In case anyone is wondering, all devices were working PERFECTLY just before the bottom base replacement process.
- I have 2 USB ports on my laptop and both are working fine (tested with pen drive and mouse).

Request for help from you:

Please tell me whether I'm right in thinking it's a hardware fault and that the connections have been inadvertently messed up.
If it is not a hardware fault and it is indeed a driver issue, please tell me how I can solve it.

I would be much obliged for any response.


Attached Thumbnails
Strange: Bluetooth and Webcam not working after repair-device2.jpg  
Attached Images
Strange: Bluetooth and Webcam not working after repair-usb-device.jpg Strange: Bluetooth and Webcam not working after repair-install.jpg Strange: Bluetooth and Webcam not working after repair-driverinst.jpg Strange: Bluetooth and Webcam not working after repair-not-connected-2-.jpg 
My System SpecsSystem Spec
08 Apr 2010   #2
WalkerA WinTeam

Windows 7 Home Premium (64-bit) *** Windows XP SP3 (32-bit), OSX 10.6

Hi CraXJaX,

I don't have a solution for you, but I'll bump your thread since it looks like you put a lot of time into it :/


Windows Outreach Team
My System SpecsSystem Spec
23 Apr 2010   #3

Windows Vista Home Basic


I am having a similar issue on my Dell Studio One 1909, and Dell tech support is sending out a new LCD, new webcam and cable, and having a tech come out to replace it. What started my troubleshooting was that my webcam light is blinking on and off, and so I booted up the diagnostics.

While the diagnostics partition was booting, it stopped on USBTM.MDM and gave me the error: "Device Initialization Failure. Error Code: 5D00:0009. Msg: UUTUSBTM - DEVICE_INITIALIZATION_FAILURE. User must reattach unit on ROOT HUB port 6 and re-start test."

I updated the BIOS to A07, and updated the drivers. Still, nothing fixed it. Still blinking. Called Dell support at 1-800-624-9896, and although it is taking a while, he is replacing hardware at least. I would be persistent and tell them other folks have had this problem.

I will try to remember to come back here after the hardware is replaced and let you know how things went. Good luck with your issue.

My System SpecsSystem Spec


 Strange: Bluetooth and Webcam not working after repair

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
CSR Bluetooth Chip -- Bluetooth settings not working
I bought a bluetooth dongle which for some reason isn't working in Windows 7. It shows up in Devices and Printers as "CSR Bluetooth Chip" and when I right click on it and select bluetooth settings, nothing happens. It shows up under Bluetooth Radios in device manager. As a test I tried using it in...
Hardware & Devices
strange Bluetooth issues with a Nexiq usb link
Hello, I hope I'm posting in the right spot... I've recently got a Panasonic CF-C1 win7 pro 64bit. It had built in Bluetooth and when hooking upto my Nexiq USB link on J-1939 it won't lock/communicate on J-1708 it's just fine no issues faster than it used to be on my CF-30 which also had built...
Hardware & Devices
My Webcam Is not working
I upgraded from Win7 Home Premium 32bit to Win7 Ultimate and now my webcam is just shows black screen... BTW im using ASUS laptop, so usually the green light on my laptop turns on, but now its not on.. :sarc: I'm not sure, but i think its the problem with drivers
Startup Repair not working??? cant repair automatically
Hi Guys :D I'm new here the problem i have with my laptop is that it says window 7 cant repair automatically . It didn't come with any disks to fix windows what can i do Please help
General Discussion
webcam not working
I have a vaio vgn-fz4104. It orginally came with vista, I upgraded to windows 7, and now my webcam wont work. I tried re downloading the driver. what can i do?
Hardware & Devices
Webcam not working!
I had used Windows Vista previously (hated the thing) so finally I switched over to Windows 7. It's great. But now my webcam has stopped working. I have a Sony Vaio computer Model PCG-394L and the specification (idk what to call it >.>) is VGN-FZ20E. Also, the memory card slots have stopped working...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:42.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App