Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Devices and Printers fails to load.

07 Apr 2010   #1

 
 
Devices and Printers fails to load.

This is going to be long and drawn out, but this is killing me and maybe you can help me.

I work in a business environment. I have network and local machine administrator rights. Meaning, I have full control of everything. I ran into a problem a number of months ago where my Devices and Printers screen would appear, but then it would never load the devices. here is a screenshot of what happens.

Now I searched the net for some answers and I found an article that says that people have this problem when the Bluetooth service is not running. Well I started mine and the same thing happens. I logged into a different user i created on the same machine, and initially the Window comes up fine, but later on it does the same thing.

This happens both on a Windows 7 32 bit setup and a Win 7 64 bit setup.

Well, I finally found the source of the problem, at least as far as I'm concerned. We use McAfee Encryption for PC and Encryption for Files and Folders. It's only when I install the latter of the two that the issue occurs. The latter of the two btw, is a policy that forces encryption on any USB storage device inserted to the PC. So you are thinking "Great, report it to McAfee." Problem is, I did, and they tried to replicate the situation and they cannot. We ran down the list of options that we both had running and they were and are identical.

So either at this point I'm thinking one of the two is occurring.

1. McAfee has not ran into this problem and my reporting it they may find a solution.

2. There is some easy thing I am missing that is causing this to occur, since they report they cannot replicate it.


Was wondering if any of you guys got some ideas, thoughts, or rants are welcomed.



Attached Thumbnails
Devices and Printers fails to load.-capture.png  
My System SpecsSystem Spec
.

07 Apr 2010   #2

 
 

no takers?
My System SpecsSystem Spec
07 Apr 2010   #3

W7 Ult. x64 | OS X
 
 

To my feeble mind it sounds like a conflict between the software and the printer drivers. Then again, I have no clue
My System SpecsSystem Spec
.


07 Apr 2010   #4

 
 

Quote   Quote: Originally Posted by notsograymatter View Post
To my feeble mind it sounds like a conflict between the software and the printer drivers. Then again, I have no clue
I'm wondering that too. I just emailed McAfee and asked if the rep who could not replicate the issue if he had any printers configured.
My System SpecsSystem Spec
Reply

 Devices and Printers fails to load.




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:39 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33