Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows suddenly doesn't detect USB, Ethernet, Sound!

10 Apr 2010   #1

Windows 7 (x64)
 
 
Windows suddenly doesn't detect USB, Ethernet, Sound!

Hi,
yesterday night the computer was working fine and I didn't download anything
today morning when I opened the computer I found that it didn't detect any of my USB devices (including the mouse) nor the Ethernet cable nor the sound
I tried to do "sfc /scannow" but still nothing is solved
tried on safe mode but the devices still undetected there
when I tried to use windows repair the devices worked fine but I found that all restore points are gone and the devices stopped working again when I booted windows normaly
Now am scanning the computer for viruses but till mow nothing is detected and u doubt that there is any viruses
does anyone knows why that happened and how can I solve it?

I am on Windows 7 x64

thanks in advance

My System SpecsSystem Spec
.

10 Apr 2010   #2

Windows 7 Enterprise x64
 
 

Wow, that's odd indeed! Do you see them in Device Manager? If not, try and do a search for new hardware. Also, if your familiar with navigating the BIOS, make sure those devices didn't get disabled somehow. You may even want to try unplugging those devices, and adding them back to the system one at a time.
My System SpecsSystem Spec
10 Apr 2010   #3

Windows 7 (x64)
 
 

I opened the device manager and
1. All network adapters has yellow triangle
2. Sound -> Realtek high difinition audio has yellow triangle
3. All USB controllers has yellow triangle

should I reinstall the drivers or there is another way to fix those ?
My System SpecsSystem Spec
.


10 Apr 2010   #4

Windows 7 Ultimate 32 bit
 
 

Though I do not think this is the cause of your problem, run a scan of your system using Malwarebytes.
My System SpecsSystem Spec
10 Apr 2010   #5

Windows 7 Enterprise x64
 
 

Quote   Quote: Originally Posted by TatesMan View Post
I opened the device manager and
1. All network adapters has yellow triangle
2. Sound -> Realtek high difinition audio has yellow triangle
3. All USB controllers has yellow triangle

should I reinstall the drivers or there is another way to fix those ?
Yes, try to reinstall the drivers with the automatic option (search your computer). Perhaps they will reinstall, and you'll be all set. I have no idea what caused this....yet.

If your system can't find the right drivers, then try and run windows update manually to see if they download once again.
My System SpecsSystem Spec
10 Apr 2010   #6

Windows 7 (x64)
 
 

Ok automatic install drivers said I already have the driver installed
reinstalling the drivers didn't fix anything
did maleware bytes scan, and 0 objects are infected
thanks for ur help but is there any other fixes?

And btw I can't connect to Internet since network adapters are disabled
My System SpecsSystem Spec
10 Apr 2010   #7

Windows 7 Enterprise x64
 
 

Quote   Quote: Originally Posted by TatesMan View Post
Ok automatic install drivers said I already have the driver installed
reinstalling the drivers didn't fix anything
did maleware bytes scan, and 0 objects are infected
thanks for ur help but is there any other fixes?

And btw I can't connect to Internet since network adapters are disabled
My next step would be to try and uninstall one of the devices [in Device Manager] and then reboot to allow Windows to reinstall the device that way. If that works, then repeat the process with the remaining devices one at a time.
My System SpecsSystem Spec
10 Apr 2010   #8

Windows 7 (x64)
 
 

Ok thanks a lot for ur time I managed to fix it
I remembered that I installed a libusb for the iPhone but I guess it was a 32 bit verdin not 64 which made my computer act the way I said after turning it off and on

THANKS A LOT again for ur time and help

Peace...
My System SpecsSystem Spec
10 Apr 2010   #9

Windows 7 Enterprise x64
 
 

That's what we're here for. Glad you got it figured out. Enjoy the rest of your SevenForums experience. I'll report this as solved.
My System SpecsSystem Spec
10 Apr 2010   #10

Windows 7 (x64)
 
 

Yeah do that, and thanks again
My System SpecsSystem Spec
Reply

 Windows suddenly doesn't detect USB, Ethernet, Sound!




Thread Tools



Similar help and support threads for2: Windows suddenly doesn't detect USB, Ethernet, Sound!
Thread Forum
Solved Computer Doesn't Detect Ethernet Cable Network & Sharing
Computer doesn't detect wired ethernet connection Network & Sharing
Windows 7 doesn't detect/recognize Ethernet Adapter Network & Sharing
Solved MB doesn't detect 2nd HDD while Windows does Hardware & Devices
windows seven doesn't detect my keyboard Hardware & Devices
Windows doesn't detect any audio devices: no sound Sound & Audio
Windows 7 doesn't detect USB port Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:16 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33