Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows suddenly doesn't detect USB, Ethernet, Sound!

10 Apr 2010   #1
TatesMan

Windows 7 (x64)
 
 
Windows suddenly doesn't detect USB, Ethernet, Sound!

Hi,
yesterday night the computer was working fine and I didn't download anything
today morning when I opened the computer I found that it didn't detect any of my USB devices (including the mouse) nor the Ethernet cable nor the sound
I tried to do "sfc /scannow" but still nothing is solved
tried on safe mode but the devices still undetected there
when I tried to use windows repair the devices worked fine but I found that all restore points are gone and the devices stopped working again when I booted windows normaly
Now am scanning the computer for viruses but till mow nothing is detected and u doubt that there is any viruses
does anyone knows why that happened and how can I solve it?

I am on Windows 7 x64

thanks in advance


My System SpecsSystem Spec
.

10 Apr 2010   #2
MadMaxData

Windows 7 Enterprise x64
 
 

Wow, that's odd indeed! Do you see them in Device Manager? If not, try and do a search for new hardware. Also, if your familiar with navigating the BIOS, make sure those devices didn't get disabled somehow. You may even want to try unplugging those devices, and adding them back to the system one at a time.
My System SpecsSystem Spec
10 Apr 2010   #3
TatesMan

Windows 7 (x64)
 
 

I opened the device manager and
1. All network adapters has yellow triangle
2. Sound -> Realtek high difinition audio has yellow triangle
3. All USB controllers has yellow triangle

should I reinstall the drivers or there is another way to fix those ?
My System SpecsSystem Spec
.


10 Apr 2010   #4
CarlTR6

Windows 7 Ultimate 32 bit
 
 

Though I do not think this is the cause of your problem, run a scan of your system using Malwarebytes.
My System SpecsSystem Spec
10 Apr 2010   #5
MadMaxData

Windows 7 Enterprise x64
 
 

Quote   Quote: Originally Posted by TatesMan View Post
I opened the device manager and
1. All network adapters has yellow triangle
2. Sound -> Realtek high difinition audio has yellow triangle
3. All USB controllers has yellow triangle

should I reinstall the drivers or there is another way to fix those ?
Yes, try to reinstall the drivers with the automatic option (search your computer). Perhaps they will reinstall, and you'll be all set. I have no idea what caused this....yet.

If your system can't find the right drivers, then try and run windows update manually to see if they download once again.
My System SpecsSystem Spec
10 Apr 2010   #6
TatesMan

Windows 7 (x64)
 
 

Ok automatic install drivers said I already have the driver installed
reinstalling the drivers didn't fix anything
did maleware bytes scan, and 0 objects are infected
thanks for ur help but is there any other fixes?

And btw I can't connect to Internet since network adapters are disabled
My System SpecsSystem Spec
10 Apr 2010   #7
MadMaxData

Windows 7 Enterprise x64
 
 

Quote   Quote: Originally Posted by TatesMan View Post
Ok automatic install drivers said I already have the driver installed
reinstalling the drivers didn't fix anything
did maleware bytes scan, and 0 objects are infected
thanks for ur help but is there any other fixes?

And btw I can't connect to Internet since network adapters are disabled
My next step would be to try and uninstall one of the devices [in Device Manager] and then reboot to allow Windows to reinstall the device that way. If that works, then repeat the process with the remaining devices one at a time.
My System SpecsSystem Spec
10 Apr 2010   #8
TatesMan

Windows 7 (x64)
 
 

Ok thanks a lot for ur time I managed to fix it
I remembered that I installed a libusb for the iPhone but I guess it was a 32 bit verdin not 64 which made my computer act the way I said after turning it off and on

THANKS A LOT again for ur time and help

Peace...
My System SpecsSystem Spec
10 Apr 2010   #9
MadMaxData

Windows 7 Enterprise x64
 
 

That's what we're here for. Glad you got it figured out. Enjoy the rest of your SevenForums experience. I'll report this as solved.
My System SpecsSystem Spec
10 Apr 2010   #10
TatesMan

Windows 7 (x64)
 
 

Yeah do that, and thanks again
My System SpecsSystem Spec
Reply

 Windows suddenly doesn't detect USB, Ethernet, Sound!




Thread Tools





Similar help and support threads
Thread Forum
Windows Server 2008 Won't Detect My Ethernet Controller
Windows Server 2008 won't detect my Ethernet Controller: Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.20). I am running Aspire 7750. I would like to try a different Lan driver, if anybody can suggest a substitute. DXDIAG: Operating System: Windows 7 Home Premium...
Drivers
Computer Doesn't Detect Ethernet Cable
I recently moved into the dorms of my college and tried connecting my laptop to the internet using an ethernet cable. It worked, so I decided to try and play Xbox Live through the use of the ethernet cable and it did not work. After messing around with it and failing to get it to work for my Xbox...
Network & Sharing
Computer doesn't detect wired ethernet connection
I've been having internet connection problems for the last couple weeks, i moved my entire setup closer to my router, and i still had bad internet. I searched around my house a little bit and found ethernet cables, i connected them and everything but, windows doesn't seem to detect them (well it...
Network & Sharing
Windows 7 doesn't detect/recognize Ethernet Adapter
I upgraded a computer to Windows 7 because it had a corrupt Windows XP install and I wanted to save myself the hassle of reinstalling Windows XP. I am now having a problem getting the PC to connect to the internet. It says that no Ethernet Driver is installed and it doesn't even detect an...
Network & Sharing
MB doesn't detect 2nd HDD while Windows does
Never had this problem before with a motherboard not detecting a drive. Is it a BIOS issue that will be resolved once updated? Check my spec page on user profile for my system info if this helps provide more info. It is running v4.1 and I can upgrade that to 4.3. What happens is it will not...
Hardware & Devices
Windows doesn't detect any audio devices: no sound
Hello, my name is Conan. I have installed Windows 7(Ultimate, 64-bits) in 2009, my previous os was Windows XP(32-bit). Although I am really happy with W7 there's something which is a big turn-off. The sound, that is, it hasn't worked on W7 ever since I installed it. It's not the devices that...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:52.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App