Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: HIGH speed USB hub running at FULL speed.H

14 Apr 2010   #1
wr332

windows 7
 
 
HIGH speed USB hub running at FULL speed.H

after dealing with PCI usb hub. i went and got external usb hubs and yes it worked on windows 7, but only FULL speed, my cam went from fast to laggie, iphone connect to usb hub had a message " it can perform faster if connect to a high speed port" , i check under device manager and it says " the device is operating on FULL SPEED "

i have check online, full speed = 12 mb/s , high speed = 480 mb/s

are there any ways to change this?


My System SpecsSystem Spec
.
14 Apr 2010   #2
CommonTater

XP Pro SP3 X86 / Win7 Pro X86
 
 

Quote   Quote: Originally Posted by wr332 View Post
after dealing with PCI usb hub. i went and got external usb hubs and yes it worked on windows 7, but only FULL speed, my cam went from fast to laggie, iphone connect to usb hub had a message " it can perform faster if connect to a high speed port" , i check under device manager and it says " the device is operating on FULL SPEED "

i have check online, full speed = 12 mb/s , high speed = 480 mb/s

are there any ways to change this?
First question... Are they high speed hubs?
I have an older 4 port Dlink here that's never run 480... looking into the chip on the internal circuit board, it turns out to be a 12mbps chip... you can slow them down, but you can't scare them into running faster.
My System SpecsSystem Spec
14 Apr 2010   #3
not so gray matter

W7 Ult. x64 | OS X
 
 

Most hubs can't run high speed anyway. They're connected to another usb hub whose maximum speed is high speed. This means that they can't possible go high sped because there's anywhere from 2-7 devices plugged into one port. Now, if you have a PCI USB Hub then you've got a real high speed hub.
My System SpecsSystem Spec
.

18 Jun 2010   #4
Faladu

Windows 7 Ultimate Retail Box (64-bit installed) + Service Pack 1
 
 

My first question, why did you go to a PCI USB Hub in the first place and did you leave it behind (remove it), like your message suggests?

What is the new hub you bought plugged into, and what is the hub itself rated as? USB 2.0?

Devices have to match USB port speed also to run at that speed.
I too have old stuff with 1.1 ports, including G11 keyboard; for running a keyboard, microphone, or mouse, 1.x is just fine, but for external storage, yes you want 2.0 or even firewire.

I dug a little deeper, and web cams will need a higher speed USB, definitely.
Did you just recently add more USB devices + the hub?
In that case you are using up bandwidth (taking it away from camera) and if it's too much then yes you will start to take a performance hit, and if you are using 1.1 USB instead of 2.0 now, you are definitely taking a step backwards and have to get back to 2.0 or you web cam is doomed to stay a laggy beast.
My System SpecsSystem Spec
Reply

 HIGH speed USB hub running at FULL speed.H




Thread Tools




Similar help and support threads
Thread Forum
Fans running full speed
Hi Switched on the pc this morning Fans running at full speed ... switched off and restarted two or three times with the same effect. Looking inside the pc the cpu was clean and virtually free of dust and connections were fine.I started the pc again and ran pc wizard to check temperatures (quad...
Hardware & Devices
got new Ram... not sure if its running at full speed...
ok i got new ram today Vengeance® — 16GB Dual Channel DDR3 Memory Kit (CMZ16GX3M4A1600C9B) Memory Type: ...
General Discussion
How to know if CPU is running at full speed ?
Hey guys, I'm a 3D artist, and I'm currently rendering out a whole load of frames. I'm using a reasonable, Sony Vaio laptop for the task, which has an Intel i7-720QM, however I'd like to know what CPU speed it's currently operating at. I know that it says it runs at 1.6Ghz as standard but then...
Hardware & Devices
Fan running at Full Speed, CPU Usage at 100%
In Task Manager, I see that my laptop has a total of 2038 MB of physical memory, but 0 of it is free. The only thing that I am running is Firefox with 4 tabs, Spybot, my touchpad program for my mouse and Open Office QuickStarter. My CPU usage is always above 80% and the fan runs at max nearly all...
Performance & Maintenance
Memory not running at full speed
It is running at 1300MHz constantly and it is suppose to run at 1600MHz, any reason why? Specs at bottom.
Hardware & Devices
Vid card not running at full x16 speed.
So here's my dilemma: After this problem with Bsods and such my video card only wants to run at x4 speeds. It was running at x16 speeds when I first installed windows. Now for some reason it only wants to stay at x4 sometimes it will go to x8 after a reboot. What are you guys' thoughts? I...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 00:41.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App