Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Serious issue with USB drivers and possibly Ethernet?


15 Apr 2010   #1

Vista 7 Professional
 
 
Serious issue with USB drivers and possibly Ethernet?

It seems you guys have your heads screwed on the right way so I bring you an issue that came up today.

I just got home from work and both my keyboard and mouse aren't working. I hard reset the computer and plugged in an old PS/2 keyboard to test and it worked fine.

I've navigated to the Device Manager and all of the USB ports (labeled Intel(R) ICH10 Family USB Universal Host Controller - 3A3A through 3A39) have a yellow exclamation mark on them. 3A37, however, does not. Also, USB Root Hub seems to be fine.

I've also noticed that my Realtek RTL8168C(P)/8111C(P) Family PCI-E Gigabit Ethernet NIC #1 and #2 are both listed with a yellow exclamation mark.

I checked recently installed updates through Windows Update and there are several listed:
KB978601
KB979309
KB981332
KB890830 (the only non-Security Update for Windows 7 for x64-based Systems, being a Windows Malicious Software Removal Tool itself)
KB980232
KB979683

I did a System Restore back to early yesterday before those updates were installed. When I checked update history, those are still showing. I also tried uninstalling the Intel USB drivers and when they tried to reinstall, the computer locked up.

So, under the assumption that none of the about was vague in any way, has anyone else been having an issue? Do you think it's Windows Update related?

Not sure where to go from here...

My System SpecsSystem Spec
.

15 Apr 2010   #2

W7 Ult. x64 | OS X
 
 

I just installed the latest updates and had no issues. Sorry.
My System SpecsSystem Spec
15 Apr 2010   #3

Vista 7 Professional
 
 

I haven't seen anyone else complaining so I'm going to assume it's probably not a Windows Update issue.

I checked the event log and I'm seeing a ton of errors and warnings for LibUSB-Win32. I installed that the other day while working on jailbreaking 3.1.3 on my iPhone and I'm thinking after my computer restarted because of the Windows Update, it's started to conflict with my USB devices across the system. I've uninstalled it and I'm gonna see where it leads me...
My System SpecsSystem Spec
.


15 Apr 2010   #4

Vista 7 Professional
 
 

The USB ports seem to be in working order now. LibUSB-Win32 was most likely the culprit. Take note that it apparently will reek havoc on your box if you're running 7, haha.

Unfortunately, I'm still getting a Code 10 with the Ethernet and a resource conflict error message in the Event Viewer.

Edit: Ethernet is now running after closing Vidalia and any Tor process before deleting and re-installing Ethernet drivers.

Sorry about creating a thread and solving it on my own. Suppose it was a waste?
My System SpecsSystem Spec
Reply

 Serious issue with USB drivers and possibly Ethernet?




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:10 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33