Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: device & printer panel does not load?

27 Sep 2010   #21

Windows 7 Home Premium 64
Nothing seems to be working for me

Hello folks,

new to the forum and fairly new to Win7, so please be patient with me

I have this very problem on my Dell XPS8100 with Win7 Home Premium, but ONLY on one of the regular user accounts. The admin, guest and another user account all loads "Devices & Printer" regularly. On the one user account where it does not work, I get the usual green progress bar going on forever and the window is never populated with Devices and Printers. As others have mentioned, the printer and all other devices (iPod, camera etc.) works fine with ALL accounts.

I have been searching the web for several weeks and I believe I have tried all the solutions that have worked for many, but not for me:

- I activated the bluetooth service
- I played with turning on/off the spooler service
- I re-registered the I8 DLLs
- I run "sfc /scannow"
- I run check disk

What drives me crazy is that I can't figure out what is the difference between the user account not working and ALL others where the "Devices & Printer" panel loads perfectly!!!

Is there anything else that could be the cause of this? Short of a repair install, I do not know what else to do.

I have been using Windows since 3.1 (and DOS before that, yeah, I'm getting old ), I have another computer running XP, one running Vista and all of them dual boot with Linux and this is the one thing that is eluding ANY attempt to fix it. Very frustrating. Before my ego is permanently damaged, would please somebody out there help me out

Thanks in advance.

My System SpecsSystem Spec
29 Oct 2010   #22

Windows 8.1 x64 Enterprise

it finally worked for me too,
after disabling the bluetooth and the print spooler, i have also kill the "explorer" process from task manager, restarted it (File> New Process > type explorer and hit enter) and started both bluetooth and print spooler services, everything works just fine right now

thanks guys for your tips
My System SpecsSystem Spec
08 Nov 2010   #23

Windows 7 Home Premium Edition (64-bit)

Thanks so much-this fixed my issues!
My System SpecsSystem Spec

07 Dec 2010   #24

Windows 7 Ultimate 64/32

Thanks - this worked for me too. My BT service was set to disabled (not sure why?) but setting to auto fixed the issues immediately.
(Fujitsu S7110, Win7 Ultimate 32)
My System SpecsSystem Spec
04 Feb 2011   #25
Manbreed AW

Windows 7 Ultimate 32 bit

Can anybody help me and make It clearer ,step by step ,on how to check the BT services to see how to enable it and ,also step by step instructions to get my Print Spooler back on line without knocking my Device printers offline. Everytime I turn on the Printer Spooler Services it goes back to loading slow and, finally giving me a blank page.I did what was instructed on this Forum and in going to Task manager and turning off the Explorer processes I lost my desktop completely and had to use System Restore to put the OS back online. Being that Im learning slowly about this OS,for the last 6 months,this problem happenned when I tried to put some HP Printer files in for my OS and it messed up my OS System and I had to turn off the spooler services to uninstall the files because the would not uninstall at all even from the HP Website. So in me getting the correct information through Microsoft to fix my Spooler Services so it wont interfere with my Device Printers would be a great help......
My System SpecsSystem Spec
05 Feb 2011   #26

Windows 7 Ultimate 64/32

Start> "compmgmt.msc"
Services and Applications > Services > Bluetooth Support Service.
rt-click> Properties
set Start Type to Manual or Automatic.
My System SpecsSystem Spec
05 Feb 2011   #27
Manbreed AW

Windows 7 Ultimate 32 bit

CGO Hello; I already set the Bluetooth Services eariler by reading the Forum and when I restarted the Print Spooler Services the Device Printers still got knocked offline and wouldn't load so I had to go back in and turn yhose services off to put the Device printers back online.Still have the problem. I understand that Microsoft created a Hotfix for a kernel problem in the registry that Win 7 and 2004 Server users have been experincing and I applied for the Hotfix but when I try to download it Ikeep getting a error message code 40 so some advice would be helpful in eliminating these problems in Win 7 once and for all.And thanks for your help and in trying to assist me in becoming a better Computer Geek.....Peace my Friend.Manbreed
My System SpecsSystem Spec
06 Feb 2011   #28

Windows 7 Ultimate 64/32

Print spooler reboots can be related to printer drivers.. try uninstalling drivers -- particularly any from HP. Other than that, just try googling the print spooler issue.
My System SpecsSystem Spec
07 Feb 2011   #29
Manbreed AW

Windows 7 Ultimate 32 bit

Hello CGO, I did uninstall the drivers first before i carried on the trying to go through the paces, of fixing my problem with restarting the Print Spooler Services and to no avail, it still wont work right at all, so at this moment I have turned off all Spooler Services .I allready tried the Googling and it was a waste of time, that's when I figured that It only makes sense to get the right information from the Forum that made and designed the OS so I could learn the right way to fix my PC's when the problems arise.With the Spooler Services turned off the Device Printer Loads,so until I can find the right way to fix my PC It'll be turned off,I have a Printer but it's a HP 6310xi all in one,it's not connected to the PC so,I can only Print or Scan Directly to the Printer for now....but Thanks for trying anyway.....Manbreed AW.....
My System SpecsSystem Spec
03 Mar 2011   #30

Windows 7

I had the same problem. Today I restarted the computer, uninstalled the printer, turned it off before that, after that turned the prnter on, and when windows automagically installed the printer everything worked fine. Printer, and devices and printer panel.
Hope it will stay the same.
Still didn't figure it why this happens.

maybe this will help someone.
My System SpecsSystem Spec

 device & printer panel does not load?

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
can not load my printer please help thanks
i have an epson r300 but i find that windows 7 wont install my drivers anybody out there that can help please many thanks
General Discussion
HP LaserJet Pro CM1415nfw All-in-one printer software will not load
My new HP LaserJet Pro CM1415nfw all-in-one printer software will not load completely on my desktop computer. The desktop is a Dell Inspiron 560 running Windows 7 Professional. It stops at the 71% mark and quits, giving the following error message: "Error Message: A problem occurred while...
Hardware & Devices
Control panel failed to load
I am having issues with the control panel: I am getting a message with most control panel pages saying "this page failed to load" I ran sfc/ scannow and it froze at 6% with an error (see attached pic). I am running Win7 64 bit home premium. If anyone can help that would be great.
BSOD Help and Support
Get rid of Control Panel,Device Manager,etc.. in desktop right-click
Hey Actually what happened is I got some .ico files and some regdit file that guy who gave it just wrote to copy it and give merge and i now get Control Panel,Device Manager,etc.. in my desktop right-click background so i need to know how to delete those items from my context menu of desktop Please...
Installed Printer Not Showing Up in Control Panel
I installed my HP Laser Jet 2100 printer using the PCL 5.0 driver. I can print to it since it shows up in the Word printer drop down menu but it doesn't show up in control panel. Why is this? As a result I can't set it to be my default printer. In addition, some of my prior failed attempts of...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:20.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App