Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 USB problems.

13 Jun 2010   #1
Thardus

Windows 7
 
 
Windows 7 USB problems.

So I have been having some frustrating issues with windows 7 ever since a few months after I upgraded from Windows Vista. My computer is only a year old and ever since I upgraded to Windows 7 I have been having issues with the USB ports and not recognizing devices that are plugged in. When I plug anything into the USB devices they simply do not show up or work (I don't even get the windows message saying that the USB device isn't recognized). For example, plug my ipod in and nothing shows up in itunes or My Computer. The ipod doesn't even recognize that it is plugged in. Same thing for any other USB device or multimedia device (my computer has a SD card slot which also stops working when the USB does) I have tried all USB slots on the computer.

The only way to get around this is to restart the computer (which has issues as well) in which the USB will then work a bit and then after 10 minutes or so anything plugged in does not work. And when restarting the computer after the USB has stopped working windows stalls on the shut down screen and I am forced to force shut down using the power button; This happens nearly every time I restart or shutdown the computer.

I am clueless as to how to go about fixing this and would appreciate any help that can be offered.

Thank you


My System SpecsSystem Spec
.
14 Jun 2010   #2
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by Thardus View Post
So I have been having some frustrating issues with windows 7 ever since a few months after I upgraded from Windows Vista. My computer is only a year old and ever since I upgraded to Windows 7 I have been having issues with the USB ports and not recognizing devices that are plugged in. When I plug anything into the USB devices they simply do not show up or work (I don't even get the windows message saying that the USB device isn't recognized). For example, plug my ipod in and nothing shows up in itunes or My Computer. The ipod doesn't even recognize that it is plugged in. Same thing for any other USB device or multimedia device (my computer has a SD card slot which also stops working when the USB does) I have tried all USB slots on the computer.

The only way to get around this is to restart the computer (which has issues as well) in which the USB will then work a bit and then after 10 minutes or so anything plugged in does not work. And when restarting the computer after the USB has stopped working windows stalls on the shut down screen and I am forced to force shut down using the power button; This happens nearly every time I restart or shutdown the computer.

I am clueless as to how to go about fixing this and would appreciate any help that can be offered.

Thank you

Did you do a clean install of win 7?

Do you have a backup from before the problem started?

Do you have a win 7 dvd??

How many un-powered USB devices do you have externally?
My System SpecsSystem Spec
14 Jun 2010   #3
Thardus

Windows 7
 
 

Did you do a clean install of win 7?

-- No, I did the upgrade install from Windows Vista to Windows 7

Do you have a backup from before the problem started?

-- Unfortunately no I do not.

Do you have a win 7 dvd??

-- Yes

How many un-powered USB devices do you have externally?

-- The only USB device that I have plugged in via USB regularly is a Wireless USB adapter.
My System SpecsSystem Spec
.

14 Jun 2010   #4
fseal

Windows 7 x64 Ultimate
 
 

This may be a known issue with a hotfix...

I know that this hotfix solved my wifes iPod/iTunes problems:

http://www.sevenforums.com/crashes-d...-problems.html
My System SpecsSystem Spec
Reply

 Windows 7 USB problems.




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
I upgraded from Windows XP PRO to Windows 7 Ultimate, driver problems
I have a Pavilion a810n, which has the ASUS K8S-LA motherboard. Do I have a Realtech or SIS network adapter? I have tried all day downloading different drivers, but I haven't found the right one yet. I know this is a common problem so I have searched all of the common forums and stickies without...
Drivers
Problems downgrading preinstalled Windows 8 to Windows 7 on ASUS Vivo
Hello. I think I'm losing my mind here and now I think I'm lost. Been googling and circling around for hours. So, I have an ASUS Vivobook laptop here, which has a preinstalled Windows 8. Now I'd like to downgrade to Windows 7, which I got thanks to my school having a deal with DreamSpark. So...
Installation & Setup
Windows 7 Shell Problems: Drag and drop, Windows Installer, etc...
There is probably one underlying problem that will solve all of this because it all started about the same time. 1. Drag and drop frequently stops working Upon releasing mouse: http://i.imgur.com/ydToW.jpg Releasing a favorite on the top bar of Chrome: http://i.imgur.com/QA5WP.png Dragging...
General Discussion
Fresh windows 7 install, windows updates fails and other problems
Hello all, My computer recently caught a virus and I had to reformat my computer. I have reformatted this machine before without a single problem. First problems appeared after the initial re-format and install. Installing various games and drivers would wind up alerting me that various dll...
Installation & Setup
Windows live essentials 2011 installer problems on Windows 7 64 bit
Windows live essentials 2011 installer is stuck on 99%, and doesn't move. No error messages or anything. It just sits there and does nothing. I have to use task manager to force it to close as the cancel button is greyed out, and it won't let me run the visible windows live messenger that seems...
Software
Windows Index Problems a.k.a Windows Assesment Problems
Hi, I have had Windows 7 for a while now and have continually tried to run windows assesment tool for a while now, but each time I run it, it always ends up having a problem when it starts "Tuning Windows Media Decoding" and ends up closing. This is not terribly important but I was just wondering...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:41.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App