Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't scan with Canon Pixma MX700

25 Jun 2010   #1
MarcG

Windows 7 RTM x64 (desktop), x32 (HTPC)
 
 
Can't scan with Canon Pixma MX700

Hi folks,

This is driving me nuts: Back in the fall when I switched over to Windows 7 Home Premium x64 from Vista Home Premium SP2 x64, I installed the software for my Canon Pixma MX700 multifunctional printer. I used the original Vista driver installer disc, and despite an warning message about a "known compatibility issue" the printer and scanning functions worked fine. I use the Pixma on the LAN via a wired ethernet connection. Worked fine for occasional scanning in November, December, and January.

Then for months I had no need to scan anything, just printing over the network with no problems.

Last weekend I needed to scan something. I usually just push the scan button on the printer, verify the computer it's going to scan to (it lists them), and away it goes. This time my computer threw an error about the scanner driver saying the scanner wasn't on the network. Huh? If the scanner's not on the network how did the computer know it was trying to send a scan... So I bailed on that and instead used the MP Navigator EX software on the computer. It failed too, giving the "scanner not connected" error, either using Navigator's direct interface or telling it to open the scanner driver which brings up a slightly different interface (when it worked).

First I went to the Canon site and d/l'ed all the latest drivers for 7 x64 and installed them. Still get the same errors.

Tried setting it up to scan via USB temporary connection. If I install it that way it works, but it's not a long term solution. And it stops working after a reboot. The odd thing is the scanner works over the LAN after I set it up for USB (when using NAvigator, because the scan to lan button on the printer doesn't work of course), again until reboot.

I've googled the heck out of this and tried many things (such as a weird solution involving deleting a link to MSN Web Resources [which doesn't exist on my machine so I can't do it]).

I'm at wits end. Some update to Windows or some other change caused the original installation of drivers/software not to work after January sometime, and nothing I do gets the scanner to work consistently.

And it's particularly interesting that it works temporarily after I set it up to use the USB cable, but that it dies again after reboot.

MS firewall and Security Essentials are disabled through all this; no other AV etc. software running.

HELP!

Marc


My System SpecsSystem Spec
.
25 Jun 2010   #2
Borg 386

Win 7 32 Home Premium, Win 7 64 Pro, Win 8.1, Win 10
 
 

I had this problem too & I also have a MX 700. I didn't have quite the probs your having, but when I went to scan something, it would just sit there doing nothing.

The way I found after playing around with it was like this:

I had to go to Start/Devices and Printers.

I R clicked on the printer/scanner and clicked "Start Scan".

Once I did that, it worked for me. You'll get a window with all the options for scanning. For some reason Windows took over the scan feature, but it works, so I'm happy.

Mine is hooked up via USB also, but I'm not on a x64. Driver prob maybe?

Anyway, that's how I got mine to scan, I hope it helps.
My System SpecsSystem Spec
25 Jun 2010   #3
MarcG

Windows 7 RTM x64 (desktop), x32 (HTPC)
 
 

Thanks for the reply. It's pretty bizarre. I can scan via USB (briefly) if I connect it that way and re-install telling to do so, but it loses it again after reboot. Right now it's not even showing a scanner device! And USB would only be a short term solution because the Pixma needs to be accessible by multiple computers, several of which are only on the network and not within USB cable range.
My System SpecsSystem Spec
.

25 Jun 2010   #4
MarcG

Windows 7 RTM x64 (desktop), x32 (HTPC)
 
 

I've done some more tests and confirmed that when attached via USB, the printer scanning works either through MP Navigator EX 1.06 or via the "right click on the device in the printers window then pick 'scan' " methodologies. Even got the scan button on the printer itself to work once. However after reboot it no longer works. Removing the device (device manager or delete out of printers window), followed by plugging it back in to the computer results in reinstall and it works again until reboot. After rebooting I get connection errors, though I can print via usb or network just fine.

This is so frustrating.

Anybody have ideas for the optimal place to find others to help troubleshoot? Is there some hidden Canon forum somewhere?

Marc
My System SpecsSystem Spec
26 Jun 2010   #5
Borg 386

Win 7 32 Home Premium, Win 7 64 Pro, Win 8.1, Win 10
 
 

I found this discussion going on

Canon MX700 AIO Network printer
My System SpecsSystem Spec
26 Jun 2010   #6
MarcG

Windows 7 RTM x64 (desktop), x32 (HTPC)
 
 

Thanks. I found that one a while back... seems like a fair amount has changed when W7 approached finalization; lots of things that worked broke in the final release, and lots of things that were broken were fixed. Unfortunately the suggestions there didn't do it for me.

It's really strange. I know this was working November through January. Something changed in-or-after January that hosed my setup. No other devices are complaining, though, and I've eliminated AV/Firewall possibilities. Maybe some Windows Update has nuked me.

Marc
My System SpecsSystem Spec
28 Jun 2010   #7
Borg 386

Win 7 32 Home Premium, Win 7 64 Pro, Win 8.1, Win 10
 
 

Apparently you're not the only one with this problem:

Amazon.com: Customer Discussions: MX700 Scanner Stops Working (running Vista)

Someone on this thread mentions fixing it by switching to a shorter cable...worth a try if you've tried everything else.
My System SpecsSystem Spec
03 Mar 2012   #8
ChristieD

Windows 7
 
 
cant scan with Canon MX700

MarcG - were you ever able to resolve this issue? I am having exact same issue. Worked for a few months after I installed my Windows 7 upgrade but has stopped working now.
My System SpecsSystem Spec
04 Mar 2012   #9
MarcG

Windows 7 RTM x64 (desktop), x32 (HTPC)
 
 

ChristieD-

I can't say that I solved it, as I never found out what caused the problem. However, I eliminated the problem by restoring an OS image backup I made during a time that the scanner was working. This restored scanning functionality. I then updated windows and other software packages in a stepwise fashion, testing scanning periodically, fully expecting something to break the scanning function. Much to my surprise, it never broke again.

It has been working fine ever since.

I'm still nervous about it, though... Every time I install or update something I test to see if I still have communication.

Marc
My System SpecsSystem Spec
Reply

 Can't scan with Canon Pixma MX700




Thread Tools





Similar help and support threads
Thread Forum
BSOD after updating Intel Wifi drvs & pixma mx700 printer SW & drvs
After loading 64 bit drivers for my canon mx700 printer, updating the firmware on my Asus RT-AC66U router and my intel wifi drivers on Monday, my laptop started crashing instead of going to sleep. It began doing so last yesterday morning, or Monday night, and did it again last night.
BSOD Help and Support
Canon PIXMA MX700 Printer
My Canon PIXMA MX700 Printer isn't functioning as a network printer. During installation of it as a network printer, what it does is say "Communicating with printer." for a while and then it says "The printer in the network could not be detected automatically. Set the IP address of the printer...
Hardware & Devices
Canon Pixma iP4200
Urgent help please. This printer normally connected through USB to pc running Windows XP in room 1. 2nd wireless pc running Windows 7 Ultimate 64bit in room 2. Connected printer through USB on Win 7 pc and windows updated drivers ok and everything printing ok. Then re-connected printer to XP...
Drivers
Canon Pixma IP4200
Hey peps. anyone have this driver for Windows 7 64 bit? i couldn't find it for the love of God. only found that utility stuff on their site.
Drivers
Canon MX700 AIO Network printer
Not happy.....in all builds up to and including 7077 my Canon MX700 network printer was recognised and worked like a charm, including the scanner etc. Now on a clean install of the RC (build 7100) the Canon network scanning utility comes up with a message saying it has known problems and to...
Drivers
Canon Pixma MP160
Hi I just installed Windows 7 and my printer doesn't seem to work.. Its a Canon pixma MP160.. i guess i have to install the proper drivers.. could someone help me out with this?
Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:02.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App