Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Mouse Lagging

21 Jul 2010   #1

Windows 7
 
 
Mouse Lagging

Ran a search on google and here and although there are topics concerning mouse lagging, there isnt one with my problem.

Ive had Windows 7 for about 2 month now and this issue has plagued me from the start.

When i start my computer, browse the internet, anything like that everything is fine.

However, if i play a game, or use some 3d editing software like maye etc, after 30 mins to 1 hour, my mouse behaves very erraticly as tho it is lagging.

I use a Razer Lechessis, According to theyre site the drivers they give do not support windows 7 so i have removed them and just using the HID standard drivers from Windows.

I didnt have this issue in xp, just when i upgraded to Windows 7.

If i unplug the mouse from the usb and replace it, it loses all the acceleration etc from the settings and is even slower than it should be, only way i can fix it is by rebooting.

Anyone experiencing something similar? i sent a mail to the Razer Support but i never recieved anything in return, so im here looking for help.

Filled out system specs when registering but just in case:

AMD Athlon X2 6400Black Edition
MSI K9A2-Platinum Motherboard
Sapphire HD 4870 X2
Corsair TX650W PSU
3.5gb(4gb) DDR2 OCZ Reaper HCP Edition
Windows 7 Ultimate 32bit


My System SpecsSystem Spec
.

22 Jul 2010   #2

Windows 7 Profession 64-bit
 
 

Quote:
I use a Razer Lechessis, According to theyre site the drivers they give do not support windows 7
Oh? Then what's this?
My System SpecsSystem Spec
22 Jul 2010   #3

Windows 7
 
 

Yes, i was mistaken, im using that driver, what they dont have a Firmware compatable with Windows 7, i still have the problem, noone can help shed any light?
My System SpecsSystem Spec
.


22 Jul 2010   #4

Windows 7 Profession 64-bit
 
 

Did you try Vista firmware? Razer Lachesis Firmware Updater v1.94
My System SpecsSystem Spec
23 Jul 2010   #5

Windows 7
 
 

Indeed i tried, but it wouldnt let me install it, came up with an error warning "This Version does not support Windows 7"
My System SpecsSystem Spec
23 Jul 2010   #6

Windows 7 Profession 64-bit
 
 

Then I guess you need a new mouse - and should probably send a stern note to Razer telling them you are unhappy with their support and will be sure to tell your other Windows 7 friends who not to do business with.
My System SpecsSystem Spec
23 Jul 2010   #7

Windows 7 Ultimate SP1 x64
 
 

Quote:
Then I guess you need a new mouse - and should probably send a stern note to Razer telling them you are unhappy with their support and will be sure to tell your other Windows 7 friends who not to do business with.
make sure you link to this thread to prove it also.
My System SpecsSystem Spec
23 Jul 2010   #8

Windows 7 Professional SP1 64-bit
 
 

Did you try doing it in compatibility mode? Right click the firmware update icon and click properties. Go to the compatibility tab. Tick the compatibility mode box and choose Vista 32bit or 64bit, depending on what version of 7 you have.
My System SpecsSystem Spec
23 Jul 2010   #9

MS Windows 7 Ultimate SP1 64-bit
 
 

Quote   Quote: Originally Posted by billy341 View Post
Indeed i tried, but it wouldnt let me install it, came up with an error warning "This Version does not support Windows 7"
I'm going to approach you problem differently. Let's assume that the problem is not caused by the mouse or its driver.

Be certain that you have the latest bios update for your motherboard.

Be certain that you have the latest driver for your video card.

If problem still exists after the updates, then
go to the Startup tab of MsConfig and uncheck EVERYTHING that is not from microsoft.

Problem go away? If yes, start rechecking until you find the culprit.

Oh yes, AV software can cause funny problems. For this, I recommend uninstalling your present AV and downloading and installing Microsoft Security Essentials which is free, excellent, and non-interfering.
My System SpecsSystem Spec
23 Jul 2010   #10

Windows 7
 
 

I decided to do a fresh install from the cd', This gave me the most up to date Firmware (v1.94), but i had to redownload the 1.10 Driver. Sadly the problem still persists.

Managed to get a dialog going with the Razer Support through emails but theyre just asking copy/paste questions regarding USB slots Motherboard updates/Bios etc, ive tested all of these and its not them at fault.

I fear you may be correct, a new mouse may be in order, one more suited to Windows 7. Kinda wish id stayed with XP till i got my new pc next year now. Atleast the only problems i am having is with one hardware device and not the rest of the pc

To reiterate, in the operating system its fine, as soon as anything involves 3d graphics, i screws up, could it be an issue with the graphics card at all?
My System SpecsSystem Spec
Reply

 Mouse Lagging





Thread Tools



Similar help and support threads for2: Mouse Lagging
Thread Forum
My mouse is lagging when i scroll it.. Performance & Maintenance
Mouse is Lagging - Is it Hardware or the OS? General Discussion
Solved PC is lagging sometimes Performance & Maintenance
Lagging.. Gaming
Mouse cursor & functions are lagging behind by a few seconds General Discussion
Mouse Issue - lagging Gaming
Bluetooth mouse lagging out Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:11 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33