Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: internal USB port žs "unknown device"

22 Jul 2010   #1
gridforza2

Windows 7 32bit Enterprise
 
 
internal USB port žs "unknown device"

Hello I`m new here, I searched this forum for something similar to my issue but didn`t find anything.

I have set up an old PC for my daughter for learning and playing reasons (older games).

I couldn`t find any driver for my motherboard for windows 7, so I used vista 32bit instead.

My issue is, that one internal usb-port had not been recognized by system, status is "unknown device, code 43". The chipset driver are installed, everything else too.
My system is:

motherboard: ASUS M2N-MX bios:1004
RAM: 2 GB DDR2
Graphics: NVIDIA 8600GTS PCI-e
cpu: AMD Athlon x64 4050e

all on Windows 7 Enterprise


The funny thing is, that all outside ports are working properly, all internal except of this one (Port_#0005.Hub_#0001) also.
On this board no device is connected, the only usb-device now running is keyboard and mouse.
Coud ther be an issue with windows 7 and usb/power management?


My System SpecsSystem Spec
.

22 Jul 2010   #2
Wallonn7

Windows 7 Ultimate x64 SP1
 
 

Welcome to SF!

You tried to solve the problem via Windows Update?!
Have you tried uninstalling the device and reinstall it?! If you have not tried,
right click on the device marked as unknown, go to properties and then to the Driver tab. There, click uninstall. If asked if you also want to uninstall the driver, uninstall it. That done, reboot the system. Windows tries to install the device again - I recommend that the PC is connected to the internet during this process.
If in any case the problem persists, download the drivers compatible with Windows Vista here: ASUSTeK Computer Inc.

Let us know the results!


"PLEASE REP ANYONE WHO HELPS YOU"
My System SpecsSystem Spec
22 Jul 2010   #3
gridforza2

Windows 7 32bit Enterprise
 
 

Thanks for reply

I tried all of this steps before, sorry that I didn`t mention that. I`ve read in Google a few weeks ago something about windows 7 having trouble with usb port, specially with the power management, but I can`t find this article anymore.
The hardware is ok because in the meanwhile I did an installation with vista ultimate 32 on other hdd and everything works properly. On Windows 7 I think I did everything except a clean new installation.
My System SpecsSystem Spec
.


22 Jul 2010   #4
Kirsch

Windows 7 Ultimate
 
 

Please go here and download this bios version, using mirror 1 on the right side, see if that works
My System SpecsSystem Spec
22 Jul 2010   #5
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Where did you buy your Windows 7 Enterprise from?
My System SpecsSystem Spec
22 Jul 2010   #6
gridforza2

Windows 7 32bit Enterprise
 
 

Thanks @ Kirsch: This Bios-Version is older than my installed. Are there special Bug Fixes in it?

hello theog: I got a license from my company I`m working at. Why do you ask?
My System SpecsSystem Spec
22 Jul 2010   #7
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Quote   Quote: Originally Posted by gridforza2 View Post

hello theog: I got a license from my company I`m working at. Why do you ask?
There is a lot on the net with virus in.
My System SpecsSystem Spec
22 Jul 2010   #8
gridforza2

Windows 7 32bit Enterprise
 
 

Well, that`s a legal copy. I`m lucky I can use operating systems given by my company since XP Prof.

Do you also think, I should downgrade my Bios as Kirsch asked for?
My System SpecsSystem Spec
22 Jul 2010   #9
gridforza2

Windows 7 32bit Enterprise
 
 

OK, I can`t downgrade the Bios anymore, because there is a protection built in in version 1004. So it says on the asus page
My System SpecsSystem Spec
22 Jul 2010   #10
Wallonn7

Windows 7 Ultimate x64 SP1
 
 

Quote   Quote: Originally Posted by gridforza2 View Post
Thanks for reply

I tried all of this steps before, sorry that I didn`t mention that. I`ve read in Google a few weeks ago something about windows 7 having trouble with usb port, specially with the power management, but I can`t find this article anymore.
The hardware is ok because in the meanwhile I did an installation with vista ultimate 32 on other hdd and everything works properly. On Windows 7 I think I did everything except a clean new installation.

Do not worry about not having mentioned the procedures already adopted, no problem! From what I see, things did not progress, even with the tips from other members ... I found a thread that might be helpful: Device Manager - Finding Unknown Devices
If you can find or you do not find the solution there, let us know.
All the best!


"PLEASE REP ANYONE WHO HELPS YOU"
My System SpecsSystem Spec
Reply

 internal USB port žs "unknown device"




Thread Tools





Similar help and support threads
Thread Forum
"Universal Serial Bus (USB) Controller" Unknown in Device Manager Win7
Hi Friends in my win7 i have this unknown device http://www.uploadax.com/images/38843079203947519178.png i have another windows 8.1 and there is no unknown device. this means It's only in windows7. please help me to solve it. because i think this problem bring some error in HDMI. when i...
Hardware & Devices
Built-In Webcam Not Working - "Unknown Device" USB Code 43
Hello, I have looked over many, many other forums and threads regarding this issue, but to no avail, have not been able to solve my problem. I'm starting to think that some hardware that communicates with my Webcam could be damaged - but I have not given up hope that this could be solved...
Hardware & Devices
Random BSOD, "Unknown Device" error in perfmon
I'm getting seemingly random blue screens on a regular basis. Blue Screen View blames ntoskrnl.exe, so make of that what you will. I no good at computer OS: Windows 7 home premium 64 bit Installed 3 weeks ago, when the system was built. I didn't build it, the guys I ordered it from did...
BSOD Help and Support
USB Memory Stick just started saying "unknown device"
My USB stick has suddenly just started saying "unknown device" when i plug it into my laptop. i don't know why it's suddenly just started saying it, but i've plugged it into my brothers laptop and it still says the same thing. I have no idea what to do and all my gcse work is on it and i haven't...
Hardware & Devices
Graphics Card Showing up as "Unknown Device"
My ATI Mobility Radeon 9600 is showing up as a unknown device in device manager and i can't install the driver because it wont install a standard VGA driver :confused:
Drivers
need help fixing this "unknown device" pictures added
Hello everyone. Please assist me in fixing this issue. I have already installed and ran DriverMax. That did not help. Would appreciate any input, thanks.
Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 19:21.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App