Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: USB Mass Storage Issue Windows 7 x64

25 Jul 2010   #1

Windows 7 x64
 
 
USB Mass Storage Issue Windows 7 x64

I have finally given up so I am posting this. I have an issue in which no USB mass storage devices work on my system. I have tried my BlackBerry, IPod, multiple USB jump drives and a SATA dock. They system recognizes them but won’t install them and they show a yellow exclamation mark in the device manager. The USB ports work as I can use a webcam, scanner or mouse in the same port with no issues. I used a program called DriverMax to make sure all my drivers were up to date but that did not help. Any help would be greatly appreciated! Thanks in advance!

Attached is a report from DriveMax of what drivers are installed.



Attached Files
File Type: txt installed_devices_report.txt (7.7 KB, 109 views)
My System SpecsSystem Spec
.

25 Jul 2010   #2

Windows 7 Ultimate x64, XP Mode, W8.1 Preview VM - 7 Pro x64 second remote tower
 
 

Welcome to the Seven Forums! texusn

Most likely since the ports are known to be working something is preventing the detection process on those particular items. For the external dock and flash drives once plugged in you should be seeing a popup for running things or viewing the file content.

The two images here what to look for when in the Disk Management for either a drive when present in the docking station or when plugging in a flash drive and displayed in the DM there. The two screens attached here will show that the drive in the external enclosure is being seen as "online" otherwise a right click to find that option rather then setting it to offline would be needed as well as right clicking a second time to assign a drive letter.

This usually is all it takes at first to see any new drive or device initialized. When opening up an explorer afterwards you should be seeing the new drive icon with the drive letter selected in view. As far as DriverMax or any other 3rd party driver locator those are generally a waste of time to begin with since this is a Windows related item not a driver concern as far as detection and automatic installation to make things active. Once detected properly you would see a prompting if any drivers are needed.


Attached Images
  
My System SpecsSystem Spec
26 Jul 2010   #3

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86
 
 

Try uninstalling the drivers for all the USB root hubs, then all the USB host controllers, then reboot. This should force the Windows 7 host drivers to load again.
My System SpecsSystem Spec
.


26 Jul 2010   #4

Windows 7 x64
 
 

Thank you for your replies!

Night Hawk,
I looked in the disk management tool but none of the items show up in their when they are connected. I tried rescan and still they did not show.

Bill2,
I tried to remove all the root hubs and then host controllers. Two of each would not remove visually from the list but said they would remove on a restart. I waited till I attempted all and then rebooted. 3A35 and 3A39 were the two that would not remove of the host controllers. After reboot same issue.

All,
They do show up in the “Devices and Printers” as unspecified. If I try and repair it then it says it was unable to because they did not have a driver. It is almost like I am missing the mass storage driver all together.


I loaded two files showing the screen shots I am seeing.


Attached Images
  
My System SpecsSystem Spec
26 Jul 2010   #5

Windows 7 Ultimate x64, XP Mode, W8.1 Preview VM - 7 Pro x64 second remote tower
 
 

If the docking station lacks a drive inside that's all you would see since you wouldn't be installing any drivers for it. That one is ok and should be seen that way until a drive is docked where you then will see the drive itself appear in the DM.

Have you tried the flash drives(jump drives) on any other machine to see if those are working there?
My System SpecsSystem Spec
26 Jul 2010   #6

Windows 7 x64
 
 

The dock did have the drive in it during that screen shot I sent you. It did not show up in DM.

I have tried all these devices:

Multiple Jump Drives
Camera
SATA Dock
BlackBerry Phone
iPod

All of which work on other machines fine. They all just appear to be missing a common mass storage driver on this new OS.
My System SpecsSystem Spec
26 Jul 2010   #7

Windows 7 x64
 
 

I see others are having this issue. I saw that some recommended running sfc. I ran it and am attaching the results. Apparently it sees an issue but I am not entirely sure how to fix.


Attached Images
 
My System SpecsSystem Spec
26 Jul 2010   #8

Windows 7 Ultimate x64, XP Mode, W8.1 Preview VM - 7 Pro x64 second remote tower
 
 

One thing I did here was custom assign a particular rather loud wav file to the the "new device connected" and "device disconnected" items in the Control Panel>Sound>sounds tab there so I no longer have to looking at the screen when plugging or unplugging any usb drive or device.

Apparently the present installation is not detecting anything new like it should and may have been a bad install seen there. You can try running the "sfc /scannow" command at the Run command with the 7 dvd in the drive and see if that will help by replacing any system files if found damaged or missing as one idea.

Since you are seeing the other mass storage device present something is still working where this might be all that is needed if only one or two system files are involved. Or the one thing often overlooked is the regulation of the usb bus seen on different boards.

When going to take a usb flash for example from one system to another older case the drive will be sluggish and the owner complains of not being able to use some of the ports while having multiple devices plugged in or his own flash has to be plugged into a separate usb hub. Those are powered externally with an ac adapter.

You may have to consider that as a likely cause since you know all the drives work and the individual ports still work but not when having multiple drives plugged in suggesting the bus is being pulled down a bit. Some time back while in a Walmart I picked a small 4 port Cyberpower blue led hub that actually works llike a champ for any printer, external drive, enclosure, or flash drive plugged from simply providing an adequate level for each device.

Funny how we missed each other's own idea on using the system file checker on this! But conisder the other on adding a good hub on to see if that will provided the power level correctly to see the drives and devices work for you.
My System SpecsSystem Spec
01 Aug 2010   #9

Windows 7
 
 

Hi, I'm having exactly the same problems as texusn.
My USB-memory stick and USB-HDD are both plugged in to my computer directly with no USB-hub. I can find both devices in the device manager but not in Disk Management. There's no difference if I have one or both plugged in. My USB-mouse and keyboard are working fine and the USB-storage devices run perfectly on other computers.
I've tried running sfc /scannow with my Windows 7 disc in but apparantly I don't have administrative rights... However, if someone finds a solution to texusn's problem I'm sure it will help me too.
My System SpecsSystem Spec
01 Aug 2010   #10

Windows 7 Ultimate x64, XP Mode, W8.1 Preview VM - 7 Pro x64 second remote tower
 
 

Hello and welcome to SF! Diadiadia

The first thought people often have is something must wrong in Windows as far as usb devices especially with external HDs and flash drives. WRONG!

Try measuring how well the usb bus itself is on the board! If you have several devices attached for example or with certain brands it seems the usb bus simply won't provide what the drive or device wants to pull from it.

I see this with different brands of flash drives on different systems where sometimes that good working hub is the only place you are able to use some of them! For flash drives 4 brands as one example with PNY left out in the cold! HP not doing much better. San Disk slow but will work. Kingston Data Travellers won out in every test between 3 or 4 desktops and even a Vista laptop.

When moving the PNY being the notorious fail around it simply would not work on one old XP build at all! When plugging the additional front or top usb ports in the drive is seen but does nothing again. A small 4 port hub being independently powered is the only place it will work!

Likewise the illuminated usb keyboard will not work as far as the illumination off of any hub. It requires being plugged into a port on the board directly. This problem catches everyone at some point with external HDs, flash drives, printers, and other devices where some are simply too fussy about where they get plugged into.
My System SpecsSystem Spec
Reply

 USB Mass Storage Issue Windows 7 x64





Thread Tools



Similar help and support threads for2: USB Mass Storage Issue Windows 7 x64
Thread Forum
Mass Storage Controller New SSD Hardware & Devices
usb mass storage Hardware & Devices
Mass Storage Controller driver issue Drivers
Solved USB mass storage Hardware & Devices
Using DVD-RWs for mass storage Hardware & Devices
windows 7 does not turn off usb mass storage Hardware & Devices
Mass storage controller issue Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:19 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33