Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Setup was unable to create a new system partition

04 Aug 2010   #1

Win 7
 
 
Setup was unable to create a new system partition

This is a fresh Windows 7 install on a 500GB HDD (previously used under XP)
In the BIOS the Storage is configured as: Raid. Obviously I have the right raid ICH10R drivers from Asus (they are on a USB drive)
Installation starts, Windows sees the disk, I specify the drivers, BUT when I click Next, I get: Setup was unable to create a new system partition.......
I can delete the partition, create a new one, format it, BUT when I click Next, I get: Setup was unable to create a new system partition.......
I used Gparted to delete the partition, and tried again - no luck
I used Seagate tools to zero the disk (sort of low level format) - no luck
If I try to install on a brand new 1TB HDD following the same steps, it installs fine...
Both drives are Sata II and I used the same Sata port (only one disk at a time)
I can bet the disk is fully functional because, if I try to install Windows XP SP3 on the same 500GB used disk it also works fine...
WHAT Windows 7 accepts only new drives, this is ridiculous....from Microsoft
I ran out of ideas. Please help !!!!. I think I'm about to get c r a z y...


My System SpecsSystem Spec
.

04 Aug 2010   #2
Microsoft MVP

 

Windows 7 is somewhat allergic to RAID.

Best to install to one HD with others unplugged during install, if you can hang with that.
My System SpecsSystem Spec
04 Aug 2010   #3

Win 7
 
 
Setup was unable to create a new system partition

I seems that in the BIOS, for some reason, in boot order, the HDD that I was planning to use as system disk, was not specified at all. It was probably me when I changed disks back and forth the drives.

So if you get this kind of error, the possible reasons are:
1. you did not provide the right drivers for your controller SATA/IDE, RAID, AHCI, etc.
2. make sure the HDD that will be your system disk, appears after the DVD-Drive in the BIOS Boot Order.
My System SpecsSystem Spec
.


Reply

 Setup was unable to create a new system partition




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:24 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33