Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: windows 7 install error, I/O communications, SATA drive

23 May 2009   #1

windows 7 install error, I/O communications, SATA drive

hi guys, i need help. i am not sure it's windwos 7 problem or my configurations

i tried to install windows 7 RC on the below setup (all new), but failed

1. SATA harddisk, WD Cavier 1T
2. mobo, Gigebyte GA-GM-785-S2H
3. SATA optical drive. LG-GGC...

the last two components work fine if i replace the SATA HD to a IDE HD, meaning the existing system (xp) started normally. no windows 7 installation

but, when i try the 3 componenets togehter to install windows 7 (the SATA HD was not even formated). the scenarios were:
1. if i configured the cmos to see the SATA HD as AHIC mode, the system would freeze at "verifying DMI pool", not even bothering to start the windows 7 installation disk (even i defined only one start-up device, my optical sata).
2, if i configured the cmos to see the SATA HD as Native IDE mode, the system would go to the optical sata and found windows 7. THE PROBLEM came during "windows is loading files". after like half min, the error message popped out, saying an I/O error occured, either i had a external usb drive corrupted or a storage fault.

The problem came out when i had no usb devices attached at all. then i also tried to copy SATA mobo driver to a usb stick and connected to the system. but still the same problem.
i also tried clear cmos, load default profie,

My questions:
1, how to solve this....
2, should i set native IDE mode before installing windows 7(also other windows systems?)
3, what is at least the correct way to install this.
4, is this a windows 7 installation issue or what?

Thanks a lot for reading so long post, and especially for your help!!

My System SpecsSystem Spec
23 May 2009   #2


First of all can you please go and check your the motherboard model as the one you have provided does not seem to be right. Have you tried disconnecting the optical drive and seeing if the the bios boots past the verifying dmi pool message? If not do this first.

If it does go past this then it means your hd is not the issue. If it doesn't go past this then it may be an issue between your mobo and the hd. Check for a bios update for your mobo and then post back here.
My System SpecsSystem Spec

 windows 7 install error, I/O communications, SATA drive

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
New SATA hard drive, cant install Windows.
My old IDE system drive failed so I bought a new Seagate SATA drive and windows wont install. During the installation process I get the dreaded 'setup was unable to create a new system partition...' message and I cant escape it. I currently have no windows installed so I only have the CMD to work...
Installation & Setup
Hp g61 sata drive Error upon installing windows XP
i have a HP g61 with a 500 gig SATA drive when i try to install windows XP on it i get a windows stop messsage Stop: 0x0000007b (0xf78d663c, 0x00000034, 0x00000000,0x00000000) when googled it says something about the sata drive settings needing to be changed in the bios chang the setting...
General Discussion
SATA DVD CD Drive - How to Install
How to Install and Setup a SATA DVD CD Drive Today i'm going to show you how to install and setup a SATA Disc Drive on a desktop PC. (Parts needed is in picture above) Always remember to discharge yourself before touching the components inside the case. This is done by touching the...
Install Windows 7 with Sata Hard Drive and IDE DVD ROM Drive
Hi, Is this possible? I have tried numerous times on my PC to install Windows 7 onto my Sata Drive to no avail. Yet as soon as I plug in my IDE HD it installs fine. I have unplugged all external peripherals USB and internal Card Reader. Set my Bios ok as it sees both the Hard Drive and DVD fine...
Installation & Setup
Cannot install on SATA Drive
This seems to be such a frequent issue that it could/should be a FAQ but I haven't found my answer yet. I am (currently) running Win7 64 ULT on my home PC. I purchased an Intel X25M 80GB SATA drive and connected it in order to benefit from the speed. The issue is that setup hangs during the...
Installation & Setup
Oem install fresh sata drive
I am attempting to install a Windows 7 OEM x64 onto an older machine I have. MB is a Foxconn NF4UK8AA-8EKRS, CPU is AMD Athlon 64 x2, 4200+ 2.25 GHz, RAM 1GB. I installed a new OEM 500GB SATA hard drive unformatted. Current OS is Windows XP Home SP2, I deleted SP3 since it was giving me some...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:58.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App