Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Issues installing from USB

30 Oct 2010   #1
ggoforth

Ubuntu Linux 10.04 LTS
 
 
Issues installing from USB

Hello all, great forum. I'm on a mission to install Windows 7 along side Ubuntu (which is already installed). I've got a fresh hard drive waiting for Windows, but I seem to be having some issues when installing from USB. I've got a bootable USB stick, and I've modified my bios to boot from USB first. When I reboot my computer, the windows seven install setup begins. I select the new hard drive and begin installation. All goes well, and it eventually says "Windows needs to restart to continue". The computer reboots (remember, it's booting from USB first), and immediately goes right back to the beginning of the set up process. So I'm in the infinite loop of running the set up process, but it never gets passed that. Any ideas with what I'm doing wrong? Set up seems to go fine, but after reboot, it just starts over again.

Thanks for any advice!

gg


My System SpecsSystem Spec
.

30 Oct 2010   #2
mickey megabyte

ultimate 64 sp1
 
 

take the usb stick out after it has finished installing but before it boots again.
My System SpecsSystem Spec
30 Oct 2010   #3
ggoforth

Ubuntu Linux 10.04 LTS
 
 

Quote   Quote: Originally Posted by mickey megabyte View Post
take the usb stick out after it has finished installing but before it boots again.
I will give that a shot. I wasn't sure if all files had been transfered by that point. Will post back how that goes. Thanks!
My System SpecsSystem Spec
.


30 Oct 2010   #4
mickey megabyte

ultimate 64 sp1
 
 

good luck
My System SpecsSystem Spec
30 Oct 2010   #5
ggoforth

Ubuntu Linux 10.04 LTS
 
 

Ok, did the install as you mentioned, everything completes fine, reboots, removed the usb key, and it boots straight to the already installed Linux os. I thought that windows would wipe out the MBR when it installed...still very puzzled Thanks again for your responses!
My System SpecsSystem Spec
30 Oct 2010   #6
mickey megabyte

ultimate 64 sp1
 
 

erm. i'm not sure i've only done it the other way (ie installed 7 first then a linux).

someone will be along shortly with more help than me.
My System SpecsSystem Spec
30 Oct 2010   #7
ggoforth

Ubuntu Linux 10.04 LTS
 
 

Quote   Quote: Originally Posted by mickey megabyte View Post
erm. i'm not sure i've only done it the other way (ie installed 7 first then a linux).

someone will be along shortly with more help than me.
No worries, your responses are appreciated Thanks!
My System SpecsSystem Spec
30 Oct 2010   #8
Brink
Microsoft MVP

64-bit Windows 10 build 10074
 
 

Hello GG, and welcome to Seven Forums.

This can be a common problem sometimes when your BIOS boot priority settings are set to boot first to a USB flash drive.



To work around this:
  • Boot first to the USB flash drive and start the installation as usual.
  • As soon as the computer restarts the first time during installation, boot into BIOS.
  • Set your boot order to boot from the hard drive first now instead of the USB flash drive.
  • Exit BIOS and let the computer restart to finish the installation.
Hope this helps,
Shawn
My System SpecsSystem Spec
30 Oct 2010   #9
Ponmayilal

Windows 7 Ultimate 32bit
 
 

If the motherboard and bios facilitate entering into a boot menu ( in most cases by hitting F11 or F12 during the boot process), then without changing the boot priority in the bios one can boot from any of the bootable devices listed in the boot menu.

This should be the most preferred way of doing it. No exercise of pulling out the USB device or reentering the bios setup to change the boot priority.

It also facilitates injecting any additional drivers like the AHCI/RAID -which one might store in the same bootable media - at the appropriate stage in the installation process.
My System SpecsSystem Spec
31 Oct 2010   #10
Pusspa

 
 

this is grub related i am guessing, can you use the win7 disk to fixmbr? and then after you can boot into win7 use ur linux disk to reinstall grub, but this time it will see ur win7 install
My System SpecsSystem Spec
Reply

 Issues installing from USB




Thread Tools





Similar help and support threads
Thread Forum
Issues installing everything
This problem just started recently, I am not sure what changed aside from installing Visual Studio 2013, but I don't think thats related (Hope anyway) So, nothing will install without elevation, but I never get the usual pop up for elevation, it just does a splash screen for a split second then...
Software
Need help. Re installing Windows 7 to fix issues
Ok so my computer is having a lot of issues lately. I believe it is because of some registry issues that cleaners have caused. I cant install many driver (gpu drivers ) some games etc. I built this computer its very fast. i use it for gaming and school work. Now heres what i want to do. I have 2...
Installation & Setup
installing 32 bit issues
the Drivers like the ATI does not startup and has errors after restarting, MS Office 2010 also were unable to startup...or install well. There are also many other softwares that did not start up well or worked after successful install. Do I need to do something in the BIOS first like S1 power save...
General Discussion
Issues installing itunes
Hi, I am having trouble installing iTunes. A couple weeks ago, when after I had imported a cd and plug in my ipod to sync. An error message popped up saying: Bonjour failed. Verify you have privileges. Also, I am only able to install or uninstall programs in safe mode. Please help! ...
Software
issues after installing updates
hi guys basically it installed 5 updates on tuesday night and shut down started it up wed and all worked fine for a few mins then if i tried loading anything my comp just froze so had to restart, which i then had to repair and restore to previous update to get it to work wed night it...
Windows Updates & Activation
Installing Issues
Hey, when im installing the Windows 7 official beta release, when it's expanding files , my screen just cuts off doing installation and no matter what I do i cant wake it back up. Is this a problem with have a EVGA 260, or just something im not doign correctly, i have delete all the contents off my...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:35.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App