Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: A disk read error has occurred but disk can be read


11 Jan 2011   #1

Windows 7 Home Premium 64bit
 
 
A disk read error has occurred but disk can be read

TLDR: I get the "A disk read error occurred" error but the system disk is readable and checks OK in the recovery USB.

So, I have two hard drives--a terabyte drive with some data on it and a smaller drive with the Windows 7 installation on it--and a USB drive. I made the USB drive into a recovery USB using the instructions here Installing Windows 7 System Recovery into USB Flash Drive | Raymond.CC Blog with the addendum found in the comments. I made a system image of the smaller drive via the control panel and then put the image in the terabyte drive. I then replaced my smaller hard drive with a new drive of a comparable size.

In order to restore the drive, I booted into the recovery USB, formatted the new hard drive with ntfs, made it active, and ran
wbadmin start recovery -version:xxx -items:C: -itemtype:Volume -backupTarget:C: -recoveryTarget:

where C was the terabyte drive and D is the new drive. I may have the drives mixed up here, but I assure you I had them correct when I actually ran the command

After a reset, I got some generic error so I went back into the bios, and set the new drive to be at the top of all boot lists, and then rebooted. It was at this time I got the above error. I feared that my drive was actually DOA, so I booted back into the recovery. I did a D:;dir and saw that all of my old files did indeed exist, so I figure it was a boot issue. I ran the boot repair utility in the recovery menu and it said there were no errors and I should restart. I didn't restart, and instead ran a chkdsk D: /f and found no errors. I did a bootsect /nt60 /all /mbr and restarted and still nothing changed. I even tried a "bcdedit /timeout 10" and I do not see the boot loader before getting this error. Not sure if that is expected or not but I'll throw that in here.

Sorry about the font change here. Happened when I copied from the other site

Any ideas? I can still view all of the files on the drive in question so I know it's not malfunctioning. I have a feeling it's a boot issue, but I can't find anything wrong. Looking forward to your assistance.


My System SpecsSystem Spec
.

11 Jan 2011   #2
Microsoft MVP

 

If you have the Repair CD on USB flash, then boot into it and select Recover Using an Image, browse to the WindowsImageBackup file on 1tb, reimage it to the new HD.

Or if you have WD or Seagate on either end, use their excellent free Acronis cloning app on the Downloads webpage for your model. Then just clone the old HD over to the new one without the 1tb plugged in.
My System SpecsSystem Spec
11 Jan 2011   #3

Windows 7 Home Premium 64bit
 
 

For the first option, I tried that but received the error that it needs to format the drive that the recovery environment is on. I googled a bit and found that typical when recovering using a usb drive. That is why I used wbadmin instead.

I'm hesitant to use third-party cloning software before I know why this isn't working. Especially since the old system drive was beginning to fail in the first place (i.e. among some other problems, it was only being detected by the bios on cold startups, and not on reboots). I'd rather try to solve this booting/formatting problem since the data is intact and already on the new drive.

Edit: To illustrate how utterly close I am to this, I actually have to type in my password in order to enter the recovery environment. It is able to recognize my windows installation but the loader can not, apparently.
My System SpecsSystem Spec
.


11 Jan 2011   #4
Microsoft MVP

 

Boot the Windows 7 Repair CD, mark the Windows 7 partition Active using Diskpart: Partition - Mark as Active
Then run Startup Repair up to 3 separate times with reboots to repair or write the System MBR to Windows 7: Startup Repair - Run 3 Separate Times

If this fails, I would run the HD maker's diag/repair full CD scan: HD Diagnostic followed by Disk Check from the Repair CD Command Line

Next try wiping the target HD first from Repair CD, then Recover Using an Image:
Disk - Clean and Clean All with Diskpart Command
System Image Recovery
My System SpecsSystem Spec
11 Jan 2011   #5

Windows 7 Home Premium 64bit
 
 

I tried the thrice repair with no success, and so I will be trying the clean-all and reimage overnight and tomorrow. Crossing my fingers!
My System SpecsSystem Spec
11 Jan 2011   #6
Microsoft MVP

 

If it fails then clean reinstall: re-install windows 7
My System SpecsSystem Spec
12 Jan 2011   #7
Microsoft MVP

W 7 64-bit Ultimate
 
 

Hello Ruzihm, welcome to Seven Forums!



If you need to do a clean install you can use the Windows 7 installation disk to clear the HDD of any format configuration data if you have previously run a clean all by using the command clean it its place and then specific size partitions can then be created using this same tutorial at the link below.


DISKPART : At PC Startup

SSD / HDD : Optimize for Windows Reinstallation
My System SpecsSystem Spec
Reply

 A disk read error has occurred but disk can be read




Thread Tools



Similar help and support threads for2: A disk read error has occurred but disk can be read
Thread Forum
Solved a disk read error occurred no access to SSD- sometimes. BSOD Help and Support
Custom Build. A disk read error occurred. General Discussion
Disk read error occurred. Hardware & Devices
Solved Random appearance of A disk read error has occurred BSOD Help and Support
Solved A disk read error has occurred, - after deleting partition Installation & Setup
Serious problem: A disk read error occurred General Discussion
A disk read error occurred Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:08 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33