Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't Boot from CD-ROM in AHCI mode


09 Feb 2011   #1

Windows 7 x64
 
 
Can't Boot from CD-ROM in AHCI mode

I'm trying to do a startup repair of Windows 7 x64 on an SSD but can't boot from the CD-ROM while in AHCI mode. I have set CD-ROM at the top of the boot order in BIOS but this is just ignored and the computer boots from the SSD with the knackered version of W7x64.

I read somewhere that when in AHCI mode, the BIOS boot order may include "CD-ROM" but it's not the real device anymore. I tried looking for the CD-ROM by its manufacturer name in the list under Hard Drives but it's not there either.

So just how do I go about booting from the CD-ROM in AHCI mode? There would be no problems if I set the BIOS back to IDE mode, installed Windows 7 and then did the registry hack to install the AHCI drivers but I'd like to be able to boot from the CD-ROM in AHCI mode.

P.S. I have a Gigabyte GA-MA78GM-US2H motherboard and am using the latest BIOS version (F9D)

My System SpecsSystem Spec
.

09 Feb 2011   #2
Microsoft MVP

W 7 64-bit Ultimate
 
 

Hello mate.



If the mobo supports booting from USB, use this tutorial at the link below to add the Windows 7 installation media to a USB stick to see if that will sort it for you and be sure to post back with any further questions you may have and to keep us informed.


USB Windows 7 Installation Key Drive - Create
My System SpecsSystem Spec
09 Feb 2011   #3

Windows 7 x64
 
 

Yes the mobo claims to support booting from USB so I'll give it a try. I'd still like to be able to boot from a DVD but thanks for the pointer to an alternative.

UPDATE:

Yes Bare Foot Kid's alternative did work. My machine booted from the USB with the BIOS setting of boot from "USB-HDD0" and started loading windows files but I aborted as I want to update stuff on my HDD backup before repairing the SSD.

Thanks Bare Foot Kid.... but I would still like to know if there is any way to enable boot from CD-ROM with AHCI enabled.
My System SpecsSystem Spec
.


09 Feb 2011   #4
Microsoft MVP

W 7 64-bit Ultimate
 
 

Hello again.



There must be an issue with the CD/DVD drive, that's the first thing to check, is it SATA or PATA/IDE?

Good to see you found a solution that worked for you and thanks for the update.
My System SpecsSystem Spec
09 Feb 2011   #5

Windows 7 x64
 
 

I have an ATAPI CD-ROM (called ATAPI iHA220 6 ATA in Device Manager) with a SATA connector.

Looking a little further down the Integrated Peripherals page in BIOS I found a separate "OnChip SATA Port4/5" setting which could be IDE or SATA. I'd mistakenly set this to SATA when I set the "OnChip SATA Type" to AHCI. The Boot Priority only works properly if the CD-ROM is plugged in to the SATA2_4 connector and the "OnChip SATA Port4/5" is set to "Native IDE"

I'd actually tried setting it to IDE at some stage but I mixed up the SATA cables (all yellow) and still had a HDD plugged in to the SATA2_4 connector on the motherboard. Apart from me taking more care in tracing back which cable was connected to which device, it would have helped if the manual had had mentioned that the IDE setting was needed to boot from an optical drive.

Anyway, problem solved and to answer my question - Yes you can boot from CD-ROM in AHCI mode - all you have to do is take a little care with the BIOS settings.
My System SpecsSystem Spec
10 Feb 2011   #6
Microsoft MVP

W 7 64-bit Ultimate
 
 

Good to see you got it sorted mate.
My System SpecsSystem Spec
Reply

 Can't Boot from CD-ROM in AHCI mode




Thread Tools



Similar help and support threads for2: Can't Boot from CD-ROM in AHCI mode
Thread Forum
can't boot from cd/dvd sata drive/AHCI mode Hardware & Devices
SSD problems in AHCI mode Hardware & Devices
BSOD during boot on AHCI mode Drivers
Solved Can I switch my boot disk from ahci mode to raid mode? Hardware & Devices
AHCI mode no boot from sata optical drives Hardware & Devices
AHCI mode Installation & Setup
SB600 ATI RAID AHCI drivers? (BSOD on boot if in RAID/AHCI mode.) Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:31 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33