Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Device malfunctioning, windows disabled it.

12 Mar 2011   #1

Windows 7
 
 
Device malfunctioning, windows disabled it.

Hey,

The last couple of days my Logitech Webcam Pro 9000 has had slower than usual picture quality and this morning it stopped working completely. When I connect it it says one of the USB devices connected to your computer has been malfunctioning an Windows has disabled it.
So it doesn't recognize the webcam anymore, saying it's an unknown device.
Under Device Manager the device status is "Windows has stopped this device because it has reported problems. (Code 43)"

I have tried using other USB ports - nothing.
I have downloaded the latest software from the Logitech website for this webcam to work with Windows 7 - nothing, says there isn't a webcam connected.
I have tried uninstalling the USB port it is connected to - nothing.
I have even tried turning my laptop off for a while and trying again - nothing.

My OS is Windows 7 Professional. Anyone got any ideas what to do?

Thanks.

My System SpecsSystem Spec
.

12 Mar 2011   #2
Microsoft MVP

 

Try uninstalling the software in Control Panel>Programs & Features, then plug in the cam to see if it finds it's driver via Windows Update.

First enable hardware auto-updating so Windows Updates will cue up the driver or it's update: Automatically get recommended drivers and updates for your hardware

See if the cam gets enough functionality with the driver software which Windows 7 wants it to use via Updates. If not try reinstalling the smaller SmartInstaller software listed for Windows 7 under that model on Logitech website. It is sometimes the extra functionality software which hamstrings Windows 7.
My System SpecsSystem Spec
13 Mar 2011   #3

Windows 7
 
 

Thanks for help, but managed to solve it with a system restore.
Apparently it was a download gone wrong.
My System SpecsSystem Spec
.


Reply

 Device malfunctioning, windows disabled it.




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:09 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33