Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Boot blank, but windows boots

06 Jun 2011   #1

Windows 7 Ultimate N 64-bit
Boot blank, but windows boots

rite i've managed to make a pig's ear of my boot. my windows still boots fine.....but

my boot menu is blank
in msconfig boot tab
is blank

easyBCD cant see any boot info and asks me for it, it wont write any boot info.

bcdedit constantly says

"the store import operation has failed
the device is not ready"

in repair also when i try to do anything i.e. import

bootrec.exe in repair also doesnt recover it.

what im trying to do is have a boot menu, where i have the option for win 7 then a pen drive with a linux disto on it then also CDrom as i normally chop and change between all them 3 on this pc and im sick of going in the bios 4 times a day to change these options.

cheers guys for any help.

My System SpecsSystem Spec
07 Jun 2011   #2

Windows 7 Ultimate N 64-bit

can anybody think of anything?
My System SpecsSystem Spec
07 Jun 2011   #3

Windows 7 x86/x64, Server 2008r2, Web Server 2008

Once upon a time I used to run a quad boot over three hard drives I used the Acronis Disk Director suite. It used to offer a GUI boot loader which was great for this.
My System SpecsSystem Spec

07 Jun 2011   #4


SIW2 might have some repair ideas, but I would wipe the HD to clean the boot sector which is likely corrupted. SSD - HDD Optimize for Windows Reinstallation
My System SpecsSystem Spec
07 Jun 2011   #5

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86

Blank boot tab in msconfig indicates missing reg entries. If you can, do a system restore otherwise try restoring the backed up reg hives in the regback folder.

Startup Repair Infinite Loop Recovery
My System SpecsSystem Spec

 Boot blank, but windows boots

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Laptop boots to blank screen and cursor. Help.
Hello, my laptop won't boot correctly. Everything loads but instead of the home login screen showing up, I get a blank screen with a cursor. I tried booting in safe mode and restoring but I still get a blank screen. Tried booting a recovery cd, but still get the blank screen. This happened right...
General Discussion
Boots to blank screen
On a Dell Latitude E6400 laptop running Windows 7 Ultimate 32bit, after choosing a user account and providing the password, it boots to a completely blank screen except for the mouse, which can be moved around normally. Same problem with other user accounts. Same problem booting to Safe Mode. ...
General Discussion
Windows (7 Ultimate x64) boots into a blank screen with a cursor
I was all good working on my computer when I decided to restart my computer because "rocketdock" (a dock program) didn't open a folder and gave me the "open with" dialog instead. Background:- I've installed a lot of updates recently, including SP1. The windows is customized i.e. some files...
BSOD Help and Support
Windows 7 Enterprise Boots to Blank Blue Screen after Hard Drive Clone
Hello, I have a Shuttle SB61G2 and I wanted to upgrade the hard drive to one of a higher capacity. I wasn't prepared to reinstall Windows so I decided to clone the hard drive. I used DriveClone XML and backed up the current drive image and restored it onto the new drive. All was successful so...
BSOD Help and Support
Win7 boots to blank screen (no login box), startup repair not working
We have a Windows 7 computer, fairly new Acer Inspire laptop. Recently, when it had turned itself off for power reasons, when we entered the login it first said 'not found' and then dropped to a screen that looks like the login background but without the login box. Ctrl+Alt+Delete doesn't work, you...
BSOD Help and Support
win7 pro boots to blank screen with cursor. Please.. he
Did a search but nothing came up. I just installed a new 1TB WD Black Caviar and successfully loaded the OS. I was enjoying Prototype and all for a while. Then I decided I needed to get adaware and after installation induced a restart my machine wouldn't boot up on my TV. So I hooked up an old...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:13.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App