Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Error - Windows could not configure one or more system components

18 Jun 2011   #1
Milosss

Windows Xp 32
 
 
Error - Windows could not configure one or more system components

Windows could not configure one or more system components To install Windows, restart the computer and then restart the installation i get this message on clean windows 7 instal i formal my disk and custom instal from boot and on compliting instalation i get that error



My System SpecsSystem Spec
.
18 Jun 2011   #2
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate
 
 

Hello Milosss, welcome to Seven Forums!


It maybe help to do a complete wipe of the Hard Disk Drive / Solid State Drive and then start the installation process again, have a look at Step One of the Optimize tutorial below; after you have copied out or made back-ups of the data you need to save to external media, then boot the Windows 7 installation media to do the wipe secure erase to the HDD / SSD and be sure to post back with any further questions you may have and to keep us informed.

Whether you use diskpart to run either the clean all command to completely wipe a HDD / SSD or just the clean command to remove the format configuration data and don't use diskpart to create at least a single partition to do the installation to, letting the Windows installer do the format, the new Windows 7 System Reserved partition will be automatically issued, if you want to make your own decision whether this partition is added, study these two (2) options below.
  • If you do not want to create the new Windows 7 "System Reserved" partition use the outline in Step Two #2 to create, format and mark Active a single 100GB partition to do the installation to.
  • If you do want to create the "System Reserved" partition use the outline in Step Two #3 to create, format and mark Active the System Reserved partition and then create and format the 100GB partition to do the installation to.
Either way, running the clean all then creating and formatting the partition(s) using diskpart will get you the best possible space to do a clean install of Windows 7 to; you can always extend the Windows partition to include the remaining unallocated space on the HDD / SSD or create additional Primary partitions or an Extended partition after the installation completes if you choose.

SSD / HDD : Optimize for Windows Reinstallation

DISKPART : At PC Startup
My System SpecsSystem Spec
18 Jun 2011   #3
Milosss

Windows Xp 32
 
 

I have HDD.....When it boots and setup starts i selectdriver options (advanced) and i sellect format
My System SpecsSystem Spec
.

18 Jun 2011   #4
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate
 
 

Try doing a wipe of the Hard Disk Drive first to see if it helps, have a look at this tutorial at the link below and be sure to post back with any further questions you may have and to keep us informed.



SSD / HDD : Optimize for Windows Reinstallation
My System SpecsSystem Spec
18 Jun 2011   #5
Milosss

Windows Xp 32
 
 

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\aa>diskpart

Microsoft DiskPart version 5.1.3565

Copyright (C) 1999-2003 Microsoft Corporation.
On computer: AAA-6792E2EAB03

DISKPART> list disk

Disk ### Status Size Free Dyn Gpt
-------- ---------- ------- ------- --- ---
Disk 0 Online 75 GB 0 B

DISKPART> select disk 0

Disk 0 is now the selected disk.

DISKPART> clean all

The selected disk is neccessary to the operation of your computer, and may not b
e cleaned.

DISKPART>

i cant wipe my HDD
My System SpecsSystem Spec
18 Jun 2011   #6
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate
 
 

Have a look at this one, then boot the Windows 7 installation DVD , it can't be run from the XP desktop.


DISKPART : At PC Startup
My System SpecsSystem Spec
18 Jun 2011   #7
Milosss

Windows Xp 32
 
 

This didnt help i boot and on stup to select language i press shift and f 10 to open command propt and diskpart select disk clean all and i w8 for 15-20 min and it was clean and i start istalation but i still get same error PLS HELP
My System SpecsSystem Spec
Reply

 Error - Windows could not configure one or more system components




Thread Tools




Similar help and support threads
Thread Forum
Error 0x80070057 while trying to configure Windows 7 Backup
When I try to configure Windows 7 backup I got an error: "An internal error has occured The parameter is incorrect. (0x80070057)" Tried this fix but does not help: "0x80070057" error message when you back up files in Windows 7 sfc /scannow also does not help - it detects some errors but...
Windows Updates & Activation
Windows could not configure one or more system components
Hello guys, I have currently Windows 7 Ultimate x64 (SP1) installed on my computer, but due to some .dll files corrupted, i decided to do a Repair Install of my Windows. So i downloaded the ISO from digitalriver and burned it on DVD with =General%20Tips"]Windows 7 USB-DVD Download Tool. ...
Installation & Setup
FAILURE TO CONFIGURE WINDOWS 7 SERVICE PACK 1 x-64: Error 0x80070490
This has been an ongoing issue since my first attempt to configure it on 24 June 2011: It always reboots @ 10% during the configuration; restarts @ 7% configuring, then fails completely @ 10%. Error: ERROR_NOT_FOUND(0x80070490) STEP 1: Before attempting any fixes, this was the result after...
Windows Updates & Activation
How do I delete these specific components from the system partition?
I originally partitioned my Toshiba NB205-N210 for Windows XP, so I only gave the system partition 8GB. Recently I installed Windows 7 Ultimate (x86) and of course 8GB is too small for it to really work well. This is even if I have enabled "compress files" for C: and I've already removed...
Performance & Maintenance
System will not normally boot after installing integrated components
I recently created a virtual server of window 2008 x86 enterprise edition. I installed integrated components and configured my educational / testing server and things were working fine until I rebooted the host OS and everything seems peachy but after the OS splash screen something seems to be...
Virtualization
"windows could not configure one or more system components"
I am performing a clean install of windows 7 on my sony VGN-FW520F (which had Windows 7 previously). I performed a secure erase of the HD with "Clean All" command in DISKPART and reformatted the drive in ntfs (As suggested in another thread with similar problems) When I install Windows 7...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:43.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App