Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: System won't boot from SSD, please help.


09 Jul 2011   #1

Windows 7 x64
 
 
System won't boot from SSD, please help.

Hi,

I just spent hours installing my new Intel 510 250gb SSD along with Windows 7 and the software programs I use. It's connected via SATA III.

I have a Windows 7 install on the previous boot drive, which is a 750gb WD HDD.

When I changed the boot drive priority in BIOS from the HDD to the SSD, upon reboot, the system told me that I need to "Reboot and select proper Boot device or insert Boot media in selected Boot device and press a key".

I completely disabled the HDD in BIOS, but that didn't help.

When the HDD was the primary, I was given the option of selecting the Windows 7 install from which I wanted to boot: HDD or SSD. Now that the HDD is no longer primary, the machine won't boot at all and it no longer gives me an option to choose.

Please help.

Thanks in advance,
rhit


My System SpecsSystem Spec
.

09 Jul 2011   #2
Microsoft MVP

W 7 64-bit Ultimate
 
 

Hello mate.


It seems the "System" boot files may have been placed on the spinner during the install.

Disconnect the spinner and set the SSD as the first boot device, after the CD/DVD drive in the BIOS and boot the Windows install media and in diskpart run detail partition to see if the Windows on the SSD is Active if it's not, make it so and do the 3 separate startup repairs in this tutorial at the link below to (re)create the "System" boot files to the SSD.
Startup Repair - Run 3 Separate Times

DISKPART : At PC Startup


click to enlarge



My System SpecsSystem Spec
09 Jul 2011   #3

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Physically disconnect the old HD.
Make the SSD, disk0 & first HD boot in BIOS.

System won't boot from SSD, please help.-move-boot-001.png

Startup Repair
Note: You may need to do startup repair 3 to 4 times.
Startup Repair - Run 3 Separate Times

System won't boot from SSD, please help.-move-boot-002.png

Refit old Hd when Windiws 7 is booting OK.

System won't boot from SSD, please help.-move-boot-003.png


My System SpecsSystem Spec
.


09 Jul 2011   #4
Microsoft MVP

W 7 64-bit Ultimate
 
 

Be sure to post back with any further questions you may have and to keep us informed.
My System SpecsSystem Spec
09 Jul 2011   #5
Microsoft MVP

 

Once you unplug the HD to mark Active and run Startup Repair 3 times on the SSD set first to boot, then when you plug back in the HD boot it using the Asus F8 one-time BIOS Boot Menu key.

If you installed to the SSD with the HD plugged in, you should get the Dual Boot menu now if HD is set first to boot since Windows 7 should configure a dual boot during install. So you could run that way if you want, or if you want to make the drives independent to come and go as you please, do the Repairs as specified and use the one-time BIOS Boot Menu key to trigger HD.
My System SpecsSystem Spec
09 Jul 2011   #6

Windows 7 x64
 
 

Thanks for your responses.

I followed your instructions.
- I reordered the disk boot priority in BIOS.
- In DISKPART, I made the SSD active and the HDD inactive.
- I ran Startup Repair 2x. It no longer detects any problems.

The SSD is now bootable, but it isn't Disk 0. I'm unable to make it the C: drive.

And, now, even with the 750gb drive still unplugged, I now get at boot up two recovery installs from which to choose.

Please help.

Thanks,
rhit
My System SpecsSystem Spec
09 Jul 2011   #7
Microsoft MVP

W 7 64-bit Ultimate
 
 

If you don't have the HDD connected and still get the dual boot menu at PC startup, in msconfig, boot tab delete the non-default entry to see if that sorts it; then you could use the method Greg suggests to select which OS to boot ay startup if you desire a dual boot.
My System SpecsSystem Spec
09 Jul 2011   #8
Microsoft MVP

 

Did you install the SSD from the HD's Windows 7? If so C was held by the HD and can not be assigned to the SSD for when it is booted as it would have been had it been correctly installed from boot.

Can you get the SSD to boot itself by setting first to boot in BIOS, then trigger the HD using F8 key as needed? If so, then install EasyBCD 2.02 to whichever is giving the Boot menu and delete the ghost listing using Edit Boot Menu.
My System SpecsSystem Spec
09 Jul 2011   #9

Windows 7 x64
 
 

Okay.

I have the HDD connected and the machine is currently booted off the SSD.

Below are photos of how my diskmgmt and msconfig look.





In BIOS, the boot priority order mirrors the order in the Volume List at the top of diskmgmt. The disk numbering (i.e., Disk 0, Disk 1, etc.), however, doesn't appear to match that.

Windows 7 was installed onto the SSD via the autorun on the Windows 7 full version retail install disk when inserted. I didn't boot off the disk, if that's what you're asking.

Thanks for your continued help.
My System SpecsSystem Spec
09 Jul 2011   #10
Microsoft MVP

W 7 64-bit Ultimate
 
 

You may be better in the long-run, leaving the SSD the only drive connected, then boot the Windows 7 install media to do a complete wipe secure erase and clean install to sort all these issues.
SSD / HDD : Optimize for Windows Reinstallation

Additional Secure Erase / Wipe Information

My System SpecsSystem Spec
Reply

 System won't boot from SSD, please help.




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:07 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33