Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No Drive Detected in Installing Windows 7

02 Aug 2011   #1
Lnknprkfrk28

Windows 7 64 bit.
 
 
No Drive Detected in Installing Windows 7

Hi Guys, needing a little assistance here.

-I just built my custom PC with an MSI P67A-C43 mother board, with Intel I5 quad core. Everything ran perfectly in turning the PC on and everything, however when trying to install my brand new Windows 7 CD, it could not locate the drive to install it within. At first it did locate it, and then after wards the percentage in expanding the files while installing the Windows CD was frozen at 14%, so i decided to restart the PC and reinstall it, however this time the drive was not found, was giving me that error message. The hardrive I am using is a Seagate ST31500541AS 1.5TB 900RPm hard-drive. I'm under the impression that the hard drive might be defective.

-It was odd how the drive was found in the begining, but after trying it 5 more times, restarting and trying, restarting and trying, it could not locate it, kept giving me that error. I checked the setup and switched some wires back and forth and everything, but it was a no go. I have read that maybe something in the bios might have to be configured however, I did that also. Will a new hard-drive fix this issue? Any feedback is helpful.

Error Message : "No Drive found for Installation" -I am getting to the windows install screen, a few times it did go through, however got stuck in 14%, so i tried again, and no drive is being located to do the install at all now. Hard Drive defective?


FYI: These parts are all brand new, I just bought the barebone kit and put it together. But this error is driving me nuts.


My System SpecsSystem Spec
.
02 Aug 2011   #2
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate
 
 

Hello Lnknprkfrk28, welcome to Seven Forums!


Is the PC BIOS detecting the Hard Disk Drive?
My System SpecsSystem Spec
02 Aug 2011   #3
brady

 

shutdown pc and unplug from the wall for a minute or 2 and give it another go.
My System SpecsSystem Spec
.

02 Aug 2011   #4
Lnknprkfrk28

Windows 7 64 bit.
 
 
Thanks!

Quote   Quote: Originally Posted by Bare Foot Kid View Post
Hello Lnknprkfrk28, welcome to Seven Forums!


Is the PC BIOS detecting the Hard Disk Drive?


Thanks Bare Foot Kid, Yes the Bios is detecting the Hard Drive. I mean i tried everything and its a no go. Upon installation it does not detect the drive. It did detect it before a few times, but completely stopped after a while. Do you think its a defective hard drive? I mean every part is brand new. I believe the error occurs when i try to install Windows 7.
My System SpecsSystem Spec
02 Aug 2011   #5
Lnknprkfrk28

Windows 7 64 bit.
 
 
Didn't work tried it

Quote   Quote: Originally Posted by brady View Post
shutdown pc and unplug from the wall for a minute or 2 and give it another go.

I did this maybe 7 times, did not work.
My System SpecsSystem Spec
02 Aug 2011   #6
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate
 
 

Find the appropriate info/app in the link below to test the HDD, new HDDs have been known to be bad, I just had to RMA a new (used very little) 640GB WD C. Black because of bad sectors that had to have come to me that way.


Hard Drive Diagnostics Tools and Utilities

My System SpecsSystem Spec
02 Aug 2011   #7
Lnknprkfrk28

Windows 7 64 bit.
 
 

Quote   Quote: Originally Posted by Bare Foot Kid View Post
Find the appropriate info/app in the link below to test the HDD, new HDDs have been known to be bad, I just had to RMA a new (used very little) 640GB WD C. Black because of bad sectors that had to have come to me that way.
Hard Drive Diagnostics Tools and Utilities

Thanks! I will try that, I have already requested a new Hard Drive replacement for the one I have right now from Tiger Direct, waiting on that to plug in. I just hope that will fix the issue, but want to make sure its not another issue that is causing the error. Everything else on the PC runs great, turns on and everything, just the installation part.
My System SpecsSystem Spec
02 Aug 2011   #8
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate
 
 

Be sure to post back here with an update.
My System SpecsSystem Spec
02 Aug 2011   #9
Lnknprkfrk28

Windows 7 64 bit.
 
 

Quote   Quote: Originally Posted by Bare Foot Kid View Post
Be sure to post back here with an update.

Will do, I should have the new drive on Thursday, and will try it out. I will keep you updated, appreciate the help.
My System SpecsSystem Spec
02 Aug 2011   #10
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate
 
 

Ny pleasure mate!
My System SpecsSystem Spec
Reply

 No Drive Detected in Installing Windows 7




Thread Tools




Similar help and support threads
Thread Forum
SATA drive detected as an atapi drive by windows xp setup.
SATA drive detected as an atapi drive by windows xp setup. I’m wanting to install windows xp for backwards compatible with order programs. 1st primary partition is W7 size is 243.71 GB NTFS maximum it will shrink down. 2nd primary partition is setup as 99.97 GB FAT32 (can expanded space...
Installation & Setup
DVD Drive detected by BIOS but not Windows
Decided to install an aftermarket DVD drive from my old pc. It powers on and the tray works. It's the only IDE drive that is connected to my motherboard. It shows up in BIOS under boot device priority but can't be found once I log into windows. I've tried making adjustments in the registry,...
Hardware & Devices
VGN-CR36G/B inbuilt camera not detected after installing windows 7
sony laptop vgn-cr 36g/b came with windows vista.....it was slow..i installed windows 7 on it...32 bit...i got most of the drivers...but inbuilt camera is not being detected...and the driver software says that its for windows vista only........i have searched internet for many hours....but all in...
Hardware & Devices
No output device detected after installing Windows 7
Hello, After installing Windows 7, I got the message near de loudspeaker icon "no output device detected" and a red cross. When I go to control panel, sounds, I do not see anything written when I click the play-back button. My PC is a Packard Bell Imedia. The sound worked well until I...
Sound & Audio
windows 7 says no dvd cd drive detected
hey i have a huge problem ive built my self a pc and some odd reason when i try and install windows 7 it gets to a certain point and says there no cd/dvd installed please install the recommended drivers ...... but its a plug and play dvd rw so am very confused Ive spent past 8 days trying to sort...
Installation & Setup
Trouble Installing Windows 7 (No HD Detected)
Hi everyone, So I downloaded the Windows 7 RC (both 32 bit and 64 bit, just in case) and went to install it. The OS is being installed on a brand new system that has not had any other operating systems on it before. However, after accepting the license agreement and choosing "Custom" (for a...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:03.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App