Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows setup could not configure windows to run on this computer's ha

10 Aug 2011   #1
rkiecaboose

Windows 7 Ultimate x54
 
 
Windows setup could not configure windows to run on this computer's ha

I'm trying to do a fresh clean install of Windows 7 x64 on a new harddrive
(Seagate Barracuda ST31000524AS 1TB 7200 RPM 32MB Cache SATA 6.0Gb/s 3.5") through a USB Key

CPU: Intel i5-2500k
MSI P67A-C43 (B3)

Installing proceeds as normally, until it restarts at Configuring hardware....
The resolution will change and then the error message "Windows setup could not configure windows to run on this computer's hardware" will pop up.

I've changed my SATA settings in the bios to ACHI, RAID, IDE and tried installing multiple times under each option but no dice.
I've tried loading Intel Rapid Storage Technology Driver from the MSI website prior to the Windows installation, but its giving me an error message about the drivers not being signed.

Please help. I've been struggling with this for 3 days.


My System SpecsSystem Spec
.

10 Aug 2011   #2
seavixen32

Windows 7 Ultimate SP1 64-Bit
 
 

Welcome to Windows Seven Forums.

Useful information here on installing Windows with a USB flash drive: Installing Windows 7 on a netbook
My System SpecsSystem Spec
10 Aug 2011   #3
rkiecaboose

Windows 7 Ultimate x54
 
 

Well it doesnt seem that installing through a usb key is the problem.
As far as my google searches have gone it seems to be something wrong with the BIOS, Drivers, and Harddrive. I've done all the solutions that have come up through searching but again no dice.
My System SpecsSystem Spec
.


10 Aug 2011   #4
seavixen32

Windows 7 Ultimate SP1 64-Bit
 
 

I assume you're trying to install from a Windows ISO?

If so, have you tried burning the ISO to a DVD and booting from that?
My System SpecsSystem Spec
10 Aug 2011   #5
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate
 
 

Hello rkiecaboose, welcome to Seven Forums!


Have a look through the information in this tutorial at the link below for some additional ideas and be sure to post back with any further questions you may have and to keep us informed.


Windows 7 Installation Errors : Troubleshoot Step by Step



My System SpecsSystem Spec
10 Aug 2011   #6
rkiecaboose

Windows 7 Ultimate x54
 
 

Yea I am using an iso, I unfortunately do not have a drive to attempt a DVD installation
My System SpecsSystem Spec
10 Aug 2011   #7
seavixen32

Windows 7 Ultimate SP1 64-Bit
 
 

OK, just go through the steps in the link that Bare Foot Kid gave you and let us know how you get on.
My System SpecsSystem Spec
10 Aug 2011   #8
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate
 
 

Quote   Quote: Originally Posted by Bare Foot Kid View Post
Hello rkiecaboose, welcome to Seven Forums!


Have a look through the information in this tutorial at the link below for some additional ideas and be sure to post back with any further questions you may have and to keep us informed.
Windows 7 Installation Errors : Troubleshoot Step by Step
Quote   Quote: Originally Posted by rkiecaboose View Post
Yea I am using an iso, I unfortunately do not have a drive to attempt a DVD installation
Perhaps you could use Method Two in the tutorial at Step #12 a and install Windows 7 to the HDD on another PC then when that completes, move the HDD to the target PC to finish-up.
My System SpecsSystem Spec
10 Aug 2011   #9
rkiecaboose

Windows 7 Ultimate x54
 
 

Thanks Bare
I don't know why I didn't think of that sooner. It looks like thats the easiest route to take rather than continually going through all these different settings =/
My System SpecsSystem Spec
10 Aug 2011   #10
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate
 
 

Good to help mate, be sure to post back here with updates.
My System SpecsSystem Spec
Reply

 Windows setup could not configure windows to run on this computer's ha




Thread Tools





Similar help and support threads
Thread Forum
Windows Setup Could not Configure Windows on this computer's hardware
Yesterday, after Windows 7 updated and restarted I could no longer boot into Windows 7. I tried start repair several times, no luck. So I got out the recovery DVD's that I made when I purchased the laptop. Did what the directions told me to do and I received this message. I tried rebooting but...
Installation & Setup
Windows setup could not configure windows to run on this Hardware
I recently preformed a clean install on my Inspiron 5423. It seemed fine until I got aan error message -"Windows setup could not configure windows to run on this computer's hardware" Does anyone have any suggestions? -using (Windows 7 Ultimate 64-bit) off a usb stick
Installation & Setup
Windows setup cannot configure hardware on this pc!!!
Hi All, I have been doing lot of reading and looking around but cannot seem to get past this problem. I recently bought a new HP laptop, i7 processor, Navidia GT6300M video card, 8 GB RAM. HP original windows come with so much bloatware and have so many problems that i want to do a fresh clean...
Installation & Setup
Windows setup failed to configure on your hardware??!!
I am typing on my phone so hopefully you know my situation just by that! I had just replaced my hard drive from my sony vpccw29gx. It was corrupt. I bought a different brand hard druve, but same rpm. I ordered the recovery disks from sony. I installed the disks, but after the windows 7...
Installation & Setup
Windows setup cannot configure Windows to hardware? Why?
Hey. I was recently using my computer, when I got the message, "potentially harmful software detected." I clicked the take action option, but nothing happened. So, I turned off my tower, and turned it back on. It wouldn't get to the user sign in process. It just kept with it's blank screen. So,...
General Discussion
"windows setup could not configure windows to run on this computer..."
I've recently gone out and bought 4 HDDs to run as a raid 10, now I am using my motherboards onboard fakeraid a ihc10r. The cables are fine and when I try and install windows 7 (pro 64x) onto each individual drive with raid and ahci turned off in bios windows installs just fine. Now when I raid...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:00.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App