Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 Installation saying NTLDR missing??


08 Oct 2011   #1

Windows 7 64 Home Premium
 
 
Windows 7 Installation saying NTLDR missing??

Hey all. First off hello I am newbie to this site and have just joined. Ok, basically I am at my wits end with this one and I am here as I have nowhere else to go and have exhausted all options (at least I think so).

I am currently running Windows XP SP3 32 bit and that is on my primary HDD. I also have a 1TB HDD (see specs) that I wish to install Windows 7 Home premium Edition to. I wish to install the 64 bit version as my system is 64 bit compliant.

I have backed up most of my files and settings to an external HDD but I am by no means finished (system is nearing 6 years old so you can imagine all the stuff I have to back up).

I intend to do a fresh install and I am not doing it over the original XP drive as I still use it and I am in the process of finalizing back ups etc.

Now, this is what is happening. I unplugged the primary HDD (Win XP), leaving it unplugged and plugged the 1TB HDD in to its place (slot 0) and set the system to boot from my DVD-RAM drive to boot the Win 7 installation disc from the BIOS.

All seemed ok and when I saved to CMOS and rebooted it loaded the disc no trouble (even showed grey bar and "windows is loading files" text so I though I’m onto a winner. It then proceeded to the screen where you enter keyboard language/layout and then I clicked next to setup.

Screen then displayed "Setup Starting" and then uh-oh hung. Hhmmm not good I thought and it got stuck there for 5 mins so I did hard shut down. Thought it was a blip so repeated process and after a few reboots (the system was trying to boot the HDD even though I asked it specifically to boot from optical drive!) I managed to get back to the same “setup is starting” screen.

This time it went to the next stage and asked which drive I’d like to install it to so I simply clicked the drive and pressed next. Then I get an error report saying drive is not formatted. Not a problem me thinks, so, I now press “back” button to go back to where the option is to format drive and guess what? Yep hangs again.

Getting annoyed now so I have to do yet another forced shut down and now this time the Win 7 disc won’t load and after POST screen it says “press any key to boot from CD or DVD” so I press it and it doesn’t load the disc but says “operating system failed to start”.

Now I’m really stuck so I go back into BIOS and check that the initial Win 7 install crash didn’t screw my changed settings (boot from DVD-RAM) and I find with no surprise that they are the same. I thought that the 1TB HDD perhaps got screwed up or had been written to and had an error on it or something like that when it crashed so I now swap the Sata cables and put Win XP back on as primary and the 1TB as secondary.

XP boots up no problem so I use XP to format the drive (remember that Win 7 disc won’t load so I have no choice). Wait over 3 hours and it finally formats. Swap Sata cables again (leaving XP drive unplugged) and attempt to boot win 7 install again.

Now, it gets worse and I mean worse. Says “press any key to boot from CD or DVD” then the little dots appear as if it is loading (note: pressing the enter key seems to have no effect, carries on regardless) and I am met with the delightful phrase “NTLDR is missing”, “press CTRL + ALT + DEL to restart and that does diddly squat so I have to do forced shut down again.

It is worth mentioning that if I press ESC button during POST it should normally let me select a boot device. Oh no, not this time. My keyboard does bugger all and the timer runs down and yet again that above message you read pops up. I am totally stuck and don’t know why this is happening.

Surely a clean install to another HDD should not be this difficult. I am beginning to wonder if formatting it in XP has caused an issue and I have no idea what that whole NTLDR is missing.

Another point worth mentioning is, when I went into BIOS after first attempt screwed up (to check settings remember) the 1TB drive was listed as BzBzBzBzBz. What??!!

Then, it went back to its actual manufactured information. Before you ask everything else is ok. No viruses and haven’t changed anything else. Win XP boots and runs fine so there is no major hardware failure and 1TB drive is brand spanker.

Please, please help me I do not and will not install this over XP. I shouldn’t have to and that is the reason I got a new HDD in the first place. Simple plan really, but new drive, install Win 7 to it then format XP drive and use it as storage. This is a disaster now and I’m left feeling gutted as I am left with a Win 7 disc I cannot use. Has anyone else had this problem?

I am very sorry for the long winded post. Even had a mate round for an hour (he works nights btw) and he is even scratching his head and said The HDD is corrupt!

What do I need to do to get Win 7 on that drive??

Thanks all for your patience.

My System SpecsSystem Spec
.

08 Oct 2011   #2
Microsoft MVP

 

Reset the CMOS: Clear CMOS - 3 Ways to Clear the CMOS - Reset BIOs

Wipe the target HD and create a 100gb install partition following the steps given here: SSD - HDD Optimize for Windows Reinstallation

Boot the Windows 7 DVD to attempt install to target partition. Unplug all other HD's and peripherals. Use PS2 mouse and keyboard.

If this fails, try install from XP desktop to target HD.

If these all fail, enter BIOS setup to set SATA controller to AHCI, try install to target HD plugged alone. If this works you'll have to set it back to IDE to boot XP.
My System SpecsSystem Spec
Reply

 Windows 7 Installation saying NTLDR missing??




Thread Tools



Similar help and support threads for2: Windows 7 Installation saying NTLDR missing??
Thread Forum
NTLDR is missing....but General Discussion
Solved Windows 7 dual boot to XP but ntldr missing during install Installation & Setup
Solved Windows 7 blue screen crash/hard drive booting issue/NTLDR missing BSOD Help and Support
Solved Ntldr is missing after erasing windows and installing ubuntu General Discussion
NTLDR is missing BSOD Help and Support
NTLDR is missing! Installation & Setup
NTLDR missing? Please HELP! Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:56 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33