Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Install Error Setup was unable to create a new system partition


05 Nov 2011   #1

Windows 7 64-bit
 
 
Install Error Setup was unable to create a new system partition

I am having a problem with doing a fresh install of Windows 7. It is on a Dell Inspiron 1546 with a 150 GB hard drive. There was an original install but the computer was having issues as some files were corrupted. I used the Windows 7 disc to format the hard drive and booted from CD after restarting.

However when I try to install the new Windows 7 it sits at the part where it says: Expanding files. Then after a while an error pops up that says: Setup was unable to create a new system partition or locate an existing system partition. See the Setup log files for more information

Any help would be greatly appreciated. I have read a lot of posts on this same issue but have yet to find one that applies closely to my situation. I am getting frustrated trying to figure it out lol. Please help!! If I need to supply you with other information to help me figure it out, I can.

My System SpecsSystem Spec
.

05 Nov 2011   #2
Microsoft MVP

 

Try wiping the HD to see if boot sector corruption or possibly a Dynamic disk is blocking install: SSD - HDD Optimize for Windows Reinstallation

Next reset the CMOS: Clear CMOS - 3 Ways to Clear the CMOS - Reset BIOS

While in BIOS setup set SATA controller to AHCI to try install. Unplug all other HD's and peripherals.
My System SpecsSystem Spec
06 Nov 2011   #3

Windows 7 64-bit
 
 

Thanks Gregrocker. I will give these tips a try in the morning and post my results.
My System SpecsSystem Spec
.


06 Nov 2011   #4

Windows 7 64-bit
 
 

Ok, here are the steps I took:

1. Did a clean all on the HD
2. Loaded BIOS and clicked Load Defaults and applied.
3. Changed the SATA drive to ACHI and clicked apply

It is still hanging up on the same part and not installing. Any other suggestions?
My System SpecsSystem Spec
Reply

 Install Error Setup was unable to create a new system partition




Thread Tools



Similar help and support threads for2: Install Error Setup was unable to create a new system partition
Thread Forum
Solved Setup was unable to create a new system partition Installation & Setup
Solved Setup was unable to create a new system partition...HELP!!! Installation & Setup
Setup was unable to create a new system partition - Installation Error Installation & Setup
Setup was unable to create a new system partition - I can not create p Installation & Setup
Win7 64 bit clean install error. unable to create system partition. Installation & Setup
Setup was unable to create a new system partition. Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:16 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33