Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Install Error Setup was unable to create a new system partition

05 Nov 2011   #1
Necessary2bme

Windows 7 64-bit
 
 
Install Error Setup was unable to create a new system partition

I am having a problem with doing a fresh install of Windows 7. It is on a Dell Inspiron 1546 with a 150 GB hard drive. There was an original install but the computer was having issues as some files were corrupted. I used the Windows 7 disc to format the hard drive and booted from CD after restarting.

However when I try to install the new Windows 7 it sits at the part where it says: Expanding files. Then after a while an error pops up that says: Setup was unable to create a new system partition or locate an existing system partition. See the Setup log files for more information

Any help would be greatly appreciated. I have read a lot of posts on this same issue but have yet to find one that applies closely to my situation. I am getting frustrated trying to figure it out lol. Please help!! If I need to supply you with other information to help me figure it out, I can.


My System SpecsSystem Spec
.
05 Nov 2011   #2
gregrocker

 

Try wiping the HD to see if boot sector corruption or possibly a Dynamic disk is blocking install: SSD - HDD Optimize for Windows Reinstallation

Next reset the CMOS: Clear CMOS - 3 Ways to Clear the CMOS - Reset BIOS

While in BIOS setup set SATA controller to AHCI to try install. Unplug all other HD's and peripherals.
My System SpecsSystem Spec
06 Nov 2011   #3
Necessary2bme

Windows 7 64-bit
 
 

Thanks Gregrocker. I will give these tips a try in the morning and post my results.
My System SpecsSystem Spec
.

06 Nov 2011   #4
Necessary2bme

Windows 7 64-bit
 
 

Ok, here are the steps I took:

1. Did a clean all on the HD
2. Loaded BIOS and clicked Load Defaults and applied.
3. Changed the SATA drive to ACHI and clicked apply

It is still hanging up on the same part and not installing. Any other suggestions?
My System SpecsSystem Spec
Reply

 Install Error Setup was unable to create a new system partition




Thread Tools




Similar help and support threads
Thread Forum
Error message of "Setup was unable to create a new system partition"
Let me start off my saying I've installed this exact copy of windows 7 before on this computer with no problems and it worked for years. I'm trying to install Windows 7 ultimate 64 bit version when I run into this message "Setup was unable to create a new system partition or locate an existing...
Installation & Setup
Install error: Unable to create new system partition or locate....
Hi all. I know this is a 'common' problem. I've just spend the last 3 hours scouring web sites on this issue, but the solutions suggested so far haven't worked, or it may be that the one thing I'm leaving out is actually required. I have the Win 7 Ultimate 64 bit Upgrade. I also have a GRUB...
Installation & Setup
Setup was unable to create a new system partition - Installation Error
Hello, I have my HP Laptop which came with Windows Vista as the OS. I want to upgrade to Windows 7 so I bought Windows 7 from my local store. I entered the disc and did boot from CD. It reached to the page where it shows the disk partition. I deleted the partitions and created new one....
Installation & Setup
Setup was unable to create a new system partition - I can not create p
Hello guys,'ve looked for everything that google and not found my solution. Is giving the following error when trying to install windows 7 in HD: "setup was unable to create a new system partition or locate an existing system partition" I've tried to do some procedures, but also can not...
Installation & Setup
Win7 64 bit clean install error. unable to create system partition.
Hi, I had 32 bit win7 home premium provided by OEM. Recently I purchased win7 professional 64 bit in order to increase my memory.(My system is 64 bit capable) I followed . I am using USB for installation. I booted the system with USB. Then at disk manager I deleted all the partitions(including...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:25.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App