Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Tri-boot recovery gone wrong

14 Dec 2011   #1

Windows 7 Pro x64, Windows 7 Pro x64, Ubuntu 11.10 x64
 
 
Tri-boot recovery gone wrong

In short the computer has two instances of Windows 7 Pro on it and one of Ubuntu and nothing gets to a bootloader.

A little back story on the machine, it came with the insufferable Vista preinstalled and I snuffed that out in favor of 7 the first chance I got. Unfortunately it then suffered from the Windows 7 battery error and as a result the battery is entirely useless. Being a laptop the power cable inevitable gets disconnected while in use, which causes the machine to instantly shut off. I haven't had any issues with corrupted files (until now it appears) because it would just start right back up with no issues.

For the last few nights I had left the machine on to upload my music to Google Music. Because the upload speed to google is so slow it takes days to upload. I had to relocate the computer this morning so I shut down windows, unlpugged it from the wall and moved it. When I went to start it back up the primary windows would get to saying "Starting Windows" but before the flag starts to appear it changes to "Windows is Loading Files" and then loads the startup recovery. I load up the other Windows with no issues at all. Being merely annoyed at this point I try to run the auto recovery but it fails. I try to do a system restore but it says I need to select an operating system. When I go to pick one the list is empty. When it tells me to load drivers for my drives I am able to browse the physical drives in the machine with no issues. I am unaware of what drivers I need to use so I quit out of that window and open up a command prompt. I tried "chkdsk /f C:" and it seemed to have fixed some things but it still would not boot. So I go back to a prompt and try "bootrec /fixboot" but it says "volume does not contain a recognized file system." and the mentions the hdd drivers again. So I try "bootrec /fixmbr" it says it was successful but upon reboot I find that it had overwritten the Ubuntu grub bootloader and still had not fixed windows to be bootable. All the system outputs now is "Missing oporating system". At this point I can no longer use the boot recovery on the hard drive and have to use my OEM Windows 7 disk. This is a disk that I bought from a local retailer, not one that came with the system. The system did not come with a disk. I have esentially tried the same things using the disk but have run out of ideas. I have never used bootrec before so I suspect I did something wrong. I need help getting both instances of Windows to boot.

The way I have the OS's installed is like this
HDD 0
-Partition 0 - NTFS 430GB - Windows 7 Pro x64
-Partition 1 - EXT4 70GB - Ubuntu 11.10
HDD 1
-Partition 0 - NTFS 500GB - Windows 7 Pro x64

Previous to this problem the system would first load the grub bootlader for Ubuntu and then load the bcd after that if I chose Windows

When I load up the recovery, it lists drive 1 as C: instead of D:
I do not expect help getting Ubuntu installed seeing as this is a Windows forum, but once Windows has been sorted out I can fix Ubuntu myself. I am hoping to get just the windows bootloader to show up right now.

Thanking any and everyone for the their help in advance,
Shelby Jueden

Update: I was able to install grub and it gave me back Ubuntu and my Windows on the second partition. I am still trying to get past startup recovery on the first Windows. It doesn't show the windows install where it asks you to choose it.

Solution: I just bit the bullet and reinstalled over the broken Windows. I don't see a way to delete the thread so I can't get rid of this.

My System SpecsSystem Spec
.

Reply

 Tri-boot recovery gone wrong





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:06 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33