Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No boot sector on internal hard drive while AHCI enabled installation


23 Dec 2011   #11
Microsoft MVP

 

It's nearly impossible to understand your problem from reading your original post, so you're not able to benefit from our advice until there is some clarity.

Are you able to install Windows 7 or Vista, but need the disk in drive to enable it to boot? The solution for this is to mark Windows 7 Active then boot into DVD System Recovery Options to run Startup Repair - Run 3 Separate Times to repair the boot. Partition - Mark as Active (Method Two)

If you're unable to install try IDE mode if you have it. What other SATA controller modes are available? What other OS has been installed successfully on this machine and in what mode?

If you have Vista but cannot install Windows 7, try running Windows 7 installer from Vista desktop to install to it's disk.

Once you clarify the problem exactly we will have other troubleshooting steps as this is where these problems are solved once we understand exactly what it is.

My System SpecsSystem Spec
.

24 Dec 2011   #12

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by gregrocker View Post
It's nearly impossible to understand your problem from reading your original post, so you're not able to benefit from our advice until there is some clarity.

Are you able to install Windows 7 or Vista, but need the disk in drive to enable it to boot? The solution for this is to mark Windows 7 Active then boot into DVD System Recovery Options to run Startup Repair - Run 3 Separate Times to repair the boot. Partition - Mark as Active (Method Two)

If you're unable to install try IDE mode if you have it. What other SATA controller modes are available? What other OS has been installed successfully on this machine and in what mode?

If you have Vista but cannot install Windows 7, try running Windows 7 installer from Vista desktop to install to it's disk.

Once you clarify the problem exactly we will have other troubleshooting steps as this is where these problems are solved once we understand exactly what it is.
HI, yes i can install both windows vista and windows 7 without any problem. I am using paragon partition and as well as windows disk management both shows that my (C) drive where windows, system files, boot files are existing " is active .
although i have made only one partition in order to boot properly.

I am able to install vista and windows7 on both 'Modes' ATA and AHCI. There are 3 options for controller ATA, AHCI and the other is OFF which obviousely means set the controller off so i didnt test that.

When i boot to windows repair or recovery option to fix or repaire boot automatically it says that there is no problem found in your system.

If i istall windows (vista or 7) in IDE/ATA mode system boots from bios fine without giving me any problem ,' However if i intall windows (vista or Windows 7) it giving me "no boot sector on internal hdd" problem

I have erased my HD using MHDD a software developed by hdguru.com which is more suffucient and powerfull as other manufacturer made tools. however i coudnt find manufecturer tool for Toshiba hard drive and they dont make it .

Now the problem is that system wont boot up properly when it is in AHCI mode and giving the above error.

If i install windows in IDE/ATA mode it will install and boot properly without any problem but the reason i dont want IDE/ATA is because i want to utitliz various benefits of AHCI with eSATA port enable and hotswap and also i can notice a signeficent boost in boot time and performance and so on.
My System SpecsSystem Spec
24 Dec 2011   #13

Windows 7 Home Premium 64bit
 
 

Installing windows on AHCI enabled is going same as in ATA mode but the problem is it cant boot from system the first time , It first giving me no boot sector error and then 3 option F1 , F2 , F5 after a couple of second blinking *_* this sign on top left with black screen . if i hit the F1 option then it will boot otherwise it wont boot until it gives me this error
My System SpecsSystem Spec
.


24 Dec 2011   #14
Microsoft MVP

 

Install in AHCI so you get the full functions you want, to separate HD's with one unplugged while installing to the other. Then boot choice of HD's by setting preferred first to boot in BIOS setup, boot other HD using one-time BIOS Boot Menu key which on Dell is F12.

Then post back a screenshot of your maximized Disk Management drive map with listings showing all columns, using the Snipping Tool in Start Menu.
My System SpecsSystem Spec
25 Dec 2011   #15

Windows 7 Home Premium 64bit
 
 

Here are the snapshots taken from device management and by the way i have only one internal hard drive to install windows .


Attached Thumbnails
No boot sector on internal hard drive while AHCI enabled installation-untitled1.jpg   No boot sector on internal hard drive while AHCI enabled installation-untitled2.jpg   No boot sector on internal hard drive while AHCI enabled installation-untitled3.jpg   No boot sector on internal hard drive while AHCI enabled installation-untitled4.jpg   No boot sector on internal hard drive while AHCI enabled installation-untitled6.jpg  

My System SpecsSystem Spec
25 Dec 2011   #16
Microsoft MVP

 

We need the Disk Mgmt screen, not Device Manager.

It's normal to have Safely Remove show HD for hotswapping when running AHCI mode.
My System SpecsSystem Spec
25 Dec 2011   #17

Windows 7 Home Premium 64bit
 
 

hi sorry , i mistakenly take it as you said device manager
here is the device management


Attached Thumbnails
No boot sector on internal hard drive while AHCI enabled installation-untitled1.jpg  
My System SpecsSystem Spec
25 Dec 2011   #18
Microsoft MVP

 

Check the mobo temps by installing and monitoring CoreTemp.

Run a full Disk Check on C.

Use Hitachi Drive Fitness Test to test Toshiba HD, choosing extended CD scan then zeroing the HD if you have not done that yet: HD Diagnostic

Wiping the HD should clear the boot sector of any possibly conflicting or corrupt code which might be causing the error, if HD tests out OK.
My System SpecsSystem Spec
Reply

 No boot sector on internal hard drive while AHCI enabled installation




Thread Tools



Similar help and support threads for2: No boot sector on internal hard drive while AHCI enabled installation
Thread Forum
Solved How to make the internal wireless adapter be enabled on boot? Hardware & Devices
Help Upgrading 1 TB Internal to 2 TB Internal Hard Drive Hardware & Devices
No Boot sector main hard drive General Discussion
No boot sector on internal hard drive error General Discussion
USB installation of Win7 fails to create boot sector Installation & Setup
Boot sector on the wrong drive Installation & Setup
Internal Hard Drive Installation (Help) Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:50 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33