Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Not detecting USB for RAID drivers

17 Feb 2012   #1
Waterloo

Windows 7
 
 
Not detecting USB for RAID drivers

I'm doing a fresh install on my Alienware m17x, with a copy of Win7 Ultimate that came with the laptop. Nothing was wrong with it previously, but it's been a while and things are getting choppy.

I'm installing this on RAID, and I keep getting this error "Windows Setup could not configure windows to run on this computer's hardware". This occured AFTER the installation which also ended with an error, "setup could not configure Windows", or something along those lines.

After some research, I realized I needed the RAID drivers installed before the Win7 installation, since my bios is currently set to RAID.

The problem is, my laptop isn't detecting the USB which I have the driver.exe on, when I select the load device/driver option thingy before the installation process begins.

Here is the source of the RAID, I think that's the right driver but do correct me if I'm wrong. http://downloadcenter.intel.com/Deta...ology&lang=eng

So now I'm quite stuck. I need to install the driver in order to install Windows, but it isn't detecting the USB which the driver is on. It isn't detecting the USB for some reason, but when I plug in my mouse/keyboard, it works perfectly fine.

I got like 8 USBs in the house, I tried 4 of them. One is a 128mb, others are a couple gig and a portable hard drive of 680ish gigs, so it definetly isn't because of a faulty USB.

It does detect my C disk, with Windows is already installed on, the Win7 dish, the recovery hard drive which was there when I got the PC and never touched.


My System SpecsSystem Spec
.

17 Feb 2012   #2
Golden

Microsoft Community Contributor Award Recipient

Windows 7 Ult. x64
 
 

Hi Waterloo,

Can you check in your BIOS to see whether "Legacy USB" or similar is turned ON?

Regards,
Golden
My System SpecsSystem Spec
17 Feb 2012   #3
Waterloo

Windows 7
 
 

Everything is fixed. I selected the wrong driver, and half of my USB sockets weren't working, probably due to lack of drivers or something.
My System SpecsSystem Spec
.


17 Feb 2012   #4
Golden

Microsoft Community Contributor Award Recipient

Windows 7 Ult. x64
 
 

Great news - check the Legacy USB setting anyway : it allows USB devices to be initiated before Windows boots. Very useful.

Regards,
Golden
My System SpecsSystem Spec
Reply

 Not detecting USB for RAID drivers




Thread Tools





Similar help and support threads
Thread Forum
Realtek HD Audio Drivers - Constantly detecting/undetecting front jack
Hello all, I rercently came with the following problem without any reason: I have a realtek audio chipset with my mother board. Since some time, the HD audio drivers keeps on detecting/undetecting a device plugged in my front jack (resulting is sound cutoff, which is more than annoying)....
Sound & Audio
I just need the XP RAID drivers
I am trying to install Windows XP Professional on my laptop and I really need help getting the drivers. I don't know what I need or where to get them. I need to use option 2 as I already have Windows 7 installed. I have already partitioned my HDD and such. I just need the RAID drivers. Please help!...
Drivers
RAID drivers but disks are NOT RAID - do I need them?
Hi - "Autoruns" tells me that several drivers labelled "RAID" are getting loaded on boot/login (marked yellow in the image), but my disks are NOT RAID, just regular SATA and NTFS. Similar question for the multiple USB drivers...? (Win7, 32 bit) Do I need them, or can I remove them from the...
Drivers
Raid drivers
Hey peeps, i cant seem to find the raid drivers for windows 7 64bit for my GA-P55M-UD2 motherbaord on the gigabyte website. Any help would be much appreciated. Thanks in advance
Drivers
NF4 Raid Drivers/Controller
I've just installed Windows 7 RC build 7100 onto my system. As always like with Vista installations in the past, I run into this problem. I have a DFI Lanparty NF4 Ultra-D motherboard and for some reason my RAID drive doesn't show up. I can see the two HDs I have set up as a raid appear and...
Drivers
Raid drivers
Hi all, Just putting together a list for my new October build for the W7 launch and am going to go with a "Raid 1" set up using 2x wd caviar black 1tb drives. I have not gone down the raid route before but understand that raid drivers needed to be loaded by floppy during installation. I was...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:18.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App