Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Cannot get single SSD drive to boot after copying over OS from Raid0


28 Mar 2012   #1

Windows 7 Professional x64 SP1
 
 
Cannot get single SSD drive to boot after copying over OS from Raid0

Hello everyone,

I have been running my Windows 7 system in Raid0 with two Intel 320 SSD's. I recently purchased a new Intel 520 SSD and want to go back to running the single drive as I have plans for the other two SS drives. I used the Intel cloning feature and it said successful, change over your drives and reboot. This is when the problems began. I physically disabled the two Raid drives, hooked up the single drive, restarted the computer, went into the BIOS and changed the boot order to the new drive, switched it from Raid to AHCI mode. The system gets as far as the Windows 7 logo then reboots. I've gone back into the BIOS several times trying different things hoping to figure out what setting is not correct. I wasn't sure if I was suppose to make the changes via CTRL -I and set the drives back to non-raid through there and or in the BIOS. I read something about not having any other hard drives hooked up as the system would put the boot files on there? Wasn't 100% sure of what that meant but I did have a regular HDD hooked up when I did the cloning process if that helps for information. Any ideas as to what steps I might be doing in the wrong order? I have since put everything back to the original state so I can use my system. Thanks in advance.

My System SpecsSystem Spec
.

28 Mar 2012   #2
Microsoft MVP

 

Mark Active the Windows 7 partition or it's 100 mb System Reserved partition if you have it: Partition - Mark as Active (Method Two)

Then boot into System Recovery Options on Windows 7 DVD or System Repair Disk to run Startup Repair - Run 3 Separate Times.

You can also mark Active while seeing a picture of your HD using free Partition Wizard bootable CD to right click on Windows 7 or it's 100mb System Reserved partition, select Modify>Set to Active, OK.

Then click on Disk # to highlight it, from Disk tab select Rebuild MBR, Apply, reboot. This may preclude the need to run Startup Repair 3 times to repair or rewrite the System boot files.
My System SpecsSystem Spec
29 Mar 2012   #3

Windows 7 Professional x64 SP1
 
 

Well I'm not sure if this is working 100% correctly. I followed your instructions above by going in and making the partition active via method 2, then I ran the startup repair. It said it could not fix something and do I want to report it. I said no and then realized that I may need to run startup repair 3 times to properly fix it. So I rebooted the computer and ran it again and it said there was nothing to fix the second time. I rebooted the computer, went into the BIOS to check that I have SATA mode set up to AHCI, and the computer goes to the Windows start screen then goes back to rebooting. So back into the BIOS, this time I changed the setting to Raid and voila, here I am typing to you on the new drive in the system by itself. I thought in order for Raid to work you needed at least one other drive to have that work? I don't get the Raid screeen that gives the option of CTRL - I to go into. Shouldn't the setting be AHCI not Raid? Is this possibly due to the fact that when I cloned the drive that the default option showing during cloning was Raid? When I look in Computer Management it shows the Reserved partition to be Active. Should I be running the system this way or do I need to correct it in some way.

Thanks for your time.
My System SpecsSystem Spec
.


29 Mar 2012   #4
Microsoft MVP

 

In some BIOS SATA controller settings, RAID is generic for SATA and not an actual RAID controller. This may be the case here since you have a separate RAID setup utility that isn't invoked by it.

It's possible it will not pick up AHCI drivers from Windows 7 store due to previous settings in the old image. You could SysPrep to move HD to another computer to see if that would force it to do so since it removes all drivers, SID, HID and activation to start up like a completely new install. However SysPrep is normally done on the old hardware, so it's uncertain it would make the needed adjustment.

But you are pretty much in uncharted territory here reimaging RAID0 to single HD unless you find more searching the web, and we appreciate your keeping us posted here to help others.
My System SpecsSystem Spec
29 Mar 2012   #5

Windows 7 Professional x64 SP1
 
 

Thanks again for your quick response. Originally I had debated between cloning and a clean install. I figured if the cloning did not work correctly, I would go to plan b. It's been some time since I have done a clean install so I will most likely do that in the coming week. I will do a little more research into this but I am leaning towards starting fresh. Suppose to be some rainy days coming so I will save it for that day. As for now, I will close this post. You guys at Seven Forums are great.
My System SpecsSystem Spec
29 Mar 2012   #6
Microsoft MVP

 

Glad to help.

Follow the same general steps for Clean Reinstall - Factory OEM Windows 7 to get a perfect reinstall, based on thousands we've helped with here.
My System SpecsSystem Spec
Reply

 Cannot get single SSD drive to boot after copying over OS from Raid0




Thread Tools



Similar help and support threads for2: Cannot get single SSD drive to boot after copying over OS from Raid0
Thread Forum
Solved Dual boot Win XP (RAID0), Win 7 (SSD) Installation & Setup
formatting boot partition, single drive Installation & Setup
Single physical SSD acting as two drives in RAID0??? Hardware & Devices
PC slow down when copying large files from RAID0 to eSATA HDD Performance & Maintenance
New SSD Drive turned my Raid0 drive write protected Hardware & Devices
copying outlook accounts from boot-damaged drive to new drive Browsers & Mail
Drive Xpert- Raid0? Software

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:43 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33