Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Stuck on "Setup is starting up services" during restoration

03 Aug 2012   #1
Dark875

Windows 7 Home Premium 32bit
 
 
Stuck on "Setup is starting up services" during restoration

Ok, so I recently had some problems with my computer and I ended up restoring the computer to its original factory settings. I chose the option of restoring it while keeping user files and what not. Anyways everything was going well up to this point. The screen has been stuck on "Setup is starting up services" (with that loading bar underneath the text) all night.

I'm pretty sure I did everything right. I unplugged everything, except the keyboard, monitor, and the mouse. I did not insert the Windows 7 recovery disc, but I was under the impression that I didn't need them for what I was doing.

I've looked online for people who have had similar problems, and some people give solutions; however, none of them answer my most immediate question. What do I do about it being stuck on this screen? Do I just manually shut the computer down? Is there something on the keyboard that should abort the process?

My computer is a Gateway and I'm using Windows 7.

I know I'm probably not using all the correct terms for some of the stuff I'm talking about, I'm sorry I'm not a "computer guy". I'm the guy who uses ALT, CTRL, DEL; or runs a security scan to solve every problem I have, lol. This is way above me.


My System SpecsSystem Spec
.
03 Aug 2012   #2
gregrocker

 

Your files should always be backed up externally.

Your focus should now first be on rescuiing the files stranded in the failed Recovery. To do this you'll need to boot the installer given in Step 1 of Clean Reinstall - Factory OEM Windows 7 to rescue the files as shown in Step 3.

You can then try unhanging Recovery by entering Device Manager during install to uninstall any Devices in error (likely video) so that Recovery completes: Device Manager - Access During Windows 7 Installation

If this doesn't work then wipe the HD with Diskpart Clean Command to run your Recovery Disks or get the superior Clean Reinstall.
My System SpecsSystem Spec
03 Aug 2012   #3
Dark875

Windows 7 Home Premium 32bit
 
 

Quote   Quote: Originally Posted by gregrocker View Post
Your files should always be backed up externally.

Your focus should now first be on rescuiing the files stranded in the failed Recovery. To do this you'll need to boot the installer given in Step 1 of Clean Reinstall - Factory OEM Windows 7 to rescue the files as shown in Step 3.

You can then try unhanging Recovery by entering Device Manager during install to uninstall any Devices in error (likely video) so that Recovery completes: Device Manager - Access During Windows 7 Installation

If this doesn't work then wipe the HD with Diskpart Clean Command to run your Recovery Disks or get the superior Clean Reinstall.
Most of my important files are backed up already. I moved allot of them to an external drive before I did this.

Thanks, but that doesn't solve my most immediate problem. What do I do about the "Setup is starting services screen"?
My System SpecsSystem Spec
.

03 Aug 2012   #4
gregrocker

 

Quote   Quote: Originally Posted by Dark875 View Post
Thanks, but that doesn't solve my most immediate problem. What do I do about the "Setup is starting services screen"?
Did you even read past the first paragraph?

Quote   Quote: Originally Posted by gregrocker View Post
You can then try unhanging Recovery by entering Device Manager during install to uninstall any Devices in error (likely video) so that Recovery completes: Device Manager - Access During Windows 7 Installation

If this doesn't work then wipe the HD with Diskpart Clean Command to run your Recovery Disks or get the superior Clean Reinstall - Factory OEM Windows 7
My System SpecsSystem Spec
03 Aug 2012   #5
Dark875

Windows 7 Home Premium 32bit
 
 

Yeah, I did. I just got confused there for minute.
Anyways, I'm in the Device Manager. The thing is, I really don't know what could be causing the "failure to boot"?
My System SpecsSystem Spec
03 Aug 2012   #6
gregrocker

 

Devices in error are shown with a yellow ! exclamation mark. Uninstall each in it's Driver tab. Then see if Recovery will complete. Let it run for awhile.

Can you restart Recovery from its partition?

Do you have the disks?
My System SpecsSystem Spec
03 Aug 2012   #7
Dark875

Windows 7 Home Premium 32bit
 
 

Quote   Quote: Originally Posted by gregrocker View Post
Devices in error are shown with a yellow ! exclamation mark. Uninstall each in it's Driver tab. Then see if Recovery will complete. Let it run for awhile.

Can you restart Recovery from its partition?

Do you have the disks?
I "disabled" them for now. I know you said uninstall, but the link you sent me to said to disable and not uninstall. I don't know if it makes a difference?

And, yes, I do have the disc. At least, I'm pretty sure the one I have are the right ones.
My System SpecsSystem Spec
03 Aug 2012   #8
Dark875

Windows 7 Home Premium 32bit
 
 

Quote   Quote: Originally Posted by gregrocker View Post
Devices in error are shown with a yellow ! exclamation mark. Uninstall each in it's Driver tab. Then see if Recovery will complete. Let it run for awhile.

Can you restart Recovery from its partition?

Do you have the disks?
Should I close out the Device Manager when I'm done disabling?
And I don't know if I can restart Recovery. Would I do that from the Device manager?
Sorry about the double post.
My System SpecsSystem Spec
03 Aug 2012   #9
gregrocker

 

See if there is a boot menu at reboot to choose for EMS Setup or to otherwise continue Recovery.
My System SpecsSystem Spec
Reply

 Stuck on "Setup is starting up services" during restoration




Thread Tools





Similar help and support threads
Thread Forum
Setup is starting services "loop" No Repair or installation Disk
Hi Everybody, I'm really in need of some help or advice with my laptop Specs below: Acer Aspire 5742 Intel i5-480M 6GB DDR3 Intel Graphics It started when I needed to take the computer back to factory default with a fresh install. It was going back to Acer to have the charger point...
Installation & Setup
Computer stuck on "Setup is starting services"
So about two weeks ago my computer's screen would just stay completely black whenever I turned it on. Soo I backed up my files and I guess I reinstalled the system or something. But now it's just stuck at "Setup is starting services" with a loading bar under it. Then after about 10 seconds of...
Installation & Setup
resuming Windows ... Setup is starting services..."stuck" Aspire5742
I was trying to save some files in restoring windows 7; now i can't boot my computer; 1st screen : windows resuming., then setup is starting services.... , "stuck" ; acer aspire 5742 Windows 7 64bit Home Premium; What can i do? now; F8;F2; F12; Ctr+Alt+Del; nothing runs all night ; have a recovery...
Installation & Setup
eMachines E727 laptop Stuck on "Setup is starting services".
Hi, My computer is stuck on "Setup is starting services" during a recovery and has been like that for a day now. I tried to restore days ago and I turned it off during this same screen and it came up with an Install Windows error "The computer restarted unexpectedly or encountered an unexpected...
Backup and Restore
HELP! Stuck at "Setup is starting services"
Hi everyone, I turned on my computer and i got a black screen saying "windows error recovery" I clicked on "start windows normally" and the logo starts to load. Then a black screen comes up saying "setup is starting services" and a pop-up titled "Install Windows" reads: The computer restarted...
Installation & Setup
Stuck at "setup is starting services"
Hello all, and thanks in advance for helping. About 2-3 weeks ago i purchased a toshiba satellite L500D laptop, all went smoothly through the setup etc, and it was running fine untill, a couple of days ago i turned it on and whilst starting up a screen came up saying "setup is starting services"...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:47.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App