Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sysprep tool

24 Aug 2012   #1
Lehani

Windows 8 Pro - 64 Bit
 
 
Sysprep tool

hi there

i am reading the book 70-680 from microsoft

but when i am trying to use the sysprep tool, i am stucked. i running win7 entreprise version in danish on Vm-ware workstation.

1st:
i install win 7 like normal, i update it and install it like i want. change desktop etc.
i run the cmd as admin and type:
"%systemroot%\system32\sysprep\sysprep.exe /audit /generalize /reboot"

when i enter the audit mode i delete teh former user profiles, and check the system is as i made it.
i use the sysprep tool again and type in cmd with admin rights:
"%systemroot%\system32\sysprep\sysprep.exe /quiet /oobe /generalize /shutdown"

with when i type the ^^ it says it cannot run sysprep. and need to exit.
when i reboots ( or make a shutdown and then turn my PC on again ) its just saying "installation starting the services"
its here i am stucked..

so i do anything wrong ? or is it because its a virtuelt enviorment ?


My System SpecsSystem Spec
.

24 Aug 2012   #2
Kari

Microsoft Community Contributor Award Recipient

 

Your syntax is wrong. The generalize switch should come before boot options (audit / oobe).

try:
Code:
"%systemroot%\system32\sysprep\sysprep.exe /quiet /generalize /oobe /shutdown"
Kari
My System SpecsSystem Spec
29 Aug 2012   #3
Lehani

Windows 8 Pro - 64 Bit
 
 

Quote   Quote: Originally Posted by Kari View Post
Your syntax is wrong. The generalize switch should come before boot options (audit / oobe).

try:
Code:
"%systemroot%\system32\sysprep\sysprep.exe /quiet /generalize /oobe /shutdown"
Kari
ok well i tryed that on a new system.. and well when i have installed and fully updated windows i run CMD with admin and type:

"%systemroot%\system32\sysprep\sysprep.exe /audit /reboot"
i have tried with and withput generalize commando. but it comes with the same error:
"There was a serious when trying to run sysprep on the computer"

what now?
My System SpecsSystem Spec
.


Reply

 Sysprep tool




Thread Tools





Similar help and support threads
Thread Forum
SysPrep Help?
I made a sysprep file with Windows WAK and it giving us issues. We get a "A fatal error occurred while trying to sysprep the machine." This happens when it is "Processing cleanup phase Sysprep plugins..." Here is our file. <?xml version="1.0" encoding="UTF-8"?> -<unattend...
Installation & Setup
Sysprep - Windows 7 - unable to sysprep image that joins domain
Good morning all: Below is my unattend.xml. I am using the sysprep + win7 for creating virtual machines in Red Hat Enterprise Virtualization 3.0 but having difficulty getting them to auto-join the domain. My sysprep progression proceeds normally and completes. The initial boot of the image...
Virtualization
win7 after sysprep reboot always with sysprep box
hello, 1st sorry for my english (i'm french guy). I made a sysprep and all parameters are corrects. but after the reboot I have always the sysprep preparation tools box. for me the sysprep is correct but I don't know what's happended. in attachment my unattend.xml
Installation & Setup
Sysprep HELP
Hi i try to sysprep a Dell latitude E6400 i install from DVD (normal installation) i create my sysprep anwser file: <?xml version="1.0" encoding="utf-8"?> <unattend xmlns="urn:schemas-microsoft-com:unattend"> <settings pass="specialize"> <component...
General Discussion
Sysprep
Can you do Sysprep on Windows 7 like on XP? OK so you do a clean install of W7. Then install all of your software. Now you want to set it up to clear all of the information. That way when you sell it or give it away, the person turns it on is goes through the initial walk-through process...
General Discussion
Help with Sysprep!
Hi all, Has anyone been able to sysprep windows 7? I followed the MS site of sysprep (Vista deployment) but get an error saying this OS is not supported. Anyone know a fix? Thanks
Software

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:14.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App