Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Fresh Windows 7 install doesn't find drivers

31 Jan 2013   #1
JonKlemm

Windows 7 Ultimate 64 bit
 
 
Fresh Windows 7 install doesn't find drivers

I have a Windows 7 Ultimate 64 bit upgrade disc and a Windows Vista Home Premium 32 bit installation disc. I was repartitioning my desktop to dual boot ubuntu and a third partition for data. The partitioning didn't complete and it broke the windows 7 partition. I tried to recover it using the windows disc but it couldn't save the o/s. So i did a fresh install of Windows Vista and setup the partitions for ubuntu and data in the Vista disc. After installing Vista I upgraded to 7. The 7 install didn't find drivers during the install. It doesn't see my monitor as anything but a Generic PnP, so I can't increase the resolution beyound 640 x 480, and it can't even find the ethernet connection.

I tried restarting the computer but it didn't help. I wanted to see if somehow it was a hardware problem and just was really weirdly timed up with my install, so I installed ubuntu to see if it was just windows 7 having a problem and it was. Ubuntu sees everything fine and gets internet. I tried to manually download the ethernet driver for my motherboard but the only downloads the manufacturer have didn't work. The motherboard is an Asus P8z77 V, the only driver downloads I could find from their site are for Intel Ethernet drivers, and when I try to install them it says no device found for the drivers.

I should mention that I already had this exact version of Windows 7 Ultimate installed on my computer before I reinstalled it. Does anyone have an idea on what could be causing this? I just realized I should have tried to install just Vista to see if it's Windows in general that's having problems or just the 7 install. I'll be doing that over the next few hours and I'll update this post when I do.

What do you believe could be causing this problem?


My System SpecsSystem Spec
.

31 Jan 2013   #2
AddRAM

Windows 7 Professional x64 Service Pack 1
 
 

You don`t have to install Vista to use your Ultimate Upgrade disc, in fact you should do a clean install with your upgrade disc. In order to get drivers you have to run windows update and in the case of your video drivers, you should be going directly to the manufacturers website. ( of the video card )

Clean Install with a Upgrade Windows 7 Version

Windows 7 is not 100% driver complete but it`s dam close.

Vista is probably the worst operating system windows has ever produced and in no way should you leave it the way you have it, and everyone here will agree.
My System SpecsSystem Spec
31 Jan 2013   #3
JonKlemm

Windows 7 Ultimate 64 bit
 
 

Quote   Quote: Originally Posted by AddRAM View Post
You don`t have to install Vista to use your Ultimate Upgrade disc, in fact you should do a clean install with your upgrade disc. In order to get drivers you have to run windows update and in the case of your video drivers, you should be going directly to the manufacturers website. ( of the video card )

Clean Install with a Upgrade Windows 7 Version

Windows 7 is not 100% driver complete but it`s dam close.

Vista is probably the worst operating system windows has ever produced and in no way should you leave it the way you have it, and everyone here will agree.
Haha yeah I don't have Vista installed, I have Windows 7. When I installed it after ruining the partition I had to install Vista first because the partition was so ruined it couldn't find the previous 7 installation. When I reinstalled it after that I did it straight from the 7 disc. Both of those installs were clean installs off the upgrade disc. I'm going to try and install Vista just to see if the vista disc is able to install the drivers that 7 can't.

I can't run windows update to get the drivers because it doesn't have the drivers for the ethernet, so I'm not getting internet to update. I have an xbox wireless plug so I'm going to see if I can get internet through that, it seems like the only drivers that it can see are the usb 2.0 ones.
My System SpecsSystem Spec
.


31 Jan 2013   #4
AddRAM

Windows 7 Professional x64 Service Pack 1
 
 

You should have known that you might need your network drivers before you did the install. What machine are you working on ? And what video card do you have ?
My System SpecsSystem Spec
31 Jan 2013   #5
JonKlemm

Windows 7 Ultimate 64 bit
 
 

Quote   Quote: Originally Posted by AddRAM View Post
You should have known that you might need your network drivers before you did the install. What machine are you working on ? And what video card do you have ?
I've installed from that 7 disc 2 times before on that computer with no problems, and I have a laptop so I can download drivers from this and then transfer on my external hdd. My video card is a 560 ti, but that's not my concern right now. If I can get the internet drivers to work then I can just update the graphics card from that computer. Manually installing the drivers on the graphics card will make it look nicer but there's no point right now since I can't access the internet to use those pretty graphics.

I installed Vista on it since there was nothing installed on 7 anyway, it doesn't get internet either but it sees a network adapter. It shows it as a PCI-E adapter, which is weird because I don't have a PCI-E adapter, I'm running off of the motherboard. Windows 7 showed a generic ethernet port, not a PCI-E ethernet adapter. The PCI-E adapter shows as a Realtek RTL8168/8111 PCI-E Gigabit Ethernet Adapter, I'm going to install the latest adapter for it to see if it does anything.

The hardware is:
i5 3570k
Asus P8z77-v motherboard
EVGA gtx 560 ti
8GB Corsair ddr3 1333 mhz RAM
My System SpecsSystem Spec
31 Jan 2013   #6
gregrocker
Microsoft MVP

 
 

I'd wipe the HD first with Diskpart Clean Command to clear the boot sector in case code is interfering, then follow these same steps to get a perfect Clean Reinstall - Factory OEM Windows 7.

If Win7 doesn't provide the ethernet driver which it does in 90% of installs then have it in your backup to install and immediately do all of your Important and Optional Windows Updates after enabling Automatically deliver drivers via Windows Update (Step 3). Once all rounds of Updates are done import any drivers still missing in Device Manager from the device's Support Downloads webpage.
My System SpecsSystem Spec
01 Feb 2013   #7
JonKlemm

Windows 7 Ultimate 64 bit
 
 

It won't let me clean it since the i'm running windows on the same disk as the boot sector. Will it work just as well to reformat the entire disk, boot partition included, in the windows 7 install disc? I'm not worried about losing my ubuntu boot or data partition, there's nothing in there since I lost all the data originally.
My System SpecsSystem Spec
01 Feb 2013   #8
gregrocker
Microsoft MVP

 
 

You cannot wipe the HD from itself. Run Diskpart Clean Command accessing DISKPART At PC Startup
My System SpecsSystem Spec
01 Feb 2013   #9
AddRAM

Windows 7 Professional x64 Service Pack 1
 
 

Ethernet drivers should be on the disc that came with the board, but.....I`m bored so.....

ASUS - - ASUS P8Z77-V

EVGA Download Center

Drivers | GeForce
My System SpecsSystem Spec
01 Feb 2013   #10
JonKlemm

Windows 7 Ultimate 64 bit
 
 

I ran the disk clean and reinstalled, but the drivers did not install with it. However this time the drivers I got from Asus actually installed. Last time it said failed, but this time they went through. I'm still not sure why the drivers weren't installed with Windows 7 since I installed on this exact hardware less than a month ago with the same installation disc and they were.

Thanks for the help, something was going wrong with the installations and they weren't letting drivers install I guess but wiping the disk fixed it.
My System SpecsSystem Spec
Reply

 Fresh Windows 7 install doesn't find drivers




Thread Tools





Similar help and support threads
Thread Forum
Windows 7 fresh install cannt get network drivers
Hey all, Got a new SSD and just put win 7 pro on it, However I cannot get it to connect to the internet it says to install the driver I tried to do the windows update to auto update my drivers but can not connect to the internet to even try. How would I find out what network card I have, ...
Drivers
Fresh windows home premium 64bit install, important drivers are gone!
Windows 7 re-install driver recovery failure Hello everyone. For one reason or another, i decided to re install windows 7 onto my Samsung 7 Chronos. Since I've had no issues in the past with re installing vista on my other machine, i mistakenly thought this would be a walk in the park. Anyway, now...
Drivers
BSOD while trying to update drivers and windows on fresh install
I am having continuous issues with a BSOD. Here is a little basic info: Windows 7 Ultimate 64 bit (one week old install) version of windows is a OEM upgrade (installed fresh from formatted hard drive) Computer is about 2.5 years old. Hard drive is 3 months old RAM is one month old. I am...
BSOD Help and Support
BSOD Installing drivers after a fresh windows install, Code 0xf4
My computer was suffering from random bsods and viruses before. I atributed the bsods to viruses, but after reinstalling windows 7, I found that the bsods still happened. It seems to happen when installing drivers, or running prime95. Booting into safe mode allows me to pretty much do anything. ...
BSOD Help and Support
Installing Drivers after Fresh Windows Install
Hello i was wondering how can you be sure you have installed all the Drivers when you reinstall a Fresh copy of windows like for my Motherboard i noticed i need 1 driver so that my PC would stop getting a BSOD every Time i ran a full Screen game (it was like a ATK0001 Driver or something liek that...
Drivers
Doesn't prompt to delete partitions, do fresh install
I'm trying to install Win7 x64 on a machine that currently has the Win7 RC on it. When I boot from the DVD, it immediately goes into "Windows is loading files...", which it does for 30 minutes or so and then reboots, at which point I get a message that says that Windows cannot start because files...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:43.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App