Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: new installation not connecting to internet

08 Mar 2013   #1

windows 7 64 bit
new installation not connecting to internet

ok so following on from this thread here:
laptop stays at welcome screen. only the cursor visible and it is enla

I was not getting anywhere while trying to get ti working. I couldn't waste any more time trying too get it booting correctly so I decided to just do a fresh installation. So when i was asked where to install windows 7 , I clicked on the partition with windows 7 on it and deleted it . This left me with an un allocated partition. I then chose to this partition to install windows & on and let it do its thing. So after it finished installing, it loaded the desktop for the first time , however it still has the large cursor and the desktop is as if it is in safe mode. Maybe it still is in safe mode so I thought I would restart with f8 and select boot normally , however it just loads exactly the same.
The second problem is that i can not get internet access as it says the drivers are not installed.
Thanks in advance for any help.

My System SpecsSystem Spec
08 Mar 2013   #2


Why dont' you interact with us on the help you're seeking here instead of just skipping around blindly?

Follow the steps given here to Clean Reinstall - Factory OEM Windows 7 to get a perfect install. Pay attention to how drivers are handled in Win7 which you'd already know if you'd consulted us first.

Delete all partitions this time and create new as you wish, format before install. Have your wireless driver in your backup so you can get online and run all rounds of Updates to get the rest of your drivers.
My System SpecsSystem Spec
08 Mar 2013   #3

windows 7 64 bit

I have been interacting with you. And I tried everything you had suggested on my other thread. And again I have done the install as seen here: Clean Install Windows 7

So I followed all the steps and am now at the stage in my initial post. Regardless of how you see me "skipping around blindly" the simple fact is that I am now at this stage.

As i have already deleted the initial partition does this now mean that my lan driver is gone for good? or if I do as you suggest will it start working. Its ok replying to everything with "follow this guide" but in my case the guides miss out certain parts which are relative to me.
My System SpecsSystem Spec

08 Mar 2013   #4


You need the fuller steps in Clean Reinstall - Factory OEM Windows 7 which you would have already read and been aware of had you actually followed the steps in Troubleshooting Windows 7 Failure to Start to the end.

Even now you won't read it to see where to get the drivers?
My System SpecsSystem Spec
08 Mar 2013   #5

windows 7 64 bit

I have read it but it does not say where to get the drivers! all it says is enable auto update settings. These need internet access. could you just please tell me what i need to do instead of talking in riddles.
My System SpecsSystem Spec
08 Mar 2013   #6


Did you read this?

● Just in case, save in advance your Wireless or Ethernet LAN (wired) driver on flash stick, CD or in your backup so you can install it to get online quickly - these can be found on the Support Downloads webpage for your model PC.
You need your model extension to look them up here:

Driver Install - Device Manager
My System SpecsSystem Spec
08 Mar 2013   #7

windows 7 64 bit

Ok i apologise as i had read all that but as there are so many links in there and I was reading loads of information I forgot to get them from the toshiba website. would I be better to reinstall again and delete all 3 partitions or should I get the 6 drivers I need from the toshiba website? would these drivers be one of the reasons that the desktop has the enlarged appearance?
My System SpecsSystem Spec
08 Mar 2013   #8

windows 7 64 bit

Ok the drivers available after I put my serial number in are a little different to the ones I think I need.
please bear with me as I am not clued up on terminology.
When I trouble shoot my laptop the list of drivers missing are:
1.Unknown device doesn't have a driver
2.Ethernet controller does not have a driver
3.Network controller does not have a driver
4.Sm bus controller does not have a driver
5.PCI simple communications controller doesn't have a driver

the drivers available that to me sound like the right ones are,
For 1. not a clue what to put here.
For 2.LAN driver? there is no ethernet driver listed.
For 3.wireless LAN driveror Network device ID registry setting tool
For 4. Nothing in the list that sounds like this
For 5. Nothing on the list sounds like this
My System SpecsSystem Spec
08 Mar 2013   #9


Have you done all rounds of Important and Optional Updates with necessary restarts? Only then should you import any missing drivers besides LAN driver to get online.

This is quite explicit in the tutorial so I don't understand why you have no interest in studying and applying the practices which assure you will get and keep a perfect install for as long as you do. Is it some other kind of install that you want instead?

Ethernet driver will most times be supplied and start up connected if you have it plugged in during install. Otherwise install it and the Display drivers from the website.
My System SpecsSystem Spec
08 Mar 2013   #10

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

Excuse me for butting in Greg but as mk1 has a Toshiba and having a bit of experience with this err... brand the Toshiba utilities / driver updates are pretty ruddy useless a bit like the rotten bloat they always put on.

What I would do personally is to try and get the manufacturer's drivers for the machine's component parts.
mk1 you can if you want find these from this Satellite C660-108 - Toshiba just highlight the ones you want Google for the manufacturer or the download site and get it from there.
For example the LAN Ethernet driver is this Intel® 82551IT Integrated 10BASE-T/100BASE-TX Ethernet Controller - Overview

But this is only what I would do because at the moment looks like you are in no mans land.
My System SpecsSystem Spec

 new installation not connecting to internet

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Laptop connecting to internet but no internet access (DNS server)
My laptop connects to the local network, but it has no internet access. If I run troubleshooting it says that the DNS server isn't responding. It is not the internets fault, because my room mate net works fine. It's not the cables fault because I tried plugging it in both of my routers and in...
Network & Sharing
USB modem not connecting to internet
Hi There. Afew days ago i was trying to connect my laptop to my ps3. To do this i was changing setting etc but never got it to work anyway.. The next day i turn the computer on and can't connect to the internet. I think it was something to do with dns :sarc: I uninstalled and reinstalled my...
Network & Sharing
IE Not Connecting to Internet
My IE 8 has stopped accessing the internet (running W7) and displays the message shown below when I try to connect. I have tried a few different sites and keep getting the same message. Firefoc connects no bother and another PC connected to the same router works fine in IE 8. I have the original...
Browsers & Mail
Pc not connecting to internet
Hello all, i have a problem with my internet connection. When i turn on my pc, it gets an ip-adress from my modem, but the connection to the internet does not work. Turning the network connection off and on again (see attachment) solves the problem, but only until the next time i turn my pc on....
Network & Sharing
Connecting a Pc to Internet using my own PC
Hi I`ve been connecting my 2nd PC to the internet using my first connection to the isp using a network On win xp it worked using the Network setup wizard I`m using an Nvidia nForce Network controller (in which my ISP connection is) and have a second Network card 3Com etherlink 10/100 ( which is...
Network & Sharing
Need help connecting to the internet...
Hello there everyone First off, my name is Gab and I just joined these forums ^^ I just got a quick question on how to get connected to the web using windows 7 which I just installed. Naturally, my motherboard wifi drivers didn't work to install...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:17.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App