Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: TEST -Update 7 installation media

17 Mar 2013   #11

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

@Greg,

Thank you . I have fixed it - new version (also on first post ).

On Skydrive UPDATE-v2.7z

https://skydrive.live.com/#cid=B0A22...89320E3247!216

I will upload it here when the manage attachments works.

It sits on waiting for sevenforums forever.

You would be better moving the updates folder directly onto your drive. e.g. C:\windows updates downloader

I would put update 7 folder on C as well. e.g. C\:update-7

You need to have the BIN folder in there as well as the .cmd file - or it won't be found.

Name:  uodate7.jpg
Views: 329
Size:  18.2 KB

@Danny,

Sorry , net frame 4.5 was not included.



My System SpecsSystem Spec
.

17 Mar 2013   #12

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Hi si
You may like check the order that updates are installed, as there is a problem with .NET 4.

Quote   Quote: Originally Posted by theog
Hi Noel
Done a clean reinstall.
1) Installed Windows 7 x32 Pro
2) Installed SP1.
3) Installed All updates, but not IE 10 & KB982670 .NET 4 Client Profile installer.
4) Installed .NET 4 Client Profile , Lost updates (error code 8024402C), Uninstall . NET 4.
5) Manually Installed .NET 4 Client Profile, Lost updates.(error code 8024402C)
6) Manually Installed .NET 4.5, updates back, installed updates.
7) Installed IE 10. All OK.
Ray.
More info in
8024402C Windows Check for Update error
My System SpecsSystem Spec
17 Mar 2013   #13

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

Thanks.

It works fine.

Best thing is to skip nf4 completely. after installing your updated media, run the nf4.5 slim installer. Works great.
My System SpecsSystem Spec
.


17 Mar 2013   #14
Microsoft MVP

 

OK here is what I get when I run v.2.7z as Admin:

TEST -Update 7 installation media-capture.png

I Took Ownership of the ISO files and the downloaded Updates.

Note that when I returned ei.cfg file to the extracted ISO files it insists on naming itself ei.cfg.bak no matter if I change it. Does it need to be there?

Will try extracting ISO again and leave it intact.

Re-extracted everything again and still get the same errors. A preceding error is not able to be snipped which says the image is already mounted.

TEST -Update 7 installation media-capture1.png


My System SpecsSystem Spec
17 Mar 2013   #15

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

That is the problem then.

Unmount the image - may have been there a while.

DISM /UNMOUNT-WIM /MOUNTDIR:c:\mount /DISCARD

Might add in a check for that to the cmd file at some stage.

Quote:
Note that when I returned ei.cfg file to the extracted ISO files it insists on naming itself ei.cfg.bak no matter if I change it. Does it need to be there?
No, it doesn't need to be there - if it is there, it is renamed so it does nothing.
My System SpecsSystem Spec
17 Mar 2013   #16

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

New version on it's way in a few mins.

Thanks, Greg.
My System SpecsSystem Spec
17 Mar 2013   #17

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

Ok, I put in to check for mounted images. Also new updated NF4.5 - Rick just did it.

UPDATE7v3.zip

https://skydrive.live.com/?cid=B0A22...89320E3247!216
My System SpecsSystem Spec
18 Mar 2013   #18
Microsoft MVP

 

I got it to start mounting the image and says the operation was successful but then produces an error about NF3.5 and starts over mounting the image again but this time with 10 more Updates. Is this to be expected?

TEST -Update 7 installation media-untitled3.png


My System SpecsSystem Spec
18 Mar 2013   #19

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

It is trying to install .msu or cabs from a list of folders.

One of those folders is the "%upsdir%\.NET Framework 3.5.1 Updates".

(%upsdir% is the folder of updates you browsed to earlier )

If the folder isn't there - or doesn't contain any msu or cabs - then you will get that message.

It will just carry on to the next step.

Not clear to me why you didn't download the NF updates with WUD?

It only mounts the image once.

When you see dism start again - it is beggining to integrate updates from the next folder. It isn't mounting again.


It is quite simple , this is what it is doing:

1. It mounts the image you selected:

dism.exe /Mount-Wim /wimfile:"%wimpath%" /index:%wimindex% /MountDir:"mount"

2. It integrates any msu or cab files from the following folders one after the other:

Dism /IMAGE:"mount" /ADD-PACKAGE /PACKAGEPATH:"%upsdir%\Security Updates"
Dism /IMAGE:"mount" /ADD-PACKAGE /PACKAGEPATH:"%upsdir%\.NET Framework 3.5.1 Updates"
Dism /IMAGE:"mount" /ADD-PACKAGE /PACKAGEPATH:"%upsdir%\Non-Security Updates"
Dism /IMAGE:"mount" /ADD-PACKAGE /PACKAGEPATH:"%upsdir%\Optional Updates"

There is a bit of fiddling about finding paths, checking things and popping in a few reg entries. but the above is pretty much what it does.
My System SpecsSystem Spec
18 Mar 2013   #20
Microsoft MVP

 

I selected everything you suggested in the Downloader choices. Should I download them over again in case NF 3.5 didn't download successfully?

Can you tell what the problem is with integrating it from the DISM log, or does the error generated already tell you NF 3.5 is not going to integrate?
My System SpecsSystem Spec
Reply

 TEST -Update 7 installation media




Thread Tools



Similar help and support threads for2: TEST -Update 7 installation media
Thread Forum
Windows Media Center audio test with SPDIF Sound & Audio
Can't Boot Computer (Media Test Failure) General Discussion
media test failure:check cable BSOD Help and Support
Social Media Sobriety Test News
pxe-e61 :media test failure, check cable??? BSOD Help and Support
Problem with Test Update 6 General Discussion
New Test update for RC Software

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:42 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33