Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No Signed Device Drivers Found?

23 Mar 2013   #1
sharkguys

Windows 7
 
 
No Signed Device Drivers Found?

I just finished making a custom computer. I am trying to go through the procces of installing Windows 7 on the computer. But when I try to find a driver to install it on nothing comes up. If I browse I can find somewhere to install it but it will not find the Hard Drive. What am I doing wrong? I am really new at this so I may need a lot of help... Here is my system.

Asus p8 z77-v pro motherboard

Corsair XMS3 16GB Memory DDR3 1333 RAM (2x8)

Intel BX80637I53450 Core i5 Processor i5-3450 3.1GHz 5.0GT/s

Western Digital 500GB Caviar Blue 3.5" SATA 3

XFX Core Edition FX-787A-CNFC Radeon HD 7870 GHz Edition 2GB 256-bit GDDR5


My System SpecsSystem Spec
.
23 Mar 2013   #2
Ztruker

Windows 10 Pro X64
 
 

the Asus p8 z77-v pro motherboard uses UEFI, not BIOS so the install process may be different, see here: UEFI (Unified Extensible Firmware Interface) - Install Windows 7 with
My System SpecsSystem Spec
23 Mar 2013   #3
sharkguys

Windows 7
 
 

I looked at that and Followed it. I got it to show the uefi and i started the windows 7 install from that. But It still is not showing any drivers.... I can search for drivers if I put the cd that came with the motherboard... Also from something I saw on another fourm I changed the Sata Mode Selection to IDe. Is this right Mode? The other modes are AHCI and Raid. I did follow that fourm and changed my secure boot to other OS. Whats Wrong?
My System SpecsSystem Spec
.

24 Mar 2013   #4
gregrocker

 

Unless you have an SSD that suggests IDE mode I would use the more modern AHCI setting.

The drivers should be in the installer. If not you should be prompted for drivers. What are you trying to do when it says "no signed drivers?" Can you just proceed and ignore it?.

Afterwards get online by installing the LAN driver if necessary to run all Important and Optional Updates after enabling Automatically deliver drivers via Windows Update (Step 3) . This should handle most drivers so that you only need to import any still missing in Device Manager after all rounds of Updates are done.
My System SpecsSystem Spec
24 Mar 2013   #5
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Quote   Quote: Originally Posted by sharkguys View Post
I looked at that and Followed it. I got it to show the uefi and i started the windows 7 install from that. But It still is not showing any drivers.... I can search for drivers if I put the cd that came with the motherboard... Also from something I saw on another fourm I changed the Sata Mode Selection to IDe. Is this right Mode? The other modes are AHCI and Raid. I did follow that fourm and changed my secure boot to other OS. Whats Wrong?
To install the best drivers for your MOBO use the ASUS drivers CD
or download from here:
http://uk.asus.com/Motherboards/Inte...55/P8Z77V_PRO/
My System SpecsSystem Spec
24 Mar 2013   #6
sharkguys

Windows 7
 
 

When It says No signed device drivers found I can't do anything. I can put the Cd that came with the motherboard and Look for drivers there. The CD has the driver Raid and also chip which are the two I have been trying to get to work. If I do manage to get it to work and install it It asks where I want to install windows 7 and that is blank too. I tried the link you gave me but this is a custom computer that has no OS on it. I read somewhere that it could be a bad windows 7 CD? I don't know if that is true. Also I am using a windows 7 refurbished CD That people use to put WIndows 7 on refurbished Pcs. The guy said at the computer store that it should work but I am thinking I may have to buy a Nonrefurbished one.
My System SpecsSystem Spec
24 Mar 2013   #7
bobkn

Windows 7 Pro X64 SP1
 
 

You shouldn't need any additional drivers to install Win7 on a P8Z77-V Pro. I'm not sure that would be true if you were installing onto multiple hard drives configured as a RAID array, but it sounds like you're not doing that.

There are drivers that you might need, but you can add them after the Windows installation is complete.

I don't know what a "refurbished" Win7 install disk might be, but it sounds like a pirated/hacked copy. The least expensive more-or-less legitimate copy of Win7 (slightly less than legitimate, as regards the license agreement) is a System Builder copy, such as:

Microsoft Windows 7 Home Premium SP1 64-bit - Newegg.com

According to its EULA, it's only for PCs built for resale, but I believe that many people use it for homebuilt systems.
My System SpecsSystem Spec
24 Mar 2013   #8
sharkguys

Windows 7
 
 

I am thinking it my be a pirated copy of the software. Its weird that It cannot find the drivers it needs to install windows 7. So your saying I don't need the motherboard CD to install Windows 7 and that it should come up with the drivers itself?
My System SpecsSystem Spec
24 Mar 2013   #9
gregrocker

 

Yes, all modern SATA drivers are in the installer with very few exceptions (I've seen one).

There is no such thing as refurbished Win7. What's important is if there is a COA sticker from MS that looks like this:

Name:  coa-stickers.gif
Views: 6
Size:  495.9 KB

If there isn't then I would ask the shop to provide one as they cannot legally sell Win7 without one. If they have charged you money and will not cooperate, contact MS Customer Service to report this as if you cooperate with an investigation they will sometimes provide a free copy.

Otherwise you should buy a Builder's OEM copy which can be found online at legit retailers like NewEgg, Amazon main store, or major stores for around $89 US.


My System SpecsSystem Spec
24 Mar 2013   #10
sharkguys

Windows 7
 
 

Its called a Windows 7 Home prem Refurbished Pcs. So this could be fake?
My System SpecsSystem Spec
Reply

 No Signed Device Drivers Found?




Thread Tools




Similar help and support threads
Thread Forum
No signed drivers were found on fresh install new build.
Hello, I've read a few of the other posts but haven't been able to get it to work on mine yet. I'm getting the "no signed drivers were found" error when trying to install windows 7 64 bit on my new build. I don't have an old one to format the hard drive and partition it on. So my question is can...
Drivers
How can I get my device drivers signed for use in Windows 7 64 bit?
I have seen some of the threads listed but none have been able to get my nephew's laptop working again. It is a Toshiba Satellite Pro L450D. His hard drive got corrupted and we've lost everything. I am now trying to load windows 7 64 bit on to a brand new hard drive. I keep getting 'No Drives were...
Drivers
Cannot install Win7-no signed device drivers were found.
My new PC & Win7 are having an NTLDR misiing drama. so trying to reinstall win7. "Cannot install Win7-no signed device drivers were found." i have a genuine win7CD motherboardCD windows driversCD. Where on earth are these missing drivers?
Drivers
No signed device drivers were found
I just build my pc and installing a clean windows ultimate 64bit install and my 500gb d caviar grenn istn showing up i get this error No signed device drivers were found how can i fix this so my hdd will show up. amd athlon ii x4 gigabyte a75-ud4h msi r6670r 1gb gddr5 8 gb komputerbay...
Installation & Setup
Friend can't install, No signed device drivers were found
This is going to be difficult since I am the middle man here, but here it goes. A few months ago I sent my friend a Windows 7 DVD for his new computer that he built, and everything went fine. Earlier this week he was building another one, using the same HDD and disk and he kept getting errors...
Installation & Setup
No signed device drivers were found.
Load Driver. No signed device drivers were found. Make sure that the installation media contains the correct drivers, and then click OK. I just installed a new HDD. Specs: Hitachi 500GB P/N: 0F15629 S/N: JE3VM9HK MLC: JPT50E
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:25.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App