Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't find drivers during Windows 7 ultimate x64 installation?

04 Apr 2013   #1
Andrew

Windows 7 Home Premium x64
 
 
Can't find drivers during Windows 7 ultimate x64 installation?

Alright I'm trying to do a custom installation of windows 7 ultimate, after finding out my computer won't boot. But then it says there were no drivers found. Where do I find my drivers? There is only an X: (boot) drive as a system partition.

I have an Acer Aspire V3-551 with an AMD A8 2.8 Ghz processor with 500 GB of HDD space and 4 GB DDR3. I am have been running Windows 7 Home Premium 64-bit on my computer.

Thanks


My System SpecsSystem Spec
.
04 Apr 2013   #2
Golden
Microsoft MVP

Windows 7 Ult. x64
 
 

Hi Andrew,

Are you talking about drivers or drives?

Windows will detect 99.9% of the appropriate drivers required for your computer to operate during installation, and install them automatically. After installation, you can install/update specific device drivers if you wish.

Clean Reinstall - Factory OEM Windows 7

Regards,
Golden
My System SpecsSystem Spec
04 Apr 2013   #3
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

Using the above tutorial should help you out. You should not have to install any drivers during the install. Make sure you burn the dvd at no more then 4x speed.

Post back if you still need help.

And here`s another....

Clean Install Windows 7
My System SpecsSystem Spec
.

04 Apr 2013   #4
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

How to load Sata controller driver.
SATA Driver - Load in Windows 7 or Vista Setup
My System SpecsSystem Spec
Reply

 Can't find drivers during Windows 7 ultimate x64 installation?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
windows 7 installation cannot find drivers?
well when i boot from my windows 7 retail upgrade disk to do a clean install, it say's it cant find the drivers or something and notes that i can take the disk out to put one in for it if i have one, or browse my hard drive but what the hell is it going on about? do i need to install windows 7...
Installation & Setup
Unable to find any Windows 7 Ultimate 64 bit drivers HP Pavilion PC
Model: HP Pavillion PC Desktop Model #A1720N Product# RT641AA #ABA 1.8ghz Operating System: Windows 7 Ultimate 64 bit Recently a friends husband screwed up their computer they just got by looking at tons of porn sites. Since they had no security at all, I'm sure you can imagine what was on...
Drivers
misplaced driver installation cd, where can i find win7 drivers?
I have lost my driver installation CD. My computer crashed earlier this week and am not sure what drivers I even need to reinstall so that I can reinstall the OS. Can somebody point me in the right direction?:o
Drivers
Windows can't find network drivers for installation
Evening all, I have just placed a 2nd hand mobo (ASRock M3A770DE) into my pc. It'ts running win 7 ultimate, all h/w is detected ok apart from the integrated network card, therefore i cannot connect to the router and onto the internet. Since win7 is not auto-detecting the integrated NIC, is their...
Drivers
Cant find HDD for Windows 7 installation...
I tried installing Fedora 13 64 bit OS with dual booting enabled on my Windows 7 Ultimate OS. The partitions were 257 GB dedicated entirely for Windows (C: Drive) and the remaining 50 GB was allocated for Fedora installation. I made grub as the default bootloader handler and completed the...
Installation & Setup
Can't find my hdd during windows installation
Hi there, I've been trying for around 6 hours today to get my new computer up and running, but I've run into a problem, my sata disk wont be located during the windows 7 installation. "No drives were found" I've turned on AHCI and I've downloaded drivers from Gigabyte's homepage, but I get the...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:39.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App