Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "load device drivers" prompt while installing windows 7 via usb


24 Apr 2013   #1

Windows 7 Home Premium 64bit
 
 
"load device drivers" prompt while installing windows 7 via usb

Hi great guys at SevenForums. its me again...and this damn ASUS. anyway, I have attempted to install windows 7 via usb to my system(system specs under profile), but i receive a prompt about device drivers and i cannot continue. The image is an original .iso for windows 7 home premium, downloaded from digital river using a direct download. the usb is a 4Gb transcend. note: (windows device manager says the drivers for both usb and hdd are most current, and devices are working properly.) oh, My hdd is a Seagate 5400.6 320Gb internal laptop drive. i burned .iso to usb using UUI. I do not have any dvd's to use, i had 1, but i wasted tryind to burn winRE to disk. hdd has been formatted by windows to accept install but it will not. PLEASE HELP GUYS! You guys helped me with bad memory modules on sevenforums before, i hope that there is a guru for this issue too...all the thanks, Fedaru.

I read on another post about removing disk drive before install but this asus notebook is like fort knox! i would have to remove a cover like 10 screws, and that may void warranty.


My System SpecsSystem Spec
.

24 Apr 2013   #2

Microsoft Community Contributor Award Recipient

Windows 7 Ult. x64 Windows 8.1 x64
 
 

Hi Fedaru,

I have seen this message before if the USB drive you are installing from, is inserted into a USB3 port. This happens because USB3 ports require 3rd party drivers, and the drivers only make the port fully available after Windows 7 has loaded.

Can you check to see that it is inserted into a USB2 port? If so, try inserting into a different USB2 port, and trying the installation again.

Regards,
Golden
My System SpecsSystem Spec
24 Apr 2013   #3

Windows 7 Home Premium 64bit
 
 

thanks Golden. I will try and post back with details. stay tuned...
My System SpecsSystem Spec
.


24 Apr 2013   #4

Windows 7 Home Premium 64bit
 
 

UPDATE: driver prompt no longer appearing...YEESSSS!

STATUS: Windows currently expanding files at %50

CONCLUSION: thank you's are in order...Thanx Golden- GOD BLESS GURU'S!lol.
My System SpecsSystem Spec
24 Apr 2013   #5

Microsoft Community Contributor Award Recipient

Windows 7 Ult. x64 Windows 8.1 x64
 
 

Its a pleasure

Please mark this as solved for others that have the same issue.
My System SpecsSystem Spec
24 Apr 2013   #6

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by fedaru View Post
update: Driver prompt no longer appearing...yeessss!

Status: Windows currently expanding files at %50

conclusion: Thank you's are in order...thanx golden- god bless guru's!:dlol.


"sevenforums rock!"
My System SpecsSystem Spec
24 Apr 2013   #7

Microsoft Community Contributor Award Recipient

Windows 7 Ult. x64 Windows 8.1 x64
 
 

Of course we do
My System SpecsSystem Spec
Reply

 "load device drivers" prompt while installing windows 7 via usb




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:52 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33