Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "load device drivers" prompt while installing windows 7 via usb

24 Apr 2013   #1
fedaru

Windows 7 Home Premium 64bit
 
 
"load device drivers" prompt while installing windows 7 via usb

Hi great guys at SevenForums. its me again...and this damn ASUS. anyway, I have attempted to install windows 7 via usb to my system(system specs under profile), but i receive a prompt about device drivers and i cannot continue. The image is an original .iso for windows 7 home premium, downloaded from digital river using a direct download. the usb is a 4Gb transcend. note: (windows device manager says the drivers for both usb and hdd are most current, and devices are working properly.) oh, My hdd is a Seagate 5400.6 320Gb internal laptop drive. i burned .iso to usb using UUI. I do not have any dvd's to use, i had 1, but i wasted tryind to burn winRE to disk. hdd has been formatted by windows to accept install but it will not. PLEASE HELP GUYS! You guys helped me with bad memory modules on sevenforums before, i hope that there is a guru for this issue too...all the thanks, Fedaru.

I read on another post about removing disk drive before install but this asus notebook is like fort knox! i would have to remove a cover like 10 screws, and that may void warranty.


My System SpecsSystem Spec
.
24 Apr 2013   #2
Golden
Microsoft MVP

Windows 7 Ult. x64
 
 

Hi Fedaru,

I have seen this message before if the USB drive you are installing from, is inserted into a USB3 port. This happens because USB3 ports require 3rd party drivers, and the drivers only make the port fully available after Windows 7 has loaded.

Can you check to see that it is inserted into a USB2 port? If so, try inserting into a different USB2 port, and trying the installation again.

Regards,
Golden
My System SpecsSystem Spec
24 Apr 2013   #3
fedaru

Windows 7 Home Premium 64bit
 
 

thanks Golden. I will try and post back with details. stay tuned...
My System SpecsSystem Spec
.

24 Apr 2013   #4
fedaru

Windows 7 Home Premium 64bit
 
 

UPDATE: driver prompt no longer appearing...YEESSSS!

STATUS: Windows currently expanding files at %50

CONCLUSION: thank you's are in order...Thanx Golden- GOD BLESS GURU'S!lol.
My System SpecsSystem Spec
24 Apr 2013   #5
Golden
Microsoft MVP

Windows 7 Ult. x64
 
 

Its a pleasure

Please mark this as solved for others that have the same issue.
My System SpecsSystem Spec
24 Apr 2013   #6
fedaru

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by fedaru View Post
update: Driver prompt no longer appearing...yeessss!

Status: Windows currently expanding files at %50

conclusion: Thank you's are in order...thanx golden- god bless guru's!:dlol.


"sevenforums rock!"
My System SpecsSystem Spec
24 Apr 2013   #7
Golden
Microsoft MVP

Windows 7 Ult. x64
 
 

Of course we do
My System SpecsSystem Spec
Reply

 "load device drivers" prompt while installing windows 7 via usb




Thread Tools





Similar help and support threads
Thread Forum
Need help with installing Windows 7 "CD/DVD device driver is missing"
Been trying to fix this problem for 2 days now. First tried to boot with disc and got the driver error, I formatted a usb and got the same error. Tried changing sata from ahci to Ide, or raid did not work. updated my bios, tried installing the new drivers for my sata ports on my mobo, didnt work....
Installation & Setup
When I click "install now", it's saying "No device drivers were found"
Ok, now I get another problem... When I click "install now", I get a msg box that is saying 'no device drivers were found. Make sure that the installation media contains the correct drivers, and then click OK' What should I do now?
Installation & Setup
installing windows 7 "No device drivers were found"
I have a HP ML110g5 server which I have disconnected the smart array and connected a HDD via sata directly to the motherboard. when installing windows 7 "No device drivers were found etc." does anyone know where I can get the drivers (I assume for the HDD) so windows will recognise where to...
Drivers
Fixed "Unable to load RAID drivers for Windows 7 installation"
Hi Everyone, I am currently attempting to install Windows 7 on an SSD RAID Array, and I have encountered several issues (this has been a one step forward, two steps backward affair). The issue that I am currently facing is the fact that I am unable to load RAID drivers during the OS...
Installation & Setup
How to identify "other" PCI device that did not load correctly?
guys - I'm rebuilding/resurrecting a laptop - a past-generation gaming asus unit, core 2 duo, nvidia, etc etc. its all loaded up and running, but in device manager are listed a parent "unknown" device with three sub-components underneath, unknown. so I need to fetch device drivers, but don't know...
Hardware & Devices
Windows 7 Installation Error "No Device drivers"
Hi.. i have sony vaio laptop with windows 7 home edition now i want to install windows 7 pro in my laptop.. i have the ISO of win pro, because my CD drive not working i m trying to install from the USB .. windows setup started but it shows error when i click "Install Now" "No device drivers...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:37.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App