Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Win 7 laptop freezes on boot with 2 sticks of ram, but fine with 1

02 May 2013   #21
sparkes81

win 7
 
 

Yeah I'd have to agree.

I'm so mad because when I first bought this laptop (I got it really cheap because the power board was blown.) I replaced the power board and all was fine except I had issues with it switching off when ever the battery was inserted. I bought and tried a second battery but it was the same, so I bought another SATA MOBO but still the problem persisted. After googling around some more, I convinced myself to try a third battery. Then I saw a bundle of parts for this laptop on ebay including an IDE MOBO, battery, screen, HDD and a few other peripheries, all going for 25 so I snapped it up. True enough when I tried the third battery everything was fine and it was the old battery that was faulty.

Then foolishly I resold the SATA MOBO on ebay, man I wish I hadn't now. But this is why I have all these spare parts for it.

Sigh, looks like I'm gonna have to keep an eye out for another SATA MOBO now.

Thanks for you help. :-)


My System SpecsSystem Spec
.
02 May 2013   #22
VistaKing

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit
 
 

Your welcome
My System SpecsSystem Spec
02 May 2013   #23
gregrocker

 

If the RAM sticks were common to both mobo's you tried and the problem returned, maybe you can resolve it by cleaning the slots even better, or testing RAM - Test with Memtest86+ again to isolate the stick that is bad.

Are you sure the RAM is spec'd exactly for the mobo?

Quote   Quote: Originally Posted by sparkes81 View Post
You are not going to believe this but after removing and replacing the IDE MOBO and HDD with the original SATA MOBO and HDD, and reassembling the laptop, I thought I would give the two sticks of RAM another try. And its just booted up fine.

How bizarre is that? I'm back to how the machine was before I foolishly tried to install Win7 64bit. I think I'm going to leave well enough alone now.

The only thing I did was to blow some air between the connections in and around the ram slots, as I could see some dust between them. Fingers crossed this will be the end of my issues now and the laptop will continue to function as it always has.

Will keep you posted. :-)
My System SpecsSystem Spec
.

02 May 2013   #24
sparkes81

win 7
 
 

Quote   Quote: Originally Posted by gregrocker View Post
If the RAM sticks were common to both mobo's you tried and the problem returned, maybe you can resolve it by cleaning the slots even better, or testing RAM - Test with Memtest86+ again to isolate the stick that is bad.

Are you sure the RAM is spec'd exactly for the mobo?

Quote   Quote: Originally Posted by sparkes81 View Post
You are not going to believe this but after removing and replacing the IDE MOBO and HDD with the original SATA MOBO and HDD, and reassembling the laptop, I thought I would give the two sticks of RAM another try. And its just booted up fine.

How bizarre is that? I'm back to how the machine was before I foolishly tried to install Win7 64bit. I think I'm going to leave well enough alone now.

The only thing I did was to blow some air between the connections in and around the ram slots, as I could see some dust between them. Fingers crossed this will be the end of my issues now and the laptop will continue to function as it always has.

Will keep you posted. :-)

hi mate as I posted previously, the laptop has been running win 7 32bit for over a year without issue. The ram is definitely the correct type for the laptop. I have run memtest for over 8 hours without errors and have run the laptop with a substitute IDE MOBO with both sticks of ram without issue. The laptop ran fine for a few boots after putting the original SATA MOBO back in but then sadly reverted to freezing again.

I will try cleaning the slots tho, good idea. :-)

Thankyou for your thoughts, all help gratefully received. :-)
My System SpecsSystem Spec
02 May 2013   #25
gregrocker

 

Remember that RAM isn't properly tested in cases like these until its really stressed for 6-8 passes or overnight, and that testing the slots is equally important.
My System SpecsSystem Spec
03 May 2013   #26
sparkes81

win 7
 
 

Well I dont understand it but after many hours trying to get my system working with both sticks of ram with Win7, I've given up.

I have now installed windows 8 with no hardware changes and its running fine with both sticks of ram. And its 64bit too.

Thanks for all your help guys.

While we cant really call this one resolved, I have a certain sense of satisfaction now. :-)
My System SpecsSystem Spec
04 May 2013   #27
Ztruker

Windows 10 Pro X64
 
 

Well, not to be a wet blanket, but Windows 8 uses less resources than Windows 7 so it's possible you have not hit the problem yet.

I sure hope that is not the case though!!!!
My System SpecsSystem Spec
Reply

 Win 7 laptop freezes on boot with 2 sticks of ram, but fine with 1




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
boot keypress laptop freezes
Hi all, I have a compaq presario laptop , When I press any key at windows boot manager it freezes to the same screen and I am not able to select windows of my choice...it works fine when window stars and even when I enter the bios. I also observed when I boot my laptop from bootable...
Installation & Setup
AsRock h55m-LE won't boot up with 2x4G DDR sticks
Hey, I just got a brand new mobo, AsRock h55M-LE. I got KHX1600C9D3K2/8GX (2x4GB) 1600MHz DDR3 CL9 XMP memory sticks. When I try to boot up with one stick which is in slot DDR-B, the comp works. If I put another stick in DDR-A, comp boots up for 5-7 seconds and reboots. I use only one stick in...
Hardware & Devices
Problem with RAM sticks. Not usable? Gateway Laptop.
Heh.. Kinda new to this forum so yeah. Kinda getting a bit desperate about this. I've had a Gateway NV53A Laptop for about a year and a few months. No problems with it. Only problem I've found so far? It's REALLY slow. I mean on everything. Opening something, closing, shutting down,...
General Discussion
laptop wont boot sticks on windows logo
trying to solve a problem on a dell inspiron n5010 running windows 7 when you switch it on it goes to the black boot up screen and you are given these options Launch startup repair(recomended) start windows normally if i select start windows normally it goes to the windows start up logo but...
General Discussion
Windows 7 does not boot with 4 ram sticks (16gb)
I have just built a new pc with the following (all new components 6/17/2011): os: win7 64bit mb: asus m5a88-v evo hd: seagate 1.5tb 6gb/s ram: g.skill ddr3 4gb each stick (3 installed) I had a hard time trying to install windows until I disconnected the blueray dvd (sata) and pulled out 2 of...
Hardware & Devices
RAM... Two sticks, three sticks, dual channel, triple channels, huh?
I ordered some computer stuff at 4a.m. and I had a major brainfart when doing so. I ordered some Crucial ram that came in 2GB sticks, Newegg.com sold is in doubles and triple packs, my thought was well, 6GB is better then 4GB when ordering but after doing so I thought, wait, don't you normally...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:43.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App