Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Clean install win 7 x64. Starting setup services loop/DiskPart error.

20 Jul 2013   #1
k1p

Windows 7 Ultimate x64
 
 
Clean install win 7 x64. Starting setup services loop/DiskPart error.

Hi,


I've tried suggestions around this forum but everyone had a different reason to why it came to this error so i'm trying to explain how i got to this error because this is really stressing me out.

I'm having problems with my windows 7 ultimate x64 install on a toshiba satiellite laptop..My laptop was restarted right when I was in the last stages of Completing installation and now I'm stuck in a loop "starting setup services" and then after there is another error saying " The computer restarted unexpectedly........installation cannot proceed...... click OK and the restart the installation".

At this point I press shift + f10 to open command prompt and try diskpart because I had to do the same thing on the laptop I'm on now. It worked on this one (an HP). But on the toshiba I get to "list disk" and well there is ONLY Disk 0. I "select disk 0" and it says it's selected and I type "clean"/"clean all" but I have an error "virtualdisk service error: clean is not allowed on the disk containing the current boot....etc".

-i cant do clean install/format that i need to do or is there another way besides diskpart?

-my windows disk is one i created from an iso. it's not burned into the DVD RW (could this be the problem?) i read somewhere that to install win 7 on a toshiba it must be burned.

-i actually had windows 7 x32 installed but i wanted x64 because the computer came with x64 but i was having problems so i put on x32 because it was smaller and did fix my problem.but now i need x64 because most of the laptops drivers that i put back on are only for x64! sorry a confusing part...

-windows installed perfectly during the x32. x64 is my problem. by the way both installs were done by using files from the iso so i didnt use a disk with the x32 install but during the x64 i used a non-burned iso files version to install.

-when i go in safe mode it has an error that the installation can't be completed in safe mode.

-i used custom install

-i have a 4gb usb and some extra empty DVD+RW that are 4.7gb if that info helps somehow..

so...what am i supposed to do now? do i create another disk in DiskPart(if so how?)

while waiting for a reply i'll search around here more there might be a post i missed..thanks in advance for helping me


My System SpecsSystem Spec
.

20 Jul 2013   #2
gregrocker
Microsoft MVP

 
 

The problem is you're not booting the installer to do the Clean command. Follow these steps which overcome almost all install failures and will set you up for the perfect install shown in Clean Reinstall - Factory OEM Windows 7

Unplug all other HD's and peripherals,

Boot into BIOS setup, reset to defaults, save changes. (If an EFI BIOS you'll need to decide if you want UEFI BIOS vs. Legacy BIOS. If UEFI follow these special steps for Install, otherwise enable Legacy BIOS or Compatibility Support Module to proceed with normal install.) Set DVD drive first to boot, HD second, set SATA controller to AHCI, Save changes and Exit.

Then boot into Windows 7 installer DVD or flash stick burned or written using tool and latest ISO for your licensed OS version here.

At first installer screen Press Shift + F10, or enter System Recovery Options to open a Command Box, type:

DISKPART
LIST DISK
SELECT DISK 0 (after confirming Windows 7 target HD #)
CLEAN
CREATE PARTITION PRIMARY
FORMAT FS=NTFS LABEL="WINDOWS 7"
ACTIVE
EXIT
EXIT

Next click Install Now, then Custom install to Clean Install Windows 7 to the partition you created. If it fails then report back at which step and the verbatim error message.

In addition read over these steps to understand the tools and methods which work best to get and maintain a perfect Clean Reinstall - Factory OEM Windows 7. The steps are the same for retail.

After install you can adjust partition size or Create new partitions for data, etc. in Disk Mgmt. You are creating the partition here for the purpose of wiping the HD and marking Active which overcomes certain install failures.
My System SpecsSystem Spec
20 Jul 2013   #3
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Quote:
I'm having problems with my windows 7 ultimate x64 install on a toshiba satiellite laptop..My laptop was restarted right when I was in the last stages of Completing installation and now I'm stuck in a loop "starting setup services" and then after there is another error saying " The computer restarted unexpectedly........installation cannot proceed...... click OK and the restart the installation".
Where do you buy your Windows 7 DVD & Product Key from?
My System SpecsSystem Spec
.


Reply

 Clean install win 7 x64. Starting setup services loop/DiskPart error.




Thread Tools





Similar help and support threads
Thread Forum
Setup is Starting Services Loop
Hi, I tried to install Windows 7 on my new asus computer, now in some point i got an error "The computer has restarted unexpectedly or encountered an unexpected error. Windows installation cannot proceed. To install Windows click OK to restart the computer, and then restart the...
Installation & Setup
Setup is starting services "loop" No Repair or installation Disk
Hi Everybody, I'm really in need of some help or advice with my laptop Specs below: Acer Aspire 5742 Intel i5-480M 6GB DDR3 Intel Graphics It started when I needed to take the computer back to factory default with a fresh install. It was going back to Acer to have the charger point...
Installation & Setup
Re-Installing windows - Setup is starting services then error.
Hi, my laptop wouldn't start up and came up with an error. I went back to windows when it was first purchased so I wouldn't lose my files too. Now when I start up it says "Setup is starting services" and after about 5 seconds it comes up with the error: "The computer restarted unexpectedly or...
Installation & Setup
Windows 7 'Setup is starting services'
Just tried installing windows 7 x86 on my computer. Installation seemed to be going fine up until the last stage where it gets stuck on 'Setup is starting services'. I have tried shift + f10 and disabled my video card yet the same message comes up. Any help would be appreciated! I was using...
Installation & Setup
Windows 7 hung on setup is starting services
this is what i have done so far. got a win 7 dell pc, a vostro 400 to be precise. installed all apps and settings that we need on our desktops. then i used sysprep to run the OOBE and generalize switch, then booted into windows PE to capture an image .wim file of the entire isntallation. this .wim...
Installation & Setup
Setup is Starting Services
Alright, so I downloaded Windows 7 last week onto my memory stick, and just tried installing it last night. Seems like I ran into a HUGE problem. The setup was going quickly and smoothly choose clean install. Until I got to the very end when it seems like it froze at "Windows is Completing...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:19.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App