Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: a secondary drive marked as system drive?

29 Oct 2013   #1
chris2busy

win 7
 
 
a secondary drive marked as system drive?

Hello forum friends!
This morning i did a fresh install of windows 7 pro 32 bit.
my rig has as main disk a 60gb ssd , and 3 secondary drives for multimedia storage and backups.
as i was selecting the drive i wanted to install the windows 7 on, it appeared that one of the drives had a "system" characterisation, as opposed to the other drives that were "logical drives"..i went ahead and installed the os, just fine, but it really troubled me.
what could it mean?why is the secondary drive i use to store family photos and videos characterized as "system drive" ?

thanks in advance for the time you to took to answer/read this.


My System SpecsSystem Spec
.
29 Oct 2013   #2
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

My System SpecsSystem Spec
29 Oct 2013   #3
gregrocker

 

System means its the partition booting OS. The new install might have placed its boot files there if the other drives were not unplugged during the install as they always should be.

After posting back the requested screenshot of Disk Management - Post a Screen Capture Image, unplug all but the new install SSD to see if it will boot itself. If not Mark Win7 or its 100mb System Reserved (preferred if you have it) Partition Active then run Startup Repair - Run up to 3 Separate Times until the SSD boots itself.

Then when you plug back in the other HD's, mark the erroneous System drive Inactive: Partition - Mark as Inactive - Windows 7 Forums, make sure the SSD remains set first drive to boot in BIOS setup.
My System SpecsSystem Spec
.

29 Oct 2013   #4
chris2busy

win 7
 
 

Sure mate!
Here you go.


Attached Thumbnails
a secondary drive marked as system drive?-disk-managment.jpg  
My System SpecsSystem Spec
29 Oct 2013   #5
chris2busy

win 7
 
 

Quote   Quote: Originally Posted by gregrocker View Post
System means its the partition booting OS. The new install might have placed its boot files there if the other drives were not unplugged during the install as they always should be.

After posting back the requested screenshot of Disk Management - Post a Screen Capture Image, unplug all but the new install SSD to see if it will boot itself. If not Mark Win7 or its 100mb System Reserved (preferred if you have it) Partition Active then run Startup Repair - Run up to 3 Separate Times until the SSD boots itself.

Then when you plug back in the other HD's, mark the erroneous System drive Inactive: Partition - Mark as Inactive - Windows 7 Forums, make sure the SSD remains set first drive to boot in BIOS setup.
So, if that is the case, as long as i do not remove the secondary drive that may or may not contain bootloader(or whatnot), i should be okay to run like that, right?

Or would leaving it that way, could cause some sort of implication? I am kinda "if it ain't broke, don't fix it" , theory supporter.
I just ask for learning purposes
My System SpecsSystem Spec
29 Oct 2013   #6
gregrocker

 

It's not correct. The Win7 drive should be booting itself and not dependent upon some data drive.
My System SpecsSystem Spec
29 Oct 2013   #7
chris2busy

win 7
 
 

wait...it is not showing up for you?
maybe i did something wrong...the screenshot is posted 2 posts ago..i will give it 1 more shot here.


Attached Thumbnails
a secondary drive marked as system drive?-disk-managment.jpg  
My System SpecsSystem Spec
29 Oct 2013   #8
gregrocker

 

Sorry I missed the screenshot.

The System (partition booting Win7) and Active (pointer to System partition) flags are set correctly on C.

The only potential problem is data drive E marked Active, when only the System drive should be Active. Best to mark it Inactive now: Partition - Mark as Inactive - Windows 7 Forums

A lesser concern is that if you run repairs or reinstall the System boot files may place themselves on a preceding Primary partition, so it's always best to have your OS drive is DISK0 position if that is an optimal port for it to be plugged into. If you move it be sure it remains set to boot first in BIOS. If not I would monitor that the System flag doesn't get moved to D during a repair or reinstall.
My System SpecsSystem Spec
29 Oct 2013   #9
chris2busy

win 7
 
 

Thanks bro!
That was alot of help!
Cheers!
My System SpecsSystem Spec
29 Oct 2013   #10
gregrocker

 

Glad to help. Feel free to ask any time.
My System SpecsSystem Spec
Reply

 a secondary drive marked as system drive?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
BOOTMGR is on the wrong drive? Partition marked as SYSTEM
Hello all, Just got a new motherboard yesterday so I hooked it all up, connected the SATA hard drives in the same position ports on the new motherboard as they were on the old one. Re-installed WIndows 7, and it's working fine. Installed onto C:\ which is correct, however I noticed that the 'boot'...
Installation & Setup
The wrong drive is marked as "system"
I recently installed Windows 7. I have four partitions . Windows is installed on C:, and I also have D: , E: and G: as storage partitions . However, although C: is the boot partition it managed to mark G: as the system partition. This is causing a few problems with the Windows 7 backup feature...
General Discussion
Deleted System reserved partition on secondary hard drive
I've had two disks: 1- SSD drive with OS 2- HDD with 4 partitions + system reserved Because i wanted to get rid of system reserved partition i've deleted and extended one of those 4.. After that i formated and installed windows 7 x64 on my SSD. Right now the hdd partitions won't show up, and...
Backup and Restore
Secondary Hard Drive freezes system before Windows launch
My system runs Windows 7, 64bit OS. Replaced Socket 775 Mother board and CPU with Socket 1155. ASUS was manufacturer of both old and new mobos. Kept all hard drives and reinstalled them. 2 x Seagate 350Gb Sata 3.0 (one is the boot drive with OS) 1 x Western Digital Caviar Green 1.0...
Hardware & Devices
System Reserved created on a secondary drive
Good evening posters. I'm a new member and I'm completely lost on how to fix a recent problem. My windows backup typically runs on Thursdays and last night it finished in a much shorter time than I usually expect it to. I don't know if this is related to my current problem. When I...
General Discussion
Secondary drive is system reserved - how to open?
My PC crashed, sent it back to ASUS, I think they reformatted the HD (they won't say!). Upon return I did a reinstall with the backup disks, BUT... connected the secondary hard drive before the reinstall. Big mistake, now that drive is "system reserved," and I can't access the files on it. I have...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:59.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App