Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 Device driver error desperatly need assitance!

23 Jan 2014   #1
Tuf Taxus

Windows 7 64 bit home premium/ ultiminate
 
 
Windows 7 Device driver error desperatly need assitance!

Hello all !

Just built my new pc today, all the hardware went in fine and seems to be working.

I have tried to install windows 7 by usb and the cd, both work fine until it comes to direct windows where to install and it cant find my HDD or SSD. Windows says there is no storage devices and that drivers are needed, I checked online and I found that Sata drivers come with the windows 7 install.
The SSD is new 120gb samsung evo 6gb/s it is detected in the bios and is supported.
The HDD is from my old pc it is a WD caviar black 1tb. It is detected in the bios and is supported. I know that this hard drive works fine because 4 months ago I brought it new and installed windows 7 no problems with my install disc. I formated that drive but windows still wont pick it up at the install.
I have tried formating and Partitioning the drive on another pc, the problem still remained.

The sata is set to AHCI, IDE wont work either.

Now the thing is in Diskpart in DSM I type "list disk" and get nothing meaning windows isnt seeing ethier drives. I have been here for 6 hours trying to work it out and all the other post dont have soulutions that help.

I have tried all the sata ports, windows 7 home premium and windows 7 ultimate edition both with the same issue. Starting to get really fustrated any help would be great.

My mother board is a Gigabyte GA-Z87-HD3, GPU is Asus GTX 770, CPU I5 4670k, Ram is 16 gb of corsiar vengence ram, PSU is FSP 550 CM gold.

Could this be a mother board problem?

Thanks!


My System SpecsSystem Spec
.
23 Jan 2014   #2
gregrocker

 

Change to another port.

The other HD should always be unplugged when you're installing Win7.

Reset the BIOS to defaults, SATA to AHCI, save and Exit.

If you have a UEFI BIOS you'll need to boot the installer as a UEFI device in BIOS boot menu: UEFI (Unified Extensible Firmware Interface) - Install Windows 7 with - Windows 7 Forums

or set to Legacy Mode or CSM to Bypass UEFI to Install WIn7.

For UEFI install you'll also need to use Option 1 from UEFI Bootable USB Flash Drive - Create in Windows as a file edit is required.
My System SpecsSystem Spec
23 Jan 2014   #3
Tuf Taxus

Windows 7 64 bit home premium/ ultiminate
 
 

Hello,
Thanks for the quick reply. I tried this, still the same problem.......
Im taking it to the shop today to see if its a hardware issue.
My System SpecsSystem Spec
.

23 Jan 2014   #4
gregrocker

 

You can test the hardware yourself using Troubleshooting Windows 7 Failure to Start
My System SpecsSystem Spec
23 Jan 2014   #5
Tuf Taxus

Windows 7 64 bit home premium/ ultiminate
 
 

The cpu, ram and gpu all work fine, my problem is i get the error "device driver missing" when trying to find the HDD or SSD to install windows on. Everything is completly normal up untill that stage. Could the mobo be damaged in some way?
My System SpecsSystem Spec
23 Jan 2014   #6
Tuf Taxus

Windows 7 64 bit home premium/ ultiminate
 
 

Just tried to force it to see the drives that i put on a usd, still wont find my ssd. With my hard drive and solid state drive the bios only sometimes picks it up, This has to be a sata issue on my mobo??
My System SpecsSystem Spec
23 Jan 2014   #7
gregrocker

 

I gave you a half dozen steps to try to which you've replied to none. Why?
My System SpecsSystem Spec
23 Jan 2014   #8
Tuf Taxus

Windows 7 64 bit home premium/ ultiminate
 
 

Hardware problem. Thanks very much!!!
My System SpecsSystem Spec
Reply

 Windows 7 Device driver error desperatly need assitance!




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
The driver \Driver\WUDFRd failed to load for the device... error
Hi, Since the 11/18/2012 event viewer (Event ID 219, Task Category 212) has been posting a warning: The driver \Driver\WUDFRd failed to load for the device WpdBusEnumRoot\UMB\2&37c186b&0&STORAGE#VOLUME#_??_USBSTOR#DISK&VEN (followed by name of USB device) It only occurs on start up if I...
Drivers
The driver \Driver\WUDFRd failed to load for the device error
Hi i have a couple of weeks ago installed windows and i just got bsod crash and this was the only error in the event viewer The driver \Driver\WUDFRd failed to load for the device WpdBusEnumRoot\UMB\2&37c186b&0&STORAGE#VOLUME#_??_USBSTOR#DISK&VEN_GENERIC&PROD_USB_CF_READER&REV_1. ...
BSOD Help and Support
Windows Update causes error code 52 for audio driver in Device Manager
Hello. I installed a few recommended Windows Updates on 1/15. After the update, install, and computer refresh though, my audio stopped working. I went to Control Panel and tried opening up my audio driver, HT Omega Claro Halo, but the driver wouldn't open. I then checked my Device Manager...
Sound & Audio
Windows 7 USB Device Driver Installation Error
Hi all! This is my first post and I greatly appreciate any input/help! I recently bought a refurbished Hp m6-1035dx, with OEM windows home premium 64bit. Additionally I also purchased a Samsung 830 SSD and and Optical Bay Caddy. My plan is to install the SSD in the Main Drive Bay and tranfer the...
Installation & Setup
Ricoh Device Driver Error
I am at work posting this right now. Therefore, I do not have "all" of the proper information to provide with (but will add to it later this afternoon). Anyway, my Toshiba Laptop started running slowly a few months ago, as it would make the noises like when you insert/remove a device from the USB...
Drivers
Assitance with Windows 7 Home Premium
Hello to all, I am attempting to help a relative who has Windows 7 Home Premium. I know nothing about the features of that version or how whoever set it up, set it up. Now it boots directly to explorer. His user account, only one on the machine is username and permission set to...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:00.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App