Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: UEFI reboot problem after boot to flashdrive

27 Jan 2014   #1
dianedebuda

Windows 7 Pro 64bit
 
 
UEFI reboot problem after boot to flashdrive

Building a new win7 box using Asus F2A85-V Pro with UEFI bios. Want to avoid an irritating problem found on my other Win7 box built with same mb using UEFI, GPT, Fast Boot. I boot to a flashdrive for clean system backups. Then I remove the flashdrive and try to boot "normally". The default boot device isn't found & Setup defaults to MBR. I have to reselect the UEFI partition and exit with a reset. Then Windows usually complains & I have to tell it to boot normally, sometimes twice. Not sure what's causing this; is this way UEFI is supposed to work? Or maybe it's Fast Boot or the Asus implementation of UEFI? Hopefully it's just operator error & I don't have something selected correctly in Setup. No problem with rebooting if flashdrive not involved.


My System SpecsSystem Spec
.
27 Jan 2014   #2
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Check the UEFI/BIOS firmware, make sure Windows Boot Manager is first boot device.
My System SpecsSystem Spec
27 Jan 2014   #3
dianedebuda

Windows 7 Pro 64bit
 
 

Problem is that the primary boot device changes after I do the f8 (temporary) boot to flashdrive. Have no idea why.
My System SpecsSystem Spec
.

Reply

 UEFI reboot problem after boot to flashdrive




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Asus N76 UEFI - W7 64 Install Hangs on Logo (DVD UEFI Boot)
**** This issue has been resolved **** **** Look at Page 4, posts 4 and 5 **** **** You need to enable Legacy MBR by Enabling Launch CSM in the EFI Setup **** Hello all, This is my first post. I am a Windows 7 user and now (against my will) Windows 8. I bought an ASUS N76 laptop...
Installation & Setup
Fresh Win 7 64 SP1 install on UEFI MX100 SSD won't reboot without F12
I purchased a new Dell E5540 laptop that came with Win 8.1 Pro and a 500GB HDD. I wanted to install an SSD so I cloned the HDD to a Crucial MX100 512GB SSD using a standalone dock cloner. Win 8.1 started fine on the SSD but I wanted to enable AHCI in the BIOS, which I could never get working. I...
Installation & Setup
UEFI boot keeps changing; UEFI/Win7 handshaking confusion
Trying to understand handshaking between UEFI & Win 7. Have Win7 Pro sp1 64 installed on SSD, mb=Asus F2A85-V Pro. Example: boot to flashdrive to do Acronis backup of SSD; remove SDD, insert spinner; boot again to flashdrive to do Acronis restore to spinner (to test backup); remove flashdrive, boot...
Installation & Setup
Boot UEFI from wake on lan, or convert UEFI MBR to legacy.
Hi all, Currently having a wake on lan issue with a certain computer. The machine is setup correctly but the windows boot information is stored in a 100mb UEFI partition, and when the computer wakes on lan, it will not boot windows, just sit at a blank screen. When it wakes on lan it is...
General Discussion
Fedora 15 installation won't boot in a USB Flashdrive
I'm thinking of dual booting Windows 7 with Fedora 15. I had the installer of Fedora 15 in my freshly reformatted USB flashdrive and used LiveUSB Creator to convert Fedora 15's ISO to a bootable installer in my USB flashdrive. I also had already set the BIOS to boot first the removable media...
Installation & Setup
[HELP] USB Flashdrive Problem
I'm having a problem with this particular USB flashdrive. Whenever it was inserted, USB Disk Security detects it and reports as there's no threat from malwares in the said flashdrive, but it doesn't show up in the 'My Computer' screen. I tried remapping the drive letters of some virtual drives in...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:28.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App