Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB 3 failing - Asrock A75 Pro4-m

22 Mar 2014   #1
ChrisPbass

7 Ultimate 64 bit
 
 
USB 3 failing - Asrock A75 Pro4-m

I bought a Thermaltake Blackx 5g dual USB 3 dock http://www.sevenforums.com/newreply.php?do=newreply&noquote=1&p=2726226 and I'm having some problems.

At first I thought it was the dock but now I think it's the PC I built. The dock would only work w/USB 2 ports. When plugged into USB 3, nothing happened at all. When I plugged it into a laptop w/a USB 3 port it worked flawlessly.
The build is:
Win 7 Pro x64
Asrock A75 Pro4-m A75 Motherboard Series Manufacturing - ASRock Inc.
There are 4 USB 3 ports on the back and the dock works w/none of them. NOTHING happens.

My question is; how do I determine whether or not the USB 3 ports are working OK? I have a couple external drives but they are all older and probably USB 2. The ports DO work. Flash drives show up in them.

Edit: as far as I know, all USB drivers are up to date. I got them from the disc that came w/the MB.



My System SpecsSystem Spec
.
22 Mar 2014   #2
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

You need to wipe out your thread and do it over.

And this time tell us what your problem is.
My System SpecsSystem Spec
22 Mar 2014   #3
ChrisPbass

7 Ultimate 64 bit
 
 

Quote   Quote: Originally Posted by AddRAM View Post
You need to wipe out your thread and do it over.

And this time tell us what your problem is.
What do you mean? Delete the other thread? I don't see how to do that. I marked it as solved.

I updated this thread while you were typing, apparently.

Basically - my PC does not see the dock if plugged into a USB 3 port. It sees the dock in USB 2.
My System SpecsSystem Spec
.

25 Mar 2014   #4
ChrisPbass

7 Ultimate 64 bit
 
 

I just copied files from a USB 3 flash drive and the copy speed is less than 20/mb /s which says to me that it's operating at USB 2 speeds. Any ideas?



Attached Images
USB 3 failing - Asrock A75 Pro4-m-usb3.png 
My System SpecsSystem Spec
26 Mar 2014   #5
ChrisPbass

7 Ultimate 64 bit
 
 

I went into the BIOS to make sure USB 3 was enabled.
Under USB 3 there were 4 options and 3 or 4 options for each item. Enable/disable both/disable 3 only/auto.
It was set to auto. I set it enabled.
Rebooted...
NOW the dock/HD shows up when plugged into USB 3 but it is still copying @ 25-30Mb/s which is USB2 speed.
USBdview shows the dock but under 'USB class' it has nothing.
The U3 flash drive shows as U3.
My System SpecsSystem Spec
26 Mar 2014   #6
Computer0304

Windows 7 Professional 32-bit/Windows 8 64-bit/Win7 Pro64-bit
 
 

Is the dock connector USB 3? It may be USB 2. If it is a USB 3, the inside should be blue.
My System SpecsSystem Spec
26 Mar 2014   #7
ChrisPbass

7 Ultimate 64 bit
 
 

Quote   Quote: Originally Posted by Computer0304 View Post
Is the dock connector USB 3? It may be USB 2. If it is a USB 3, the inside should be blue.
It says its 3. On other PCs it connects to USB3. USBdeview shows it as USB3.

The USB3 flash drive only copies @ 25Mb/s. Doesn't that mean the PC is only using USB2?
The dock transfers slowly as well. Def not USB3 speeds.
My System SpecsSystem Spec
26 Mar 2014   #8
Computer0304

Windows 7 Professional 32-bit/Windows 8 64-bit/Win7 Pro64-bit
 
 

The flash drive may be slow. Flash drives aren't that fast in reality.
My System SpecsSystem Spec
26 Mar 2014   #9
Computer0304

Windows 7 Professional 32-bit/Windows 8 64-bit/Win7 Pro64-bit
 
 

Could you post the model of the flash drive so we can check for its actual speeds? Even though its USB3, it is not always USB3 speed.
My System SpecsSystem Spec
26 Mar 2014   #10
ChrisPbass

7 Ultimate 64 bit
 
 

Quote   Quote: Originally Posted by Computer0304 View Post
The flash drive may be slow. Flash drives aren't that fast in reality.
I'm not sure how to confirm that I actually am using USB 3 on this PC. Thoughts?
My System SpecsSystem Spec
Reply

 USB 3 failing - Asrock A75 Pro4-m




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
ASRock has bad boards
I bought an ASRock 990FX Fata1ity Pro board last Novemeber from Newegg, exchanged it for another, and have RMA-ed it 3 times now to ASRock. Og course it is my hardware at fault according to "John" from ASRock. Odd the same symptoms on all 4 different boards. It may be AMD's new 990FX chip set but...
Chillout Room
Asrock RAM Issues
Hello, I had a ram issue which I spent all yesterday finding out the problem and cause. What happens if I put the bigger DDR3 RAM in all slots will detect it but once I put the smaller ddr3 ram in which is same speed and different brand though it wont be recognized in the last two ports. ...
Hardware & Devices
ASRock Z77 EXTREME4-M and ASRock Z77 EXTREME4 difference.
Hello, i'm building budget gaming Pc, and i so decided to get ASRock Z77 EXTREME4-M instead of ASRock Z77 EXTREME4. The ( -M ) version costs 30$ less and that's ALOT in my country. And i just can't seem to find the difference between these two boards, what do you people think about this...
Hardware & Devices
gtx 660 SLI on asrock z77 extreme 4
Little info on asrock z77 extreme 4: Slots: - 2 x PCI Express 3.0 x16 slots (PCIE3: single at x16 (PCIE2) / x8 (PCIE3) or dual at x8/x8 mode) Supports NVIDIA® SLI™ If i run 1 GTX 660 in the main pcie slot and i add another one for SLI, does the processing power or transfer rate of both...
Graphic Cards
ASRock A75 Pro4-M or Asrock B75 Pro3-M?
I used the A75 Pro4-M in my current build, but I'm building another for a friend. I'm not sure if I should go with the same board, or use the B75 Pro3-M this time. It's hard to find any reviews on either of these boards. I like the PCIE spacing on the A75 board, but I'd also like to try the...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 23:51.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App