Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Installed Win 7

29 Oct 2009   #11

Windows7 beta 7000

I got the same message so I installed the Vista64 drivers. The computer doesn't recognize the printer properly but it prints. When the new ones come out I'll update.

Oh, and the stupid HP installation program doesn't work. I downloaded the Vista drivers and when they were in my system files I "add printer" and directed it to the .inf file and it loaded.

My System SpecsSystem Spec
29 Oct 2009   #12


We have a Photosmart C4680 which Win7 autoloaded drivers for as soon as we turned it on. This driver allows us to print normally, and scan by right clicking on printer in Devices & Printers which brings up Windows scan utility.

When trying to install the special software that came with the printer, it failed repeatedly. We decided we didn't need it anyway. Just took the drivers.
My System SpecsSystem Spec
29 Oct 2009   #13
Wii Master 64

Windows 7 Home Premium

I don't have a printer attached to my computer since it's a laptop and I don't have wireless one either. I was just talking in general.
My System SpecsSystem Spec

30 Oct 2009   #14

Windows 7 x64

Quote   Quote: Originally Posted by gregrocker View Post
When trying to install the special software that came with the printer, it failed repeatedly. We decided we didn't need it anyway. Just took the drivers.
I got my old HP scanner software to work using a compatibility mode. Now all the buttons work as normal. You may have to install as admin and maybe compatibility there also, don't remember.
My System SpecsSystem Spec

 Installed Win 7

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Win 7 SP1 Installed, Previously Installed Updates Reappear
I recently installed Windows 7 Service Pack 1 for my Windows 7 Home Premium 32-bit edition. As the installation finished the computer restarted and I did not give it another thought. Later on I returned to the Windows Update screen to see if there were any recent updates available for my PC. To my...
Windows Updates & Activation
installed HD 2600 pro card, installed AMS driver, but no ccc software?
I was wondering if this would help? I see no evidence that the AMD driver installed at all. Right click desktop does not show ccc, and ccc is not in the lower right panel. Windows...
Graphic Cards
9gb Ram installed. 7 Gb shown as installed, 6.1gb available. Windows 8
Hello, Haven't needed help from you guys in a while. I'm even using windows 8 now. Your advice was so good the last time.. I'm back. Ok so I have a brand new kingston 4gb ram chip installed on my ecs p-45-t black series board. It replaced a 1gb chip. My other chips all say 1.8v this new one...
Performance & Maintenance
List of updates required to be installed before SP1 is installed?
Hello, Is there a list of hotfixes that are required to be installed prior to installing SP1? I am trying to slipstream SP1 into an installation DVD for Windows 7. It works fine, however, after I installed my newly created DVD, I found an update that said "You must install this patch before...
Windows Updates & Activation
How do I get my newly installed Hard Drive (1TB) with Win 7 installed
to boot up. Here's my issue I have a HP Desk top w/ a standard 320 GB hard Drive. I bought a new Hard drive (1 TB Western Digital) so that I could move everything to the new one and use the old one as storage. I had trouble even formatting the new drive but eventually got it and successfully...
Backup and Restore
neo basic 2165 - 4gb installed but only shows 3gb installed
hey guys got an issue her thats been like a stubbed toe - just cant let go of it - im using a dual core neo basic 2165 - i just recently upgraded my ram to 4gb 2x - 2gb -ddr2 800 but it just shows 2.75 usable - and only 3gb installed - ive tried every thing so far- still same result-...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:40.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App