Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 upg from Vista - hung on "Starting WIndows"


28 Oct 2009   #1

Vista->7
 
 
Windows 7 upg from Vista - hung on "Starting WIndows"

'lo. (and thanks in advance for reading this long post )

My problem is this one. I started the upgrade process - upgrade advisor didnt foresee any major problems (just some 3rd party programs that wouldnt work - I got rid of them). It gets through pretty much everything up to and including (most - I think) of the "putting your files and settings into the new systemn" - basically completeing the install. At which point it restarts the PC, gets through to the "Starting Windows" screen - and just hangs there for a long time (left it for 15/20 minutes). It's gotten past the stage where it flashes numlcok, capslock etc.

Assuming that a BIOS upgrade doesnt do anything (I realise now I should have done it before), is there any way I can get the installation to complete? So far I've tried options presented on a number of different sites - disabling/removing all unnecceary devices ad the like). I've also tried starting windows in a different mode - and it hangs on any mode except one of the "Safe mode" options which I cant use as they wont let me complete setup (loads the "setup is preparing your computer for first use" graphic ebfore stopping).

One thought I had would be to attempt a repair install as proscribed by this site by booting from the CD - will I run into problems as setup hasnt finished?


My System SpecsSystem Spec
.

28 Oct 2009   #2

Win7 Home Premium x64
 
 

Yes, see if it is remotely possible to perform a repair install. If it will not let you do that, I honestly am not experienced enough to assist you beyond that point.
My System SpecsSystem Spec
28 Oct 2009   #3

7600.20510 x86
 
 

Not really sure because I've never run into problems with upgrades, but when you start your computer normally, is there a choice to revert back to your original OS and rollback?

If so, I'd choose that and get previous OS up and running. Then we can make suggestions on what to do to have highest chance of success of another upgrade attempt.

That being said, you may want to consider a clean install. Your system will appreciate things in general, a lot better and there are perhaps future problems that will be caused from doing upgrade.

I myself have upgraded my machines throughout the beta process dozens of times and never a glitch. So, with this information, it's for you to decide how you'd like to proceed. We could help with either choice.
My System SpecsSystem Spec
.


28 Oct 2009   #4

Vista->7
 
 

No reversion options unfortuneately - will try a couple of more things and get it to generate a bootlog I can look at - might give me some more insight into what is failing.

Cheers
My System SpecsSystem Spec
28 Oct 2009   #5
Microsoft MVP

 

Quote   Quote: Originally Posted by linxus View Post
'lo. (and thanks in advance for reading this long post )

My problem is this one. I started the upgrade process - upgrade advisor didnt foresee any major problems (just some 3rd party programs that wouldnt work - I got rid of them). It gets through pretty much everything up to and including (most - I think) of the "putting your files and settings into the new systemn" - basically completeing the install. At which point it restarts the PC, gets through to the "Starting Windows" screen - and just hangs there for a long time (left it for 15/20 minutes). It's gotten past the stage where it flashes numlcok, capslock etc.

Assuming that a BIOS upgrade doesnt do anything (I realise now I should have done it before), is there any way I can get the installation to complete? So far I've tried options presented on a number of different sites - disabling/removing all unnecceary devices ad the like). I've also tried starting windows in a different mode - and it hangs on any mode except one of the "Safe mode" options which I cant use as they wont let me complete setup (loads the "setup is preparing your computer for first use" graphic ebfore stopping).

One thought I had would be to attempt a repair install as proscribed by this site by booting from the CD - will I run into problems as setup hasnt finished?
Hi Linxus-

What told you that you needed a BIOS update? Have you checked for one?

It should not hurt to try Startup Repair (a "repair install" post Vista is an upgrade over itself from the desktop). Boot into installer>repair my computer and see if it finds an installation (important info), then try Startup Repair and read it's finding from link before trying to restart, then run it again if it won't boot Windows.

the 20 minute pause at Starting Windows screen might not have been long enough to wait, since in-place Upgrades Vista>Windows 7 are all about waiting from what I have read, sometimes hours and hours.

Unless it has given you some other indication, perhaps the only way to resume it now is to try to start it up with Startup Repair. Then after hearing from others on your progress, I would consider the superior install, a Clean Install from boot.
My System SpecsSystem Spec
28 Oct 2009   #6

Vista->7
 
 

No specific program told me I needed a BIOS update (win7upg advisor for instance), just one of thos etips I picked up from reading around - I then lokoed at Gigabytes site for my mobo and turns out there is a newer BIOS version. WIll give it a go with waiting longer - I just thought that the long wait times were inside windows - not in the splash screen...
Cheers
My System SpecsSystem Spec
28 Oct 2009   #7

Vista->7
 
 

Left it overnight and no joy - still stuck. A repair install didn't do anything either - couldn't find any problems.

UPDATE - found this http://support.microsoft.com/kb/927525 - which points to using the recovery console to disable bad drivers - will try it when I get home.
My System SpecsSystem Spec
Reply

 Windows 7 upg from Vista - hung on "Starting WIndows"




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:07 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33