Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Base System Device no driver


28 Oct 2009   #1

Windows 7 Home Premium x64
 
 
Base System Device no driver

Hello all,

I succesfully installed Windows 7 Home Premium x64.

Only one device in devicemanager has no driver, or is not functioning correct.

see picture below:
Base System Device no driver-basesystemdevicenodriver.png

Does someone has a suggestion how to solve this?

Thanks in advance!

zx81




My System SpecsSystem Spec
.

28 Oct 2009   #2

7600.20510 x86
 
 

Wouldn't worry about it and just disable it.

Unless you actually know what it does and want the functionality. In this case, right click it in the device manager, properties, details tab, change dropdown to hardware ids. Copy and paste what you see to here.
My System SpecsSystem Spec
28 Oct 2009   #3

W8 Pro, W7 Ultimate, XP Pro x64, Vista x64, Ubuntu
 
 

My guess is Mobile Broadband card (or empty slot for one), WiFi catcher or smart battery (installing Dell Quickset would take care of the second two). Did you install Dell's chipset drivers? Sometimes they are needed for the magnetic lid-close sensor (for sleep, etc.).
Have you looked these drivers over? Drivers & Downloads
My System SpecsSystem Spec
.


28 Oct 2009   #4

7 Enterprise
 
 

click on details choose the hardware id and cut and paste it into google.

You will figure out what it is that way and then you can find the driver for it
My System SpecsSystem Spec
28 Oct 2009   #5

Windows 7 Ultimate x64 SP1
 
 

Did your laptop come with a SD card reader? If so, did it install? If not, it's probably a Ricoh reader and it'll need drivers from Dell (or from Windows Update, as mine did).
My System SpecsSystem Spec
29 Oct 2009   #6

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by torrentg View Post
Wouldn't worry about it and just disable it.

Unless you actually know what it does and want the functionality. In this case, right click it in the device manager, properties, details tab, change dropdown to hardware ids. Copy and paste what you see to here.
Thank you torrentg,

Here you go:
Base System Device no driver-basesystemdevicenodriverhardwareid.png

I hope this will help installing the correct driver.

Best regards,

Wouter


My System SpecsSystem Spec
29 Oct 2009   #7

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by jrc3 View Post
click on details choose the hardware id and cut and paste it into google.

You will figure out what it is that way and then you can find the driver for it
jrc3,

Thank you for teaching me, I tried to google, but I am not that good in searching, I did not find the answer.

Here you find the windowdump: http://www.sevenforums.com/attachmen...hardwareid.png

Maybe you can find what device it is? ;-)

Thanks in advance,

Best regards,

zx81
My System SpecsSystem Spec
29 Oct 2009   #8

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by jrc3 View Post
click on details choose the hardware id and cut and paste it into google.

You will figure out what it is that way and then you can find the driver for it
Hello jrc3,

I did cut and paste into google, but I think I am a poor searcher, here is the link to my windowdump with the details of the hardware id.

http://www.sevenforums.com/attachmen...hardwareid.png

Have a nice day!

zx81
My System SpecsSystem Spec
29 Oct 2009   #9

Windows 7 Home Premium x64
 
 

When I use Devices And Printers, I see my laptop Icon, this icon has one exlamation mark. When I rightclick the laptop icon, I can choose troubleshoot, and I can choose to apply a fix or skip it.
Base System Device no driver-devices-printers-fix-not.png

I would like to know what happens when I just select Apply this fix, before I do that, I like to know what changes are going to commited on my system.

Hope someone can help me to do the right thing.

Thanks in advance,

zx81


My System SpecsSystem Spec
29 Oct 2009   #10

7 Enterprise
 
 

searching for: "pci\ven_1180&dev_0592&CC_088000 dell inspiron"

came up with this link... as well as other links indicating the other users are right about it being a ricoh card reader.

So I would download this driver:Dell Drivers and Downloads

Double click it and extract it to the c:\dell folder
Then right click on the unknown device and update driver but point it at the dell folder

If its the right driver it will work.
My System SpecsSystem Spec
Reply

 Base System Device no driver




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:19 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33