Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Diskpart "Clean All" Hangs

05 Jul 2014   #1
thejt

Windows 7 Home Premium x64
 
 
Diskpart "Clean All" Hangs

Hello everyone. I've recently received a Lenovo H405 series computer that is completely wiped and only can run BIOS. I have all of the repair disks, the Windows 7 installation disk, along with a disk to install all of the drivers.

I've been unable to fully install Windows 7 thus far after trying 4 times, usually it fails at the installation phase or gives me an error when I try to format my main partition. So I decided to re-wipe the HDD after someone suggested it to me.

So what I did was start up the Windows 7 installation from the disk, opened command prompt at the language screen, and have been waiting about 40 hours. It's a 500GB WD HDD if that helps. Can anyone tell me what's going wrong?


My System SpecsSystem Spec
.
05 Jul 2014   #2
Brink

64-bit Windows 10 Pro
 
 

Hello thejt, and welcome to Seven Forums.

If you like, go ahead and start over, but use the "Clean" command instead of "Clean All" for it to be quicker. Hopefully, it'll successfully finish.

Disk - Clean and Clean All with Diskpart Command
My System SpecsSystem Spec
05 Jul 2014   #3
Ztruker

Windows 10 Pro X64
 
 

Sounds like a defective hard drive.

Check the hard drive with the manufacturer's diagnostic tools.
7 Free Hard Drive Testing Programs
Hard Drive Diagnostics Tools and Utilities (Storage) - TACKtech Corp.
Bootable Hard Drive Diagnostics

If there is a hard drive test built into BIOS, run that and see what it shows.

Dang, you type faster than I do Shawn
My System SpecsSystem Spec
.

05 Jul 2014   #4
Brink

64-bit Windows 10 Pro
 
 

Quote   Quote: Originally Posted by Ztruker View Post
Dang, you type faster than I do Shawn
My System SpecsSystem Spec
05 Jul 2014   #5
thejt

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by Brink View Post
Hello thejt, and welcome to Seven Forums.

If you like, go ahead and start over, but use the "Clean" command instead of "Clean All" for it to be quicker. Hopefully, it'll successfully finish.

Disk - Clean and Clean All with Diskpart Command
Thanks! The clean command worked in seconds. I'll try and start the installation again and see if it solved my problem

Quote   Quote: Originally Posted by Ztruker View Post
Sounds like a defective hard drive.

Check the hard drive with the manufacturer's diagnostic tools.
7 Free Hard Drive Testing Programs
Hard Drive Diagnostics Tools and Utilities (Storage) - TACKtech Corp.
Bootable Hard Drive Diagnostics

If there is a hard drive test built into BIOS, run that and see what it shows.

Dang, you type faster than I do Shawn
I'm worried that it is defective. I'm going to buy a new SATA cable and HDD while they're on sale, just in case.

My BIOS doesn't seem to have a repair tool built-in. I'll see if I can run of the the programs through a USB though.
My System SpecsSystem Spec
05 Jul 2014   #6
Brink

64-bit Windows 10 Pro
 
 

I hope it goes smoothly without issue.
My System SpecsSystem Spec
05 Jul 2014   #7
gregrocker

 

If not after testing HD with maker's HD Diagnostic extended CD scan if it passes work through the steps for Overcoming Windows 7 Installation Failures - Windows 7 Help Forums.
My System SpecsSystem Spec
Reply

 Diskpart "Clean All" Hangs




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
HDD shows in "Device Manager" but not in "DiskPart"or" Disk Management
Hi Guys, any ideas how to access my external hard drive device manager can see it but it does not appear in disc management. I use this HDD perfectly in my car HDD player. But when I try to connect it to my Laptop, it does not show up in disk management. Please check the attached screen...
Hardware & Devices
diskpart script hangs at "select disk"
Hi. most of the machines I deploy have two disks. I am using a diskpart script to clean and format the disks/partitions. Well, I need to be able to deploy onto a machine that only has one disk. Since the "select" command doesn't have the "noerr" option the script fails on the single disk...
Installation & Setup
Can "diskpart clean all" be performed after a "diskpart clean" ?
Hi all, I have an external 2Tb hard disk that's gone bad. It is under warranty so I can return it back. I was trying to wipe it clean and erroneously ran "diskpart clean" instead of "diskpart clean all". Now that all partitions are all gone, my laptop won't recognize it anymore. It shows...
Hardware & Devices
diskpart's "clean all" hangs, no signs of HD activity
I am following the instructions at http://www.sevenforums.com/tutorials/52129-disk-clean-clean-all-diskpart-command.html to erase my entire HD before sending my laptop somewhere. In particular, I am issuing the diskpart command from a "command prompt at boot". I only have one HD on the laptop,...
Performance & Maintenance
got an error at "clean" part of DISKPART
I got this error when trying to format my 4gb Kingston (DT101 G2) please help if you can. DISKPART> clean DiskPart has encountered an error: The request could not be performed because of an I/O device error. See the System Event Log for more information. DISKPART>
Hardware & Devices
Wipe HDD with "diskpart >> clean all"
Hi everyone, I was triying to wipe my HDD with diskpart >> clean all to overcome "Windows could not configure one or more system components" issue which I post to technet forum afew days ago. But I have some concerns about wiping process. Most of the notebooks are being sold with...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:43.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App