Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Partition doesn't show up

30 Oct 2009   #1
d0od

Windows 7 x64 & Ubuntu 9.04 x64
 
 
Partition doesn't show up

Windows 7 has it's own 80gb harddrive but i have another HDD with Ubuntu 9.10 in a 20GB partition and a sharedNTFS in the remaining 130~ GB.

The NTFS partition used to show up in 'My Computer' fine, but after re-installing Ubuntu 9.10 it doesn't. (NO i have not erased the entire disc as i can still access it in Ubuntu and it has all my files etc on)

Any ideas on how to get it to show up? it's even missing from the disc manager.


My System SpecsSystem Spec
.
30 Oct 2009   #2
torrentg

7600.20510 x86
 
 

Linux uses a different file system other than Windows' standard of NTFS. Linux uses ext2, ext3.

This normally can not work with Windows. It's been a long time for me since I played around with Unix based OSes, but there may be some kind of patch or software you can run to help you mount the Linux partition from within Windows. Google is a good resource to find what you need, if it exists.

Good luck and let us know if this helped.

Edit: I found this. Seems promising. http://www.howtoforge.com/access-lin...s-from-windows

Try the third option.
My System SpecsSystem Spec
31 Oct 2009   #3
d0od

Windows 7 x64 & Ubuntu 9.04 x64
 
 

Thank for the reply but i obviously didn't word my original post very clearly.

It is an NTFS (Windows filesystem format) that dosn't show up in Windows, but does in Ubuntu. All my files etc are still on it and it hasn't changed size or anything it simply had Ubuntu installed next to it.

I don't want/need to mount my EXT4 partition, i want my "missing" NTFS partition to show up.
My System SpecsSystem Spec
.

31 Oct 2009   #4
Minotar

Windows 7 Ultimate 64bit
 
 

Can you create a shortcut for it yourself?
I.e D:\ as the path? (obviously you change the letter to the one you want)
My System SpecsSystem Spec
31 Oct 2009   #5
Barman58

Windows 10 Pro x64 x2 Windows 10 Enterprise x64, Ubuntu
 
 

If you check the Disk management in windows 7 (right click on computer - manage), and make sure windows has a drive letter assigned to the partition - this is the major cause of missing partitions
My System SpecsSystem Spec
31 Oct 2009   #6
d0od

Windows 7 x64 & Ubuntu 9.04 x64
 
 

Quote   Quote: Originally Posted by Barman58 View Post
If you check the Disk management in windows 7 (right click on computer - manage), and make sure windows has a drive letter assigned to the partition - this is the major cause of missing partitions
I forgot to say in the original post that it doesn't show up in the Disc manager. The disc as a whole does show up in device manager so it's not a dodgy SATA cable
My System SpecsSystem Spec
31 Oct 2009   #7
torrentg

7600.20510 x86
 
 

Can you please post a screenshot of this? We'll figure something out.
My System SpecsSystem Spec
31 Oct 2009   #8
ba5ik

Windows 7 Ultimate x64 RTM
 
 

use gparted to migrate your ubuntu install to 20GB behind the shared ntfs.

Thus hd0 win7(80GB)/ hd1 sharedntfs(130GB)>ubuntu(20GB)
My System SpecsSystem Spec
08 Feb 2010   #9
heepie

ubuntu 9.10 and windows 7 Ultimate
 
 

i'm having the same problem... The device manager says the drive is working properly but windows explorer is not showing the partition.

I also tried to go to computer managament > storage > disk managament and try to activate the partition or give it a new letter but is not letting me do anything a part from deleting the partition itself, which i don't wanna do!!!!

I'm giving the link of the picture of the disk managament to make things a bit more clear... There's 3 hard drive in total, 2 of them are ext 4 (partition from ubuntu) but the last one where i have windows 7 install, all the partition are ntfs...

I also tried diskpart > list volumes but obviously the drive wasn't there...

Any more ideas... In linux i quite easy to mount a partition manually i just can't find a way to do it in windows

http://i106.photobucket.com/albums/m.../partition.png
My System SpecsSystem Spec
Reply

 Partition doesn't show up




Thread Tools





Similar help and support threads
Thread Forum
Why does Partition Wizard show a GPT (Reserved Partition) ?
I just got my first 3TB (> 2TB) HD. I initialized it as a GPT Disk in Windows Disk Management (DM). I created the partition in MiniTool Partition Wizard (PW). Seeing a difference in DM and PW, I cleaned the disk and then re-initialized and created the partition in DM. If the partition is...
Hardware & Devices
PC doesn't show anything
Hello all, I'm working on a machine that doesn't start up. It just beeps, three times, and restarts repeatedly but doesn't show anything on screen. I opened the case and found that the model of mobo is "msi h61m-e23 (b3)". The installed operating system in 7 but it even doesn't show the mobo's...
Hardware & Devices
Mystery Partition In My Computer Doesn ' t Show Up In Disk Management
i recently got an used hp envy 14 currently running x64 home premium . since it ' s limiited edition , i dont know the full specs . i was told the HDD was over 700 GB . when i added up the total space , it was not over 600 GB usable . now i ' m seeing a partition in computer with label Q: which i...
Hardware & Devices
Partition Table doesn't have valid System Partition
Few days back did a Win 7 Pro OEM clean install on a home built PC. Looked great. Installed chipset drivers. Set up my drives and volumes using disk management. Shutdown and on a cold start next AM Win 7 won't boot. Last line on BIOS screen says "boot mgr missing". Drat!! Booted to Win 7 install...
Installation & Setup
Secondary partition created doesn't show under My Comp
OK, my problem is the following: When I was installing Windows 7 I partitioned my hard drive into two parts. The first one I allocated 20GB of free space for Windows to use. The second one I crated, was allocated 230 something GB for music, software, etc. The problem is that when I started my...
Installation & Setup
HD doesn't show up
Hello everyone, I just installed W7 and everything so far seems to be working fine but for some reason I can't access my second HD. I have my main; a 250gb SATA divided into 2 partitions, 1 for Vista and the other for Windows 7. The second drive is a 160gb ATA (PATA) drive and it doesn't even...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:58.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App