Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Trying to do a clean install of OS on new SSD, but having problems

07 Mar 2015   #1
Lonelylunar

Windows 7 Professional x64
 
 
Trying to do a clean install of OS on new SSD, but having problems

HI, I'm trying to do a clean install of windows 7 Pro x64 on a new SSD I bought but I'm having a persistent problem no matter what I try or what steps I use to try and fix the problem. I'm using a disk copy for the install (if it matters) and I get to the screen where it asks where I want to install the OS, I pick my SSD, then I click ADVANCED, then NEW, I select the partition size and format. But I get the same error message every time which is "Setup was unable to create a new system partition or locate and existing system partition. See the Setup log files for more information".

If anyone can help me I would greatly appreciate it, I've been stuck on this problem for about a week now and it's drastically increasing my stress levels.


My System SpecsSystem Spec
.
07 Mar 2015   #2
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

Sounds like the ssd was setup up as gpt, convert it to mbr.

Convert GPT Disk to MBR Disk

If you have a UEFI bios and want to install using the GPT partition style, you`ll have to setup the installer that way.

I don`t use that, I always set the bios to legacy boot and disable UEFI if it has it, and install to a MBR partition.
My System SpecsSystem Spec
07 Mar 2015   #3
Lonelylunar

Windows 7 Professional x64
 
 

AddRAM, I followed the steps in the link and converted to mbr through the the command prompt, when I got to the "where do you want the OS" page of the installer I clicked ADVANCED, then NEW to partition the drive, I then formatted. But I still get the same error as before "Setup was unable to create a new system partition or locate and existing system partition. See the Setup log files for more information".

What should I do now?
My System SpecsSystem Spec
.

07 Mar 2015   #4
gregrocker

 

Work through the steps to Troubleshoot Windows 7 Installation Failures reporting back results.
My System SpecsSystem Spec
11 Mar 2015   #5
Lonelylunar

Windows 7 Professional x64
 
 

Okay, after going through the steps you gave me at least 5 times and fiddling around with bios options I finally got windows to install on to the SSD (woot), but I now have another problem (it never ends).

I now have windows installed onto my SSD and so far everything works just fine, but now my SSD is the only drive that shows up. other than the SSD I also have a 2 tb HDD, bios says its there and boot says its there but when on the desktop and go into "my computer" it doesn't show up.

How do I fix it?
My System SpecsSystem Spec
11 Mar 2015   #6
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Can you post a picture of your disk management please.
My System SpecsSystem Spec
11 Mar 2015   #7
gregrocker

 

Likely need to add a Drive Letter in Disk Mgmt: Drive Letter - Add, Change, or Remove in Windows 7 - Windows 7 Forums
My System SpecsSystem Spec
12 Mar 2015   #8
Chris2005

Windows 10 Home x64
 
 

I've had that disk missing issue before, as gregrocker said, you probably need to assign drive letters to them, and they should appear, did for me anyway, lol.
My System SpecsSystem Spec
12 Mar 2015   #9
Lonelylunar

Windows 7 Professional x64
 
 

okay the issue was a little different than just assigning the drive a letter, but I figured it out and fixed the problem and everything runs great so far. The problem was that the disk showed up as foreign so I couldn't access it, what fixed it was right clicking the disk and clicking the option to "import foreign disks".

I really appreciate all of the help you guys have given me with this, thanks you.
My System SpecsSystem Spec
12 Mar 2015   #10
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Hmm, has anybody ever heard of a "foreign disk" ?
My System SpecsSystem Spec
Reply

 Trying to do a clean install of OS on new SSD, but having problems




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Did a clean install of Windows 7 64 bit - problems with everything
Sorry for the vague title but pretty close to everything is not working properly... Ok, I got a new CPU and motherboard, and did a clean install of windows 7 ultimate onto a formatted hard drive. Installing drivers afterwards has proven very difficult (it frequently says the program is corrupt...
Installation & Setup
Problems after a clean windows 7 install
Yesterday I performed a clean windows 7 install on my fathers HP pavillion desktop PC. It had originally vista. During installing the screen became black, but when I unplugged the HDMI cabel which is for the LCD TV, the black screen dissapeared and the install could be completed. If I plug in the...
Installation & Setup
Windows 7 Clean Install Problems
I recently built my own computer, got everything setup and plugged it in and it displayed the motherboard page right away and no problems. When I go to start to install windows 7 (home premium 64 bit) the computer randomly freezes and i'm not able to install windows 7, I have some people helping...
Installation & Setup
Clean install problems with Windows 7
I did a clean install of windows 7 to a new western digital HDD and I when I start up my desktop without the win 7 CD in the disk drive, I get a BOOTMGR missing error. But i can load windows 7 with the bootable cd in the disk drive. So i reformatted the HDD and tried a second clean install and same...
Installation & Setup
problems with vista x86 to 7 x64 clean install
Hi I've been trying to upgrade my parents computer from vista x86 home premium to windows 7 x64 with a clean install. Everytime i go to boot the computer with my 7 installation disk, it begins to load files, then windows boot manager starts saying their is a problem with driver...
Installation & Setup
Clean Install Problems
Hi, I'm hoping someone here has an answer for me. I've probed through the forums but I can't locate a similar problem. Here is my problem. I'm trying to install the latest Windows 7 RC 64-bit downloaded from MS but keep getting a BSOD. This is a clean install. All drives have been...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:27.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App