Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Setup can't create system partition

07 Mar 2015   #1
Auxiliary

Windows 7 x64, windows 8.1 x64
 
 
Setup can't create system partition

Hello everyone,

A few days ago i decided on completely reinstalling everything on my computer, but as you can see in the title, i have a problem within the installation of Windows 7. Everytime i try to install it from my USB Flash Drive, i manage to get as far to select wether to upgrade or custom. I pick custom, as all old files have been wiped, but upon selecting my drive to install it on, it gives the error of not being able to create a system partition, and is unable to find an existing one. This happens both when ive created a new partition and formatted it, and when i leave the drive on unallocated space(preffered method)

All other hard drives have been unplugged, and im installing from an USB 3.0 flash drive in a 2.0 port, and all excessive USB devices have been pulled as well.

Ive tried using a method through diskpart, but that failed.

Quote:
DiskPart <ENTER>
list disk <ENTER>
select disk 0 <ENTER>
clean <ENTER>
create partition primary align=1024 <ENTER>
format fs=ntfs <ENTER> (Will Take a While)
assign <ENTER>
active <ENTER>
exit <ENTER>
exit <ENTER>



My System SpecsSystem Spec
.
07 Mar 2015   #2
gregrocker

 

Work through these steps to Troubleshoot Windows 7 Installation Failures - Windows 7 Help Forums

Once it gets going then look over the steps to get and keep a perfect Clean Reinstall Windows 7.
My System SpecsSystem Spec
07 Mar 2015   #3
Auxiliary

Windows 7 x64, windows 8.1 x64
 
 

Thanks for the help, but sadly, the error still remains. It still fails to create or find an existing system partition
My System SpecsSystem Spec
.

07 Mar 2015   #4
gregrocker

 

Then where do you get the error when running the Diskpart commands? Be specific.

Next test the hard drive with the maker's HD Diagnostic
extended CD scan to know for certain its condition.
My System SpecsSystem Spec
07 Mar 2015   #5
Auxiliary

Windows 7 x64, windows 8.1 x64
 
 

No no, the diskpart commands are all working, but upon reinstalling windows it fails, where you have to select where to install it.

*edit: i had already scanned with HDtune pro, and the device is looking fine, nothing out of the ordinary
My System SpecsSystem Spec
07 Mar 2015   #6
gregrocker

 

How did you determine if you have a UEFI BIOS or not? Is there a boot choice for UEFI when you boot flash stick?

How did you create the flash stick and what was the source of the ISO. Confirm the ISO and try writing a new stick from Step 1 of Clean Reinstall Windows 7
My System SpecsSystem Spec
07 Mar 2015   #7
Auxiliary

Windows 7 x64, windows 8.1 x64
 
 

Motherboards manufacturer page, Motherboards - F1A55-M - ASUS
It states it has UEFI BIOS, no choice to boot as UEFI however, upon hitting f8 (boot location select) it just prompts for location.

I created the USB using the recommended program rufus on here, as for the .ISO, i cant remember. theyre long standing .ISO's i havent had problems with before.
My System SpecsSystem Spec
07 Mar 2015   #8
gregrocker

 

Then this is where the problem lies.

Boot the stick using the one-time BIOS Boot menu key. Is there a choice for UEFI flash stick? If not then the stick is not formatted correctly or the BIOS settings are awry.

Boot into BIOS setup to report back all settings choices for UEFI, CSM, Legacy BIOS, BIOS Boot Priority order.

Confirm that the stick maintained the settings in Option One of UEFI Bootable USB Flash Drive - Create in Windows
after you added the ISO, since these can jump around then.
My System SpecsSystem Spec
07 Mar 2015   #9
Auxiliary

Windows 7 x64, windows 8.1 x64
 
 

i noticed the settings jump when selecting an ISO in rufus, and i accounted for that.
As for the BIOS settings, i can only give you the boot order, as i cant find the other settings. (probably there, but i dont see them)
boot option priorities: (listed as named in BIOS)
1. P5: WDC WD5000AAKX-003CAO (my HDD)
2. P4: TSSTcorp CDDVDW SH-222BB (Optical drive)
3. Disabled
My System SpecsSystem Spec
07 Mar 2015   #10
gregrocker

 

You have a UEFI BIOS but see no choices on any BIOS tab (usually Advanced, Boot and Security tabs) for UEFI, CSM, Compatiblity Module, Legacy BIOS? How about on Security tab for Secure Boot?

If the flash stick is plugged in at the time then it should show up in the boot order, and be listed as UEFI Flash stick providing it's formatted correctly and UEFI is enabled in BIOS setup.

Try plugging it in if not and check in BIOS Boot order AND one time BIOS Boot menu key.
My System SpecsSystem Spec
Reply

 Setup can't create system partition




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Setup was unable to create a new system partition (NEW SSD)
Hello I'm trying to install a fresh copy of Windows 7 onto my brand new Kingston HyperX 240GB SSD. I keep getting the same error "Setup was unable to create a new system partition or locate an existing system partition. See the Setup log files for more information". I am trying to install...
Installation & Setup
Setup was unable to create a new system partition...
So I bought a new SSD drive and tried installing windows 7 ultimate x64 on it. Before that I had a samsung baracuda HDD drive and reinstalled windows 7 on it a couple of times. Now when i try to install windows 7 on any of the drives i get the same error all over again. Tried creating a partition...
Installation & Setup
Setup was unable to create a new system partition
Hello all! I have installed windows countless times and this is the first time I have ever run into this problem. Yes, I have read countless forums on this; however, none of them help at all. I unplugged all USB devices etc. Being that this is the first time something like this has happened,...
Installation & Setup
setup was unable to create a new system partition.
HI, Yesterday i want to install windows 7 on my laptop but when i format Local disk C and click next it says setup was unable to create a new system partition. I boot through Pen Drive. I dont have a dvd rw(not working) and i have Data on other drives... please tell me solution..without wiping...
Installation & Setup
Setup was unable to create a new system partition - I can not create p
Hello guys,'ve looked for everything that google and not found my solution. Is giving the following error when trying to install windows 7 in HD: "setup was unable to create a new system partition or locate an existing system partition" I've tried to do some procedures, but also can not...
Installation & Setup
Setup was unable to create a new system partition
This is a fresh Windows 7 install on a 500GB HDD (previously used under XP) In the BIOS the Storage is configured as: Raid. Obviously I have the right raid ICH10R drivers from Asus (they are on a USB drive) Installation starts, Windows sees the disk, I specify the drivers, BUT when I click Next,...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:06.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App